Subject: AD to zeroconf WG

From: Thomas Narten <[email-masked]>
Date: Wed, 22 Jan 2003 09:44:03 -0500

AD hat on.

This WG has been going around in circles for months, having many
yes/no much-heat-little-light rathole discussions. In particular:

Alex Karahalios <[email-masked]> writes:

> P.S. I would participate in these discussion more, but I am already 
> several months behind in my development work. I was hoping that these 
> v4LL issues would have blown over by now. I guess this IETF 
> standardization is a slow process. The good news is that nothing has 
> changed in the draft in the last 4 months that would require my 
> changing any of my code.

This says it all. There are a number of outstanding issues with the LL
document, including specific IESG comments. My belief is that none of
these issues are show-stoppers. However, rather than try to address
those issues, and despite attempts by the chairs to get closure on
specific text, the WG fails to respond or participate, chosing instead
to rathole and discuss things that are not directly related to getting
closure on the documents.

If folks are unwilling to focus on the open isssues and actually try
to resolve them (which means talking about specific document text
changes), the document will never get finished. That's a shame, as the
document is 98% there and contains useful stuff. If the WG isn't
willing to focus getting the LL document finished, I suspect it's time
to just give up and close the WG.

Surely, many of you are aware of discussions on the overall
(in)effectiveness of the IETF on, e.g., the problem-statement
list. This WG is a prime example of a WG that is not working, and
hasn't been working for a long time. There are lots of reasons for
that, but its probably not productive to discuss them here. 

Shall we try to complete the tasks at hand, or should we just give up?

PS, actions speak louder then words. The best response would be to
particpate in coming to closure.

Thomas

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 Jan 2003 10:53:00 -0500

On Wed, 22 Jan 2003 09:44:03 -0500
Thomas Narten <[email-masked]> wrote:

> yes/no much-heat-little-light rathole discussions. 

What has finally become clear from these discussions is that the WG has been suffering for a long time from a fundamental dissonance between

- those wanting a mechanism to allow ad hoc networks to function, 
- those wanting a mechanism to allow automatic configuration of devices in connected networks,
- those wanting a low-overhead mechanism to allow automatic configuration of fixed-function IP-capable devices, and
- those wanting to promote the idea that some devices should have access limited to the local link

LL, as currently designed, only addresses the first goal, but it doesn't play well on connected networks.   It appears that it can be modified with little difficulty to allow it to address the first three goals.  The discussion for the last few days has been productive at exploring the technical details of how to do this.  And the last item is not a desirable goal.

-- 
I tried enlightenment but it kept crashing.

---

From: "John C. Welch" <[email-masked]>
Date: Wed, 22 Jan 2003 11:11:11 -0500

On 01/22/2003 10:53, "Keith Moore" <[email-masked]> wrote:

> LL, as currently designed, only addresses the first goal, but it doesn't play
> well on connected networks.   It appears that it can be modified with little
> difficulty to allow it to address the first three goals.  The discussion for
> the last few days has been productive at exploring the technical details of
> how to do this.  And the last item is not a desirable goal.

It would be in a hospital so that you could connect things like EKGs and
other monitoring devices to things like palm pilots, or multiple monitoring
stations. You would, in that case, want to make it as hard as possible for
that type of data to get out on the public Internet. Law Enforcement would
benefit from this as well.

john

-- 
John C. Welch
Consultant III
Administrative Computing
(617) 253 - 1368 work
(508) 579 - 7380 cell
bynkii2          AIM