Subject: RE: On Killing IPv4LL on the Link

From: "Christian Huitema" <[email-masked]>
Date: Wed, 22 Jan 2003 13:38:42 -0800

> What is wrong with a "device" acquiring both a v4LL address and an
> address via DHCP? By "device" I mean something that has a controlled
> set of applications which know how to handle both addresses. This
makes
> the implementation much easier since the network stack or application
> does not have to deal with the LL address no longer being valid when a
> DHCP address is acquired.

What would be wrong would be to force systems that already have a DHCP
address to also acquire a more ambiguous, scoped address. 

-- Christian Huitema

---

From: Alex Karahalios <[email-masked]>
Date: Wed, 22 Jan 2003 14:56:45 -0700

Hi Christian,

I am not advocating on "forced" use of LL. If a device wants to use 
both, it should not be precluded.

Alex Karahalios.

---

From: "John C. Welch" <[email-masked]>
Date: Wed, 22 Jan 2003 17:14:16 -0500

> address to also acquire a more ambiguous, scoped address.

Unless of course, you happen to need it. There needs to be both ways.

john

-- 
John C. Welch
Consultant III
Administrative Computing
(617) 253 - 1368 work
(508) 579 - 7380 cell
bynkii2          AIM

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 Jan 2003 18:24:38 -0500

> > What would be wrong would be to force systems that already have a
> > DHCP address to also acquire a more ambiguous, scoped address.
> > 
> 
> Unless of course, you happen to need it. 

but you don't.  there is no situation where you need both v4LL and a
routable address on the same interface.

-- 
I tried enlightenment but it kept crashing.

---

From: "John C. Welch" <[email-masked]>
Date: Wed, 22 Jan 2003 18:47:03 -0500

> routable address on the same interface.

You can't guarantee that unless you got the clairvoyance upgrade.

john

-- 
John C. Welch
Consultant III
Administrative Computing
(617) 253 - 1368 work
(508) 579 - 7380 cell
bynkii2          AIM

---

From: Aidan Williams <[email-masked]>
Date: Thu, 23 Jan 2003 11:53:33 +1100

> both, it should not be precluded.

I take this to be a "manual configuration" case.
Possibly "manually pre-configured".

If you want to make a device that has been explicitly configured
to do this, and you can make it work because your device has a
suitably constrained set of applications, go for it.

- aidan