Subject: ZeroConf req v6

From: [email-masked]
Date: Mon, 11 Dec 2000 14:55:26 +0100

Dear Stuart,

Thank you for your very quick answer.

You mention that work on this specific document is complete.
Does that mean that work on version 6 is complete or work
on the requirements is complete?

I understand that boxes are necessary to connect two or more links together.
It is nice to know that work in this direction has been done already.
I understand that the work of the group is on requirements. I think that the
addition of a DHCP server in such a box is not really an issue for the requirements.

We, at philips research, are worried that a DHCP server may become a necessity in zeroconf networks.
Without a DHCP server  two or more links can be interconnected at relatively low costs. 
Also we are afraid that the presence of a DHCP server needs setting up of the server by the user.
Therefore we encourage the requirements to be formulated such that a DHCP server is not needed.

We hope that the requirement on the connection box is such that the addressing of hosts
on connected links is defined unambiguously. I tried to
make clear with my additions that adressing through a router is different 
from addressing through a bridge. Also dependent on
router or bridge functionality a different set of addresses of the hosts can be
expected at the moment the bridge(router) is connected or disconnected.

Further I understand that the ZeroConf group looks at the survivability of a network
when it is not connected to the outside world. I think that also involves requirements
on the network behaviour when a link to the oustside world is inserted or removed.

We think that "in home networks" will be confronted by frequent and multiple
connections and disconnecteions to the outside world. For example, this follows from many
scenarios that involve access to the home from a mobile phone or access from the
home to a movie distributor or a game provider.

I hope I made my point of view clear and also showed the importance of the issues
I try to address in the context of home networks.

Unfortunately, I will not be at the WG meeting this week. If you think it worthwhile
that my concerns are discussed more extensively with one or more WG members, I will be pleased
to do so.

Greetings

peter van der Stok

Peter van der Stok                Philips Research Laboratories Eindhoven
Bldg: WL P 311                      Prof. Holstlaan 4
Phone: +31 40 2742649       5656 AA Eindhoven
Fax:       +31 40 274                The Netherlands
Mailto: Peter.van.der.Stok@ philips.com

---

From: Erik Guttman Sun Frankfurt Staff Engineer <[email-masked]>
Date: Mon, 11 Dec 2000 22:11:32 +0-100

>on the requirements is complete?

The requirements document is complete - it has gone through
WG last call.  The only comments we are considering now are
those which the WG agreed to in the last call period or where
someone discovers something which is terribly wrong with the
document.  It is only by adopting such processes that the IETF
can make progress with documents and complete its work.

>addition of a DHCP server in such a box is not really an issue for the

Please feel free to comment on and submit individual contribution
internet drafts on this topic.  Others have done so - see 

draft-zeroconf-<author names>

Comments on these documents are also welcome on this mailing list.
The WG charter currently does not include any goals for coordinating
what some have called 'mini-DHCP servers'.  This could change in the
future, but we would need to have a lot of discussion and arrive at
a broad agreement in the WG on goals and issues before broadening
our charter.

Erik