Subject: ZeroConf Req. version 6

From: [email-masked]
Date: Tue, 5 Dec 2000 15:11:49 +0100

Dear all,

I have the pleasure to react to the 6th version of the zeroconf requirements.
My background is home networking for consumer devices. Below I first 
give some motivation for the suggestions that follow afterwards.

Motivation.

It is expected that home networks will be composed of several links provided by different manufacturers. 
It will not be uncommon that an IEEE 1394  local link is connected to HiperLAN or HomeRF.
Nevertheless the user of the home network sees his set of interconnected devices as one network.
This is made clear in the present requirements of the ZeroConf WG.

The home will be connected to the outside world via broadcast media, telephone connections or
other internet providers.
The configuration inside the home should not unnecessarily propagate to the outside world.
Vice versa, the connection or disconnection of the home to the outside world should not perturb current
connections. Such a (dis)connections may mean that part of the devices in the home  frequently
change between managed addressing and unmanaged addressing. A change in addressing involves that a 
given host can be known with different addresses to different communication partners.

It should be absolutely certain that two boxes from different suppliers conform to
the same behaviour. Therefore, the possible configurations should be minimised.
For example: According to the IP standard two subnets can coexist on one link-local network.
This can give rise to different behaviours dependent on the interpretation of the
implementor of the standard. Therefore I recommend to restrict the number of
possible configurations and states as much as possible and to restrict a home network to
one IP subnet.

________________________________________________________________________________________________-

Suggestions:

page 3 section 1.5

I understand the term "broadcast" to mean "broadcast provided by the physical medium"

Modify a requirements:
- protocols intended to span at least one IP subnet should not use broadcasts 
or link-local addressing

Add a requirement:

Requirement;
- A ZeroConf protocol spans at least one IP subnet.
- A ZeroConf protocol can modify or add the addressses of hosts that are connected to at most one subnet

Section 2.1 

after the "terms" part,  add the following requirements:

Requirement:
- Two hosts are situated on different subnets if and only if all paths between them 
pass through a router.
- Two hosts are situated on the same subnet if there is a path over the same link, or a
path via one or more bridges without routers.

Section 2.1.2

Definition:
- Two hosts are connected if and only if there is a path between them.
- A communication between two hosts is perturbed if the requirements on the connection
 are not met.

Requirement:
- The installation or removal of a bridge or router does not perturb
the communication between hosts that are connected before and after the topology change.

Requirement:
- A host can support one or more IP addressses on the same network interface.

___________________________________________________________________________________________

Peter van der Stok                Philips Research Laboratories Eindhoven
Bldg: WL P 311                      Prof. Holstlaan 4
Phone: +31 40 2742649       5656 AA Eindhoven
Fax:       +31 40 274                The Netherlands
Mailto: Peter.van.der.Stok@ philips.com

---

From: Stuart Cheshire <[email-masked]>
Date: Fri, 8 Dec 2000 20:13:53 -0800

>Dear all,
>
>I have the pleasure to react to the 6th version of the zeroconf
>requirements. My background is home networking for consumer devices.
>Below I first give some motivation for the suggestions that follow
>afterwards.

Thanks for your comments.

While the work of the working group goes on, and any constructive 
discussion is still welcome, work on this *specific* document is 
complete, and it is only in the most extreme circumstances that further 
changes would be considered.

>It is expected that home networks will be composed of several links
>provided by different manufacturers. It will not be uncommon that an
>IEEE 1394  local link is connected to HiperLAN or HomeRF. Nevertheless
>the user of the home network sees his set of interconnected devices as
>one network. This is made clear in the present requirements of the
>ZeroConf WG.

Where there are multiple link technologies, there must be some box to 
connect those links together. Such boxes exist today -- one example I 
know well is the Apple AirPort base station, which includes an IP router 
to forward packets, and a DHCP server to configure clients. While 
zeroconf considers this case, the focus is on making IP work on networks 
where there is *no* supporting infrastructure.

>The home will be connected to the outside world

This is not the focus of the working group. While the home *might* be 
connected to the outside world, the focus of the working group is 
ensuring that IP continues to work even when the home network is not 
connected to the outside world.

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer
 * Chairman, IETF ZEROCONF
 * www.stuartcheshire.org