Subject: Configuring devices without consoles

From: "Charles Larson" <[email-masked]>
Date: Mon, 25 Sep 2000 16:52:09 -0700

I have a problem which it seems this group partially addresses.  I would like some comments on whether the topic should be considered here or elsewhere.  Or some pointers if anybody is aware of a solution.

We build industrial instrumentation which has an ethernet port.  The device may or may not have a console.  In the commercial world, I suppose this would apply to a network printer.  I want to be able to configure that device, possibly with a static IP address, possibly for DHCP without needing a console.  In other words I want to configure it over the ethernet.  The trouble is that if it is unconfigured or configured incorrectly, I cant talk to it.

I seems to me that the zero configuration protocol solves this or could solve it.  Once the device has configured itself using zeroconfig, we can communicate with it to set its regular internet configuration parameters.

It seems to me that there are some considerations which are necessary in the zeroconfig protocol to insure that it can be used for this.  Locating the devices would be part of the problem.  But I think that is just service location, which is already considered.  I suppose actually configuring the device is outside of the scope of this group.

Comments?

Thanks,
Charles Larson.

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 26 Sep 2000 09:58:18 -0400

Charles,

	Email to IETF lists should be sent as MIME text/plain
and using a standard character set (e.g. US-ASCII, ISO-8859-1).

	Your note was using some fancy format that is 
not readable using all mail readers.  Please resend
as text/plain and in a standard character set.

	My guess is that you use MS-Outlook, which seems to
be the main source of this kind of problem.  I don't use
Outlook, so can't help with how to configure it to use
normal email formats for outgoing mail, sorry.

Thanks,

Ran

---

From: Erik Guttman <[email-masked]>
Date: Thu, 28 Sep 2000 17:14:13 +0200 (MET DST)

> We build industrial instrumentation which has an ethernet port.  The device
> may or may not have a console.  In the commercial world, I suppose this
> would apply to a network printer.  I want to be able to configure that
> device, possibly with a static IP address, possibly for DHCP without needing
> a console.  In other words I want to configure it over the ethernet.  The
> trouble is that if it is unconfigured or configured incorrectly, I cant talk
> to it.
> 
> I seems to me that the zero configuration protocol solves this or could
> solve it.  Once the device has configured itself using zeroconfig, we can
> communicate with it to set its regular internet configuration parameters.

Yes.  Automatic IP address configuration would supply the device with
an address and Service Discovery would enable the device to be discovered
by your configuration management application.

> It seems to me that there are some considerations which are necessary in the
> zeroconfig protocol to insure that it can be used for this.  Locating the
> devices would be part of the problem.  But I think that is just service
> location, which is already considered.  I suppose actually configuring the
> device is outside of the scope of this group.

Device configuration protocols which are not peer to peer are by
their nature outside of the scope of the Zero Configuration Working
group.  You should consider work going on in the DHC and SNMPCONF 
for example, which are focussed on these issues.

Erik