Subject: zc = no server?

From: "Hattig, Myron" <[email-masked]>
Date: Tue, 8 Aug 2000 16:10:19 -0700

> The highest impact issues effect the direction of document,
> and could fundamentally change the focus of the working group.
> 
>  1. The definition of a zeroconf protocol is too narrow.  We need
>     to broaden it.
>
>     I contend that a zeroconf protocol requires no external 
> configuration,
>     be it from burned in defaults, user configuration or via 
> a network 
>     based configuration protocol (like DHCP).  That is not to 
> say a host
>     can't use these mechanisms to become configured, but in 
> that case, the
>     host is not using a zeroconf protocol to obtain its configuration
>     parameters.

After struggling with this for a long time, my conclusion is that the
existents of a server isn't the issue. The issue is USER configuration. In
other words, ease of use for the user is the only concern. The server may
exist but if the user doesn't see it, it doesn't matter.

-myron

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 8 Aug 2000 16:22:52 -0700

Hy Mryon,

I disagree completely.  All this 'gray area' is the problem
with all previous definitions of ZC.  The IETF ADs are unlikely
to accept word-smithing that allows ZC clients to be 'a little
bit pregnant...'.

I think Erik's got it just right - ZC means ABSOLUTELY no
external configuration, *in particular* no fetching from
routers, service repositories, etc.

My two cents,
- Ira McDonald, consulting architect at Xerox and Sharp
  High North Inc

-----Original Message-----
From: Hattig, Myron [mailto:[email-masked]]
Sent: Tuesday, August 08, 2000 4:10 PM
To: [email-masked]
Subject: zc = no server?

-myron