Subject: Use EUI-64 in ZRIP?

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 25 Aug 2000 12:49:27 -0700

Copies: Cuneyt Akinlar <[email-masked]>
        Ira McDonald <[email-masked]>

Hi,                                              Friday (25 August 2000)

A comment on ZRIP <draft-akinlar-zeroconf-zrip-00.txt> (15 August).

On page 5, you suggest creating a UID by contatenating an Ethernet MAC
address (6 octets) with two octets of 0's.

The IPv6 Addressing Architecture (RFC 2373, July 1998) requires the use
of the normal form EUI-64 for generating IPv6 addresses for interfaces
with 48-bit IEEE MAC hardware addresses.  I would suggest following that
lead in your spec.  The EUI-64 discussion is in Appendix A 'Creating
EUI-64 based Interface Identifiers' of RFC 2373.  The normative IEEE
reference is:

[EUI64]   IEEE, "Guidelines for 64-bit Global Identifier (EUI-64)
          Registration Authority",
          http://standards.ieee.org/db/oui/tutorials/EUI64.html,
          March 1997.

Good spec - it seems a straightforward extension of RIPv2 for Zeroconf.

Cheers,
- Ira McDonald, consulting architect at Xerox and Sharp
  High North Inc

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 28 Aug 2000 09:46:28 -0700

Hi Peter,

http://standards.ieee.org/regauth/oui/tutorials/EUI64.html

Sorry - the original URL was copied verbatim from the
references in RFC 2373 (IPv6 Addressing Architecture).
I just searched the IEEE site and found the above (valid)
URL.

Cheers,

-----Original Message-----
From: Peter Johansson [mailto:[email-masked]]
Sent: Friday, August 25, 2000 12:53 PM
To: Zero Configuration
Subject: Re: Use EUI-64 in ZRIP?

At 12:49 PM 8/25/00, McDonald, Ira wrote:

>http://standards.ieee.org/db/oui/tutorials/EUI64.html, March 1997.

Could you provide a working URL, please?

Regards,

Peter Johansson

Congruent Software, Inc.
98 Colorado Avenue
Berkeley, CA  94707

(510) 527-3926
(510) 527-3856 FAX

[email-masked]