Subject: RE: FW: Comments on draft-ietf-zeroconf-reqts-02

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 2 Mar 2000 11:53:29 +1100

Hi Matt,

we have much more than just NAT solutions, I'm not a fan of NATs at all and
that's why I want to see IPv6 deployed. we have application level solutions,
Transport level solutions, and Network level translators. We also have
solutions for communicating over IPv4 as I'm sure some of you know. For more
details check the NGTRANS WG page.
For most users if applications can communicate then that's fine. I'm not
sure that the average computer user knows or even cares what IP stack
they're running. 

I think the solutions ARE there, all we have to do is just take them
seriously, instead of avoiding them.

Cheers,
Hesham

> -----Original Message-----
> From:	Matt Holdrege [SMTP:[email-masked]]
> Sent:	Thursday, 2 March 2000 3:49
> To:	Hesham Soliman (EPA)
> Cc:	[email-masked]'
> Subject:	Re: FW: Comments on draft-ietf-zeroconf-reqts-02
> 
> No doubt, but as with the development of any niche IPv6 area, you have to 
> consider how you will communicate with the greater IPv4 internet. We now 
> have a IPv4 to IPv6 NAT RFC, but NAT's aren't perfect and you really need 
> to consider how it will work for each service and protocol.
> 
> My point is that just saying "we need IPv6" isn't nearly enough.
> 
> 
> At 05:20 PM 2/28/00 +1100, Hesham Soliman (EPA) wrote:
> 
> >I agree, no one seems to be considering IPv6 in any of these discussions.
> 
> >This is despite the fact that Home networking  would be a perfect market 
> >for it, considering that it basically solves half the problems in the 
> >charter of this WG.
> >
> >Hesham
> >-----Original Message-----  From:   Dave Thaler 
> >[SMTP:[email-masked]]  Sent:   Monday, 28 February 2000 
> >6:22  To:     [email-masked]  Cc:     [email-masked]; 
> >[email-masked]; [email-masked]; 
> >[email-masked]  Subject:        Re: Comments on 
> >draft-ietf-zeroconf-reqts-02
> >
> > > "McDonald, Ira" wrote:  > > I also concur.  And strongly urge that we 
> > not plan to make  > > ZC-capable devices support multiple IP addresses 
> > (e.g.,  > > link-local and also DHCP-derived) on the same 
> > interface.  >  > FWIW, I agree completely:  >  >    it's important that 
> > ZC-capable devices can operate in a >    "normal" IP 
> > environment.  >  >    and adding multiple IP address support to 
> > ZC-cabable >    devices overly complicates several issues.  >  > Take 
> > care,  > Pax.
> >
> >Aren't multiple IP addresses a "normal" IPv6 environment?
> >
> >-Dave

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 2 Mar 2000 13:07:14 +1100

Hi Matt,

> Sent:	Thursday, 2 March 2000 12:46
> To:	Hesham Soliman (EPA)
> Cc:	[email-masked]'
> Subject:	RE: FW: Comments on draft-ietf-zeroconf-reqts-02
> 
> The reason I mentioned NAT is that I'm assuming that low-cost ZC devices 
> would not undergo the burden of complex interfaces such as BIP or 6-in-4. 
> If there is a very simple NGTRANS method that would work well in a ZC 
> scenario, please let me know.
> 
Again you're assuming that your ISP is only offering IPv4, Why ? I know that
is the situation now but may not be in the near future. In fact there are
already ISP's in Japan offering IPv6. Things like 6 over 4 or 6to4 are
expected to be in border routers. 
You don't need them in every device if you're running an IPv6 network. 

> I also agree with Paul that protocols based on one IP version should not 
> impact the development under another IP version.
> 
	Of course, but my point is our reqts document should be addressing
the problem for "IP networks", that means BOTH V4 and V6. At the moment V6
is avoided for some reason, despite the fact that is very well suited to
this market.

	Cheers,
	Hesham

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 2 Mar 2000 13:43:01 +1100

How about the scenario of a ZC  IPv6 network that has one GW with the
following functions :
- configured or 6 to 4 tunnelling to communicate to V6 islands over V4
- Application level GW to communicate with apps running on V4 hosts 
- Optional Network layer translator like SIIT 
and NO NAT 
This way we have applications talking regardless of the stack they sit on.
What do you think about that ?

Cheers,
Hesham

> Sent:	Thursday, 2 March 2000 1:21
> To:	Hesham Soliman (EPA)
> Cc:	[email-masked]'
> At 01:07 PM 3/2/00 +1100, Hesham Soliman (EPA) wrote:
> >Again you're assuming that your ISP is only offering IPv4, Why ? I know 
> >that is the situation now but may not be in the near future. In fact
> there 
> >are already ISP's in Japan offering IPv6. Things like 6 over 4 or 6to4
> are 
> Yes I'm assuming the vast majority of ISP's run IPv4 and I have to work 
> under that assumption until it ceases to be true. That doesn't mean I'm 
> against IPv6 development in ZC or any other area. I'm just saying we have 
> to carefully understand what the issues are with using IPv6 in any
> scenario 
> that links back to an IPv4 Internet. In my role as editor of 
> draft-ietf-nat-protocol-complications-01.txt I'm somewhat sensative to
> this 
> issue.
> 
> That said, I'm still assuming that an IPv6 ZC would be NAT'd to the 
> Internet. Or do you think it is more likely that a real world ZC border 
> router would encapsulate?

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 27 Mar 2000 23:02:42 -0800

>I also concur.  And strongly urge that we not plan to make
>ZC-capable devices support multiple IP addresses (e.g.,
>link-local and also DHCP-derived) on the same interface.

Retrofitting current single-homed software to support multiple addresses on
an interface may be tricky sometimes, but I think that when you design a
system from the start supporting two addresses per interface, it is not
nearly so difficult. We're not saying that ZC hosts MUST support two
addresses per interface, but I think we should make it a "SHOULD", because
of the benefits that offers.

Stuart Cheshire <[email-masked]>

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 27 Mar 2000 23:03:24 -0800

>I don't understand why the charter cannot be modified such that
>IPv4 and IPv6 can both be discussed, but are not tied together
>in such a way so that we get bogged down in IPv6 cruft. In fact,
>there should be no reason why we cannot do both, but address
>both v4 and v6 as separate issues? They are indeed different.

I think that if we write the protocol requirements document properly, then
there should be no difference between v4 and v6. The protocol requirements
document should specify the mimimum requirements for Internet-style
(connectionless packet-switched) datagram networking in the absence of
external configuration information. The profile document, listing specific
protocols, may be different for v4 and v6, but even in that case I hope that
the solutions for v4 and v6 will be substantially similar, at least for host
name resolution, service discovery, and multicast address allocation.

---

From: "Hattig, Myron" <[email-masked]>
Date: Mon, 27 Mar 2000 16:06:30 -0800

I think transitioning to larger networks is a MUST for the protocol
requirement. Whether a product vendor implements a particular portion of the
protocol or not is up to the vendor.

-myron

> From: Stuart Cheshire [mailto:[email-masked]]
> Sent: Monday, March 27, 2000 10:56 PM
> To: [email-masked]
> Subject: Re: Comments on draft-ietf-zeroconf-reqts-02
> 
> 
> >For example an internet alarm clock or toaster that will 
> never be taken to
> >the office must still include DHCP client?
> 
> I think we should specify that ZC hosts SHOULD be able to 
> operate in large
> configured networks (e.g. using DHCP) as well as in 
> standalone isolated
> networks. There may be some devices, like X10-style networked light
> switches, which may never need to be globally accessible, but 
> I think the
> argument for putting IP on these devices is not very strong. 
> To my mind, the
> benefit of ZC is that it allows the same devices (and 
> application-layer
> protocols) to operate in both large and small networks. If we 
> create devices
> that don't work in large networks then we don't get that benefit.
>

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 27 Mar 2000 16:11:58 -0800

Hi Stuart,

As the author of that quoted text below, let me put it
back into context, please.

Manufacturers of network printers (favorite examples of
zero configuration and service location scenarios) almost
all buy their protocol stacks from third-parties.  To my
present knowledge, these third-parties uniformly do NOT
support multiple IP addresses on the same network interface
in their current implementations.

Designing a new system from scratch doesn't necessarily
mean that you get the option of altering network protocol
stacks for significant new features.

Implementors at both Xerox and Sharp have repeatedly
expressed their concerns to me in the last few weeks about
ZC-capable devices having to retain link-local IP addresses
*in addition to* administratively configured IP addresses. 

Such a requirement (even worded as a SHOULD) will tend to 
delay adoption of ZC solutions in network products. ZC is
supposed to be defining some lightweight, scalable solutions
for smaller networks, I think?

Cheers,
- Ira McDonald, consulting architect at Sharp and Xerox
  High North Inc