Subject: [xml2rfc] More evidence online version broken

From: Robert Moskowitz <[email-masked]>
Date: Thu, 24 Aug 2017 14:46:28 -0400

The attached fails online.  But builds just nicely on my system with the 
installed v 2.5.2.

Until 2.5.2 fails me, I will stay with it.  I have no idea how I got 
this on my system.  Perhaps some python install I did....

Bob

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 24 Aug 2017 21:00:05 +0200

Hi Bob,

> The attached fails online.  But builds just nicely on my system with the 

Unfortunately, you attached the .txt version, not the .xml version of
the -2-00 file, so I can't test it here.  If you have recreated it,
I'd like to test it with the latest xml2rfc to see what's up.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 Aug 2017 21:02:00 +0200

On Aug 24, 2017, at 20:46, Robert Moskowitz <[email-masked]> wrote:
> 
> The attached fails online.  But builds just nicely on my system with the installed v 2.5.2.

(You sent the .txt, not the .xml, so I can’t check that.)

> Until 2.5.2 fails me, I will stay with it.  

That was a stable version for a long time, its bugs are well known :-)

But there is little reason to believe the weird online behavior you (but none of Henrik, Tony, or me) are seeing transfers to the local version.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 24 Aug 2017 15:44:36 -0400

> I'd like to test it with the latest xml2rfc to see what's up.

Now I am really upset.

I went back to  the old version and it works.

I did it on the new F26 system and it failed.  I moved it to the new 
system and it works.

Something somewhere is really after me.  I better put on my aluminum hat.

I can't afford time like this.  here is one that works.  Sometimes and 
sometimes not.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 24 Aug 2017 22:09:17 +0200

Hi Bob,

On 2017-08-24 21:44, Robert Moskowitz wrote:
> I can't afford time like this.

I'm sorry that things haven't been smoother.  I'm still trying to work
out if there's something I need to fix, and if so what it is.

> here is one that works.  Sometimes and 
> sometimes not.

Thank you.  This one works for me with version 2.7.0 locally and through
the web service.

Best regards,

	Henrik

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 24 Aug 2017 21:44:32 +0000

I spotted these in the error log on the xml2rfc server:

[Thu Aug 24 09:10:07 2017] [error] [client 50.253.254.14] Malformed multipart POST, referer: http://xml2rfc.tools.ietf.org/
[Thu Aug 24 09:10:07 2017] [error] [client 50.253.254.14] Premature end of script headers: xml2rfc.cgi, referer: http://xml2rfc.tools.ietf.org/
[Thu Aug 24 09:11:25 2017] [error] [client 50.253.254.14] Malformed multipart POST, referer: http://xml2rfc.tools.ietf.org/
[Thu Aug 24 09:11:25 2017] [error] [client 50.253.254.14] Premature end of script headers: xml2rfc.cgi, referer: http://xml2rfc.tools.ietf.org/

I’m not sure if that’s you or not. (The timestamp is PDT, US/Pacific.)

	Tony

On 8/24/17, 4:09 PM, "xml2rfc on behalf of Henrik Levkowetz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Bob,

    

    Best regards,
    
    	Henrik

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 24 Aug 2017 17:58:50 -0400

That is my firewall IP.

So it is probably my Firefox or my firewall NATing.  More likely Firefox.

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 25 Aug 2017 04:06:03 +0000

Robert, can you re-run your test using http://xml2rfc.tools.ietf.org/index-tee.html ?

That’ll let me capture your exact inputs so I can see if the problem is on your side or mine.

Thanks!

	Tony

On 8/24/17, 5:59 PM, "Robert Moskowitz" <[email-masked]> wrote:

    That is my firewall IP.

    On 08/24/2017 05:44 PM, HANSEN, TONY L wrote:
    > [Thu Aug 24 09:10:07 2017] [error] [client 50.253.254.14] Malformed multipart POST, referer: 
    > [Thu Aug 24 09:10:07 2017] [error] [client 50.253.254.14] Premature end of script headers: xml2rfc.cgi, referer: 
    > [Thu Aug 24 09:11:25 2017] [error] [client 50.253.254.14] Malformed multipart POST, referer: 
    > [Thu Aug 24 09:11:25 2017] [error] [client 50.253.254.14] Premature end of script headers: xml2rfc.cgi, referer: 
    >

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Aug 2017 08:19:08 +0200

> Robert, can you re-run your test using http://xml2rfc.tools.ietf.org/index-tee.html ?

To rule out the likely firewall mangling, an https:// URI is probably more useful.

Grüße, Carsten

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 25 Aug 2017 12:51:20 +0000

And running it both with http and https would provide even more information. :)

On 8/25/17, 2:19 AM, "Carsten Bormann" <[email-masked]> wrote:

    On Aug 25, 2017, at 06:06, HANSEN, TONY L <[email-masked]> wrote:
    > 
    > Robert, can you re-run your test using xml2rfc.tools.ietf.org/index-tee.html

    Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 25 Aug 2017 13:34:32 -0400

I had an eye appt this morning.  Still dilated a bit.  Hopefully soon I 
can set up a test.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 25 Aug 2017 15:31:17 -0400

Tony,

I just generated a server error message.

My first attempt worked.  Then I opened up a window to cnn.com which 
tends to bog down Firefox, and while cnn was loading, I tried xml2rfc 
again and it failed.

Bb

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 25 Aug 2017 15:34:54 -0400

Just tried https:// ...

and it did not like my file:

Resolving include... /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml/reference.RFC.2119.xml
Resolving include... /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml/reference.RFC.2118.xml
ERROR: Unable to validate the XML document: INPUT
  <string>: Line 135: Element references content does not follow the DTD, expecting (reference)+, got (t)
  <string>: Line 136: Element reference is not declared in t list of possible children

Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8

Here is lines 135 - 138.

<references title="Informative References">
<t>
     <?rfc include="reference.RFC.2118.xml"?>
</t>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Aug 2017 23:55:24 +0200

>     <?rfc include="reference.RFC.2118.xml"?>

RFC 7749 says:

   references =
     element references {
       [ a:defaultValue = "References" ] attribute title { text }?,
       reference+
     }

   reference =
     element reference {
[…]

So you need to take out the <t> and </t> tags.
Maybe you want to try xmllint to check your XML.
(Or switch to kramdown-rfc — that is more likely to generate valid XML.)

Your previous experiment likely showed that something is broken with your TCP (client and/or middleboxes) and/or browser.
Using tools such as tcpdump and tcpflow, that could be debugged (not that I’m asking you to do that).

Grüße, Carsten