Subject: Re: [xml2rfc] v3 Format tools discussion

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 2 Jul 2017 16:24:46 +0200

Hi Julian,

On 2017-06-28 16:49, Julian Reschke wrote:
> On 2017-06-28 16:23, Henrik Levkowetz wrote:
>> Hi Julian
>> 
>> On 2017-06-27 21:56, Julian Reschke wrote:
>>> On 2017-06-27 20:27, Henrik Levkowetz wrote:
>>>> Hi Heather,
>>>>
>>>> Thank you for this.  I'm currently working on the v2v3 converter, and
>>>> I've just run into something I'd like to ask about.  Will do so there :-)
>>>>
>>>> Best regards,
>>>>
>>>> 	Henrik
>>>
>>> FWIW, prep-xml2rfc.xslt attempts some v2->v3 conversion as well. It
>>> would be interesting to compare notes and test results...
>> 
>> Indeed.  I'll ping you when I think my version is feature complete (handles
>> all deprecations mentioned in the RFC in what I believe is the appropriate
>> way).
> 
> ...for some parts that'll be tricky, such as table styles :-)
> 
> Let me know when you want to try prep-xml2rfc and can't get it to run...

Huh.  That sounds ominous.

FWIW, the converter is out now as part of xml2rfc 2.7.0; if you try it and
have feedback it would be very welcome.

Best regards,

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Sun, 2 Jul 2017 16:42:23 +0200

On 2017-07-02 16:24, Henrik Levkowetz wrote:
> ...

It requires installing an XSLT2 processor :-)

> have feedback it would be very welcome.

On my TODO list.

(right now refactoring my own v2 list support)

Best regards, Julian