Subject: Re: [xml2rfc] RFC Bibtex format doi numbering incorrect

From: "John Levine" <[email-masked]>
Date: 2 Jun 2017 12:29:43 -0000

In article <[email-masked]> you write:
>> Beats me.  If the references had come from bibtex, they'd be right, so 
>> who knows what other tools they haven't been using.  As you surely know, 
>> we can write all the tools we want but we can't force people to use them.
>> ...
>
>Well, we know that an xml2rfc processor *is* used. That processor could 
>do a sanity check on the DOIs, in which case the problem might have been 
>detected during AUTH48.

Well, sure, it could fetch them and make sure they work, and not just
for RFCs.  Should I put in a feature request?

R's,
John

PS: it is my impression that some RFCs were still coming through nroff
until quite recently.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 2 Jun 2017 14:42:03 +0200

> PS: it is my impression that some RFCs were still coming through nroff

...those I found were already broken in the AUTH48 XML.

Best regards, Julian

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 2 Jun 2017 07:40:54 -0700

Julian,

Did you use a script to check the DOIs?  Would you be willing to share with RPC so we can run it as part of our final checks before PUB? 

Thanks,
Sandy

> On Jun 2, 2017, at 5:42 AM, Julian Reschke <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 2 Jun 2017 16:53:01 +0200

> Did you use a script to check the DOIs?  Would you be willing to share with RPC so we can run it as part of our final checks before PUB?

It's part of the diagnostics generated by rfc2629.xslt. The output for 
the (XML-formatted) RFCs in AUTH48 can be found (as news feed) at 
http://greenbytes.de/tech/tc/xml2rfc/rfcdiags.atom>.

Best regards, Julian