Subject: Re: [xml2rfc] how to debug an error?

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 12 Jun 2017 15:32:46 +0000

I think for this one, we’d need to see the input file. “line 1, column 33851” literally means the 33851st column of the 1st line. Unless your input file consists of a single looooooooong line, there’s probably a bug.

Also, we need to know if you’re using the online web page or your own standalone copy of xml2rfc. If the standalone copy, we’d also need to know which version.

	Tony

On 6/12/17, 10:45 AM, "xml2rfc on behalf of JORDI PALET MARTINEZ" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,
    
    I’m trying to upload a document with is a cut down version from a previous one …
    
    I believe everything is ok, and can’t find the problem, but I get
    
    WARNING: Parsing Error: Opening and ending tag mismatch: section line 1 and middle, line 1, column 33851 (line 1)
    ERROR: Unable to parse the XML document: INPUT
     INPUT: Line 1: Opening and ending tag mismatch: section line 1 and middle
     INPUT: Line 1: Opening and ending tag mismatch: section line 1 and middle
     INPUT: Line 1: Opening and ending tag mismatch: middle line 1 and rfc
     INPUT: Line 1: Premature end of data in tag rfc line 1

    What actually means column 33851?
    
    Thanks!
    
    Regards,
    Jordi

    
    **********************************************
    IPv4 is over
    Are you ready for the new Internet ?
    https://urldefense.proofpoint.com/v2/url?u=http-3A__www.consulintel.es&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=R2l2dxtFRERlf7u9mUgKZn3qStjAv6pSREv9bHD3Gqk&s=vxb7wIu8-f2x8mH57u3NPr26iRBTi9V0sg5SrI8m66k&e= 
    The IPv6 Company
    
    This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

    _______________________________________________
    xml2rfc mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_xml2rfc&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=R2l2dxtFRERlf7u9mUgKZn3qStjAv6pSREv9bHD3Gqk&s=s2xJaViN2a-6cAQtWZ4YU6XsAuudjDkehWWvEQx8D4c&e=

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 12 Jun 2017 17:37:25 +0200

Using the online tool (https://xml2rfc.tools.ietf.org/).

I just found the problem …

I deleted one extra       </section>

by mistake …

I’m sending you the file in pvt so you can use it to debug it why is not being reported correctly, in case is not my fault for whatever reason ….

Regards,
Jordi

-----Mensaje original-----
De: "HANSEN, TONY L" <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 12 de junio de 2017, 17:32
Para: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [xml2rfc] how to debug an error?

    
    	Tony

        Hi,

        

        Thanks!
        
        Regards,
        Jordi

        

        

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 12 Jun 2017 15:59:02 +0000

Thank you, I’ve verified that it’s a bug in xml2rfc version 2.6.1. The column number is pointing at the byte number within the file, instead of the line and column number that it should be using.

Please create a trac ticket on it at https://trac.tools.ietf.org/tools/xml2rfc/trac/ and upload your input file as an attachment.

Thanks!

	Tony

On 6/12/17, 11:37 AM, "xml2rfc on behalf of JORDI PALET MARTINEZ" <[email-masked] on behalf of [email-masked]> wrote:

    Using the online tool (https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=kzKBQnkN7QXlwv75mj727_HHhrS6NWejbkwHlc5PRuI&s=z0tqoh1bl6xn8XqjPW35dPk2DbhuxfJ56uMVuYq9IhU&e= ).

    
    by mistake …

    Regards,
    Jordi

    -----Mensaje original-----
    De: "HANSEN, TONY L" <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: lunes, 12 de junio de 2017, 17:32
    Para: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
    Asunto: Re: [xml2rfc] how to debug an error?

        
        	Tony

            Hi,

            

            Thanks!
            
            Regards,
            Jordi

            

            

    
    **********************************************
    IPv4 is over
    Are you ready for the new Internet ?
    https://urldefense.proofpoint.com/v2/url?u=http-3A__www.consulintel.es&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=kzKBQnkN7QXlwv75mj727_HHhrS6NWejbkwHlc5PRuI&s=hFGaj7sUf4ioDtlM-6DN99kKOaUXPfgDqowgltaZRIs&e= 
    The IPv6 Company

    
    _______________________________________________
    xml2rfc mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_xml2rfc&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=kzKBQnkN7QXlwv75mj727_HHhrS6NWejbkwHlc5PRuI&s=TkOnW9yupDpJl6L16yZYgB6ezeobrxgIJKsyeSLfy3k&e=