Subject: [xml2rfc] reference src attribute

From: <[email-masked]>
Date: Mon, 29 May 2017 13:35:53 +0000

Hi,

I looked at the issue tracker and did not find a similar proposal back until 2013 where I stopped looking.
I apologize if this has been asked and rejected before.

I am wondering why a reference in xml2ref cannot point to a xml2ref document and the "front" element is pulled from that xml2ref document.

Example:

When the processor encounters this element in an xml2ref document:
<reference src=" https://bitbucket.org/openid/mobile/raw/tip/draft-mobile-client-initiated-backchannel-authentication.xml" />
It would pull the first child "/rfc/front[0]" from that document and treat it as if it were the first child of this reference.
Maybe kids that are legal for /ref/front but illegal for //reference/front must be ignored.

Does this make sense?

Cheers
Axel

https://trac.tools.ietf.org/tools/xml2rfc/trac/search?changeset=on&milestone=on&ticket=on&wiki=on&q=reference&page=13&noquickjump=1

---

From: Julian Reschke <[email-masked]>
Date: Mon, 29 May 2017 19:46:32 +0200

> Maybe kids that are legal for /ref/front but illegal for //reference/front must be ignored.

In V3, you could do this using XInclude, see 
<https://www.greenbytes.de/tech/webdav/rfc7991.html#includingexternal> 
(depending on whether we leave things open as specified now or restrict 
the use of the "xpath" attribute).

Best regards, Julian