Subject: [xml2rfc] Shortening Internet Draft references

From: Tom Pusateri <[email-masked]>
Date: Wed, 17 May 2017 14:56:23 -0400

Currently, an internet draft is referenced in the form I-D.ietf-dnsop-session-signal

When using the reference many times throughout a document, this can be cumbersome and wanting to shorten this throughout the document is desirable.

I know it is possible to create a full reference and define the reference tag as described in https://xml2rfc.tools.ietf.org/xml2rfcFAQ.html#anchor13

But then I have to maintain the reference as the ID changes.

It would be nice to be able to define the reference tag in the ENTITY definition like:

<!ENTITY SessSig SYSTEM "http://xml.resource.org/public/rfc/bibxml3/reference.I-D.ietf-dnsop-session-signal.xml”>

and then reference it as <xref target="SessSig”> but today this doesn’t seem possible. It is always forced to I-D.ietf-dnsop-session-signal

Any ideas?

Thanks,
Tom

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 May 2017 21:20:30 +0200

Hi Tom,

you can already replace the default anchor with the bibxml7 interface to DOIs, by adding a "?anchor=EXAMPLE" argument to the URL.
A similar mechanism could be added to bibxml3, which currently just serves files.
(See <https://mailarchive.ietf.org/arch/msg/tools-discuss/hnxDlpMgNimX9lGTx_V14lg3zkY> for some discussion.)

Incidentally, since version 1.1, kramdown-rfc2629 allows setting up references like

normative:
  SessSig: I-D.ietf-dnsop-session-signal

but this only works because kramdown-rfc2629 actually processes the XML received from the xml2rfc.tools.ietf.org server before inserting it into the XML.  Just doing this in an XML entity reference requires some server-side surgery.

(If you want to try out writing RFCs in markdown, I have a tool that can be used to convert RFCXML to markdown.)

Grüße, Carsten

> On May 17, 2017, at 20:56, Tom Pusateri <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
> 
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 17 May 2017 22:13:37 +0200

> and then reference it as <xref target="SessSig”> but today this doesn’t seem possible. It is always forced to I-D.ietf-dnsop-session-signal

You could start using v3 features, and use clean-for-DTD.xslt as 
preprocessor for the v2 xml2rfc tool.

See 
<https://greenbytes.de/tech/webdav/rfc7991.html#element.displayreference>.

Best regards, Julian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 17 May 2017 20:14:38 +0000

I actually prototyped a mechanism to allow “?anchor=EXAMPLE” to be added to bibxml1-6, but it requires some apache webserver configuration magic that I haven’t figured out yet.

If anyone would like to help me figure it out, please contact me offlist.

	Tony

On 5/17/17, 3:20 PM, "xml2rfc on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Tom,
    
    you can already replace the default anchor with the bibxml7 interface to DOIs, by adding a "?anchor=EXAMPLE" argument to the URL.
    A similar mechanism could be added to bibxml3, which currently just serves files.
    (See < https://mailarchive.ietf.org/arch/msg/tools-discuss/hnxDlpMgNimX9lGTx_V14lg3zkY> for some discussion.)

    normative:

    
    Grüße, Carsten

    
    > I know it is possible to create a full reference and define the reference tag as described in https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_xml2rfcFAQ.html-23anchor13&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=LqmcA1s0cUP0TcYdOAY31wj6VXRokjp7ZSztbsHzrCE&s=fqMFFJ8kMHQoKVOEG6bJF7m4XgF64d3YbmnlaSJLqbQ&e= 
    > 
    > <!ENTITY SessSig SYSTEM "https://urldefense.proofpoint.com/v2/url?u=http-3A__xml.resource.org_public_rfc_bibxml3_reference.I-2DD.ietf-2Ddnsop-2Dsession-2Dsignal.xml&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=LqmcA1s0cUP0TcYdOAY31wj6VXRokjp7ZSztbsHzrCE&s=Ag1sSIaLC9HszjdMbkxJumimraZoQiy_QBpnyU8ITik&e= ”>
    > 
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_xml2rfc&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=LqmcA1s0cUP0TcYdOAY31wj6VXRokjp7ZSztbsHzrCE&s=8Y1TH6ZfP6bSkCmbwbZZYFk60067xBlODRPyIbdY8w0&e= 
    > 
    > 
    
    _______________________________________________
    xml2rfc mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_xml2rfc&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=LqmcA1s0cUP0TcYdOAY31wj6VXRokjp7ZSztbsHzrCE&s=8Y1TH6ZfP6bSkCmbwbZZYFk60067xBlODRPyIbdY8w0&e=