Subject: [xml2rfc] https://xml2rfc.tools.ietf.org/

From: Fred Baker <[email-masked]>
Date: Thu, 13 Apr 2017 15:35:24 -0700

MacOSX 10.12.4, GNU Wget 1.19.1

I just sat down to set up rsync for the XML files, and

Folks: this page is way out of date: https://xml2rfc.tools.ietf.org/

I'm trying to accomplish the following:
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml/ ~/In-Progress/XML_Library
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-ids/ ~/In-Progress/XML_Library
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-w3c/ ~/In-Progress/XML_Library
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-3gpp/ ~/In-Progress/XML_Library
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-ieee/ ~/In-Progress/XML_Library
rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-misc/ ~/In-Progress/XML_Library

The only issue is that rsync doesn't do that (although I used to be able to do something similar...). What I'm looking at right now is a variant on wget, which seems to mostly work but takes for approximately ever. It also tells me "/Users/fred/In-Progress/XML_Library: Scheme missing."

wget -r -l 1 -A .xml -nd -nc https://xml2rfc.ietf.org/public/rfc/bibxml/ ~/In-Progress/XML_Library
wget -r -l 1 -A .xml -nd -nc https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/ ~/In-Progress/XML_Library
wget -r -l 1 -A .xml -nd -nc https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/ ~/In-Progress/XML_Library
wget -r -l 1 -A .xml -nd -nc https://xml2rfc.tools.ietf.org/public/rfc/bibxml4/ ~/In-Progress/XML_Library
wget -r -l 1 -A .xml -nd -nc https://xml2rfc.tools.ietf.org/public/rfc/bibxml5/ ~/In-Progress/XML_Library
wget -r -l 1 -A .xml -nd -nc https://xml2rfc.tools.ietf.org/public/rfc/bibxml6/ ~/In-Progress/XML_Library

As in: 

> --2017-04-13 15:30:27--  https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/reference.W3C.xpath.xml
> Reusing existing connection to xml2rfc.tools.ietf.org:443.
> HTTP request sent, awaiting response... 200 OK
> Length: 724 [application/xml]
> Saving to: ‘reference.W3C.xpath.xml’
> 
> reference.W3C.xpath.x 100%[=========================>]     724  --.-KB/s    in 0s      
> 
> 2017-04-13 15:30:27 (9.33 MB/s) - ‘reference.W3C.xpath.xml’ saved [724/724]
> 
> /Users/fred/In-Progress/XML_Library: Scheme missing.

I have poked around the net, and not found a great explanation or a workaround that actually works. Suggestions?

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 Apr 2017 01:55:43 +0200

On Apr 14, 2017, at 00:35, Fred Baker <[email-masked]> wrote:
> Suggestions?

I still do:

rsync -avzH rsync3.xml.resource.org::xml2rfc.bibxml std/bib

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 14 Apr 2017 14:02:23 +0200

Hi Fred,

> Folks: this page is way out of date: https://xml2rfc.tools.ietf.org/

Ack.  Tony?

> rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml/ ~/In-Progress/XML_Library

I just tried this:

rsync -avuz xml2rfc.tools.ietf.org::xml2rfc.bibxml/ /tmp/bibxml/

and it worked swimmingly   Please note the final slash on the target
directory.

This is the resulting first level:

$ ls -l /tmp/bibxml/
total 0
drwxrwsr-x 3 henrik henrik  160800 Apr 14 13:15 bibxml
drwxrwxr-x 2 henrik staff    20600 Apr 14 13:21 bibxml2
drwxrwxr-x 3 henrik staff  1873880 Apr 14 13:21 bibxml3
drwxrwxr-x 3 henrik staff   103980 Apr 14 13:21 bibxml4
drwxrwxr-x 3 henrik staff    86720 Jul 22  2015 bibxml5
drwxr-xr-x 3   1007   1006    4180 Jul 24  2015 bibxml6
drwxr-xr-x 2   1007   1006     240 Dec 18 02:33 bibxml7
drwxr-xr-x 2   1007   1006     120 Dec 18 02:52 bibxml8

> rsync -avz xml2rfc.ietf.org::xml2rfc.bibxml-misc/ ~/In-Progress/XML_Library

None of the endpoints above (::xml2rfc.bibxml-*) are supposed to exist --
not sure I've ever seen those paths.

Best regards,

	Henrik

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 14 Apr 2017 12:50:05 +0000

On 4/14/17, 8:02 AM, "xml2rfc on behalf of Henrik Levkowetz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Fred,

    Ack.  Tony?

Fred, Henrik, details please? >What< in your opinion is out of date on the page?

	Tony

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 14 Apr 2017 15:34:21 +0200

Hi Tony,

> Fred, Henrik, details please? >What< in your opinion is out of date on the page?

Ahh.  I hate it when people do that to me -- say "there's an error here"
without giving specifics.  Sorry!

So, there is very little rsync-specific information on the page, and what
there is, should probably be updated.  It now says:

rsync access is available at two independent servers (rsync1.xml.resource.org::xml2rfc.bibxml, and rsync3.xml.resource.org::xml2rfc.bibxml) — after you pick one, you shouldn't switch.

Maybe we should instead point at either or both of xml2rfc.ietf.org::xml2rfc.bibxml, xml2rfc.tools.ietf.org::xml2rfc.bibxml,
and give an example of pulling down all the citation libraries using rsync, something like

  $ rsync -avuz xml2rfc.ietf.org::xml2rfc.bibxml/ ~/cit/

?

Best regards,

	Henrik

---

From: Fred Baker <[email-masked]>
Date: Fri, 14 Apr 2017 11:07:42 -0700

OK, thanks. Not finding that in the online documentation...

> On Apr 14, 2017, at 5:02 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Fred,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 14 Apr 2017 22:09:13 +0200

> OK, thanks. Not finding that in the online documentation...

Ack.  Tony and I have exchanged mail on updating the documentation.

Best regards,

	Henrik

---

From: Fred Baker <[email-masked]>
Date: Fri, 14 Apr 2017 19:27:02 -0700

> On Apr 14, 2017, at 5:50 AM, HANSEN, TONY L <[email-masked]> wrote:
> 

URIs like https://xml2rfc.tools.ietf.org/public/rfc/bibxml-ids/, which Henrik tells me are not supported, and which I can tell you don't work.

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sat, 15 Apr 2017 20:09:44 +0000

done

On 4/14/17, 9:34 AM, "Henrik Levkowetz" <[email-masked]> wrote:

    Hi Tony,

    

    
    
    ?

    Best regards,
    
    	Henrik