Subject: [xml2rfc] < sensitivity in artwork

From: Randy Bush <[email-masked]>
Date: Sun, 05 Mar 2017 21:18:58 +0900

<figure>
  <artwork>
+--------------------------------------------------------+
|                     +------------+                     |
|                     |            |                     |
|          .---------->    NHIB    |----------.          |
|          |          |            |          |          |
|          |          +------------+          |          |
|   +------+-----+                     +------v-----+    |
|   |Adj-NHIB-In |                     |Adj-NHIB-Out|    |
|   +------^-----+     Route Server    +------+-----+    |
+----------|----------------------------------|----------+
           |                                  |           
           |                                  |           
+----------|----------------------------------|----------+
|   +------+-----+       RS Client      +-----v------+   |
|   |Adj-NHIB-Out|                      |Adj-NHIB-In |   |
|   +------^-----+                      +-----+------+   |
|          |          +------------+          |          |
|          |          |            |          |          |
|          `----------+    NHIB    <----------'          |
|                     |            |                     |
|                     +------------+                     |
+--------------------------------------------------------+           
           Fig 1. Route Server, RS Client,
            and NHIBs with In/Out Queues
  </artwork>
</figure>

pdoduces

% xml2rfc draft-ietf-idr-rs-bfd.xml 
Parsing file draft-ietf-idr-rs-bfd.xml
WARNING: Parsing Error: StartTag: invalid element name, line 235, column 37
ERROR: Unable to parse the XML document: draft-ietf-idr-rs-bfd.xml
 draft-ietf-idr-rs-bfd.xml: Line 235: StartTag: invalid element name
 draft-ietf-idr-rs-bfd.xml: Line 235: StartTag: invalid element name

with line 235 being the one with < at the right of the bottom NHIB box

clue bat, please

randy

---

From: Julian Reschke <[email-masked]>
Date: Sun, 5 Mar 2017 13:29:00 +0100

>   <artwork>

You can't have unescaped "<" characters in text content.

The advice in

   <https://greenbytes.de/tech/webdav/rfc7991.html#cdata.and.escaping>

should be helpful.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sun, 5 Mar 2017 13:34:53 +0100

On 2017-03-05 13:29, Julian Reschke wrote:
> ...

Also, you might want to use

<https://greenbytes.de/tech/webdav/rfc7749.html#element.figure.attribute.title>

to specify the title of the figure.

Best regards, Julian

---

From: Randy Bush <[email-masked]>
Date: Sun, 05 Mar 2017 21:56:45 +0900

>   <https://greenbytes.de/tech/webdav/rfc7991.html#cdata.and.escaping>

thanks.  i assumed, incorrectly, that artwork was untouchable

> <https://greenbytes.de/tech/webdav/rfc7749.html#element.figure.attribute.title>

need example

randy

---

From: Julian Reschke <[email-masked]>
Date: Sun, 5 Mar 2017 14:06:15 +0100

> thanks.  i assumed, incorrectly, that artwork was untouchable

A concept like that exists in SGML (thus HTML), but not in XML.

>> <https://greenbytes.de/tech/webdav/rfc7749.html#element.figure.attribute.title>

<figure title="another figure" anchor="testfig">
   <artwork>
   +--+
   |  |
   +--+
</artwork>
</figure>
<t>
   The figure above has the title "<xref target="testfig" format="title" 
/>".
</t>

---

From: Randy Bush <[email-masked]>
Date: Mon, 06 Mar 2017 00:33:48 +0900

> <figure title="another figure" anchor="testfig">

title not well-centered with respect to artwork

but good enough for government work, especially considering the
government

thanks

randy

---

From: "Susan Hares" <[email-masked]>
Date: Sun, 5 Mar 2017 14:21:04 -0500

Randy: 

The artwork is sensitive to "<" and ">" .  You can replace these by &lt; and
&gt;

Sue 

-----Original Message-----
From: xml2rfc [mailto:[email-masked]] On Behalf Of Randy Bush
Sent: Sunday, March 5, 2017 7:19 AM
To: XML2RFC Interest Group
Subject: [xml2rfc] < sensitivity in artwork

<figure>
  <artwork>

pdoduces

clue bat, please

randy

_______________________________________________
xml2rfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 5 Mar 2017 16:34:27 -0500

> The artwork is sensitive to "<" and ">" .  You can replace these by &lt; and

I general for artwork I use <![CDATA[