Subject: [xml2rfc] how to submit updates to the bibxml2 misc reference collection?

From: =JeffH <[email-masked]>
Date: Wed, 05 Dec 2012 18:40:56 -0800

Greetings again,

In the distant past, I submitted various references to the "Miscellaneous" 
reference collection..

   http://xml.resource.org/public/rfc/bibxml2/

..back when Marshall Rose curated that collection by hand.

How are updates to this collection being presently handled, or are they being 
handled at all?

Am curious because I have a few references I'd contribute if I knew how.

thanks,

=JeffH

---

From: Glen Zorn <[email-masked]>
Date: Thu, 06 Dec 2012 10:49:21 +0700

On 12/06/2012 09:40 AM, =JeffH wrote:

> Greetings again,
 >
 > In the distant past, I submitted various references to the
 > "Miscellaneous" reference collection..
 >
 > How are updates to this collection being presently handled, or are
 > they being handled at all?

AFAICT, nobody is doing this: I've submitted a number of references but 
none have ever showed up in the collection.  I've even offered to take 
over the job of updating the collection with no response (possibly 
because there is no one to take over /from/).

 > Am curious because I have a few references I'd contribute if I knew

In theory, you just send the reference to this list (but see above).

>
 > thanks,
 >
 > =JeffH _______________________________________________ xml2rfc
 > mailing list [email-masked]
 > https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Tony Hansen <[email-masked]>
Date: Sun, 09 Dec 2012 23:27:28 -0500

A couple IETFs ago, I tried unraveling the rat's nest that makes up the 
bibxml directories during the codesprint. My hope was to make sure that 
each of the references that reflected data coming from other SDOs 
actually used a feed from those other SDOs.

I made little progress and haven't made it back to that effort.

As far as I know, all of the current data *is* in svn.

I like the idea of opening up editing privileges, and might even 
consider making it bibxml2 itself that was opened up. However, there 
needs to be a bit of quality control on the changes before getting 
pushed out. For example, verification for proper BIBREF XML is a minimum.

     Tony Hansen

On 12/6/2012 10:55 AM, Alice Russo wrote:
> Hi,
>
> FYI, this topic came up again on the xml2rfc list.
>
> An idea for making use of various individuals' energy to improve the citations library:
> - Start an experiment with the Miscellaneous directory (http://xml.resource.org/public/rfc/bibxml2/) Rationale: it's the one that primarily comes up in discussion of 'how do I update this'. It contains  citations for documents by various SDOs.
> - Keep the existing one in place.
> - Make a copy available that can be updated by community members, while still being available via rsync. (e.g., bibxml2exp/)
> - Announce experiment with disclaimer about quality (as good as you make it). Point to examples of good citations.
> - No gatekeeper on updates.
> - RPC role is contributing, but not reviewing every change. (If the experiment concludes and the decision is to replace the existing lib., more quality control at that time.)
>
> Thanks,
> Alice
>
> Begin forwarded message:
>
>> From: Glen Zorn <[email-masked]>
>> Date: December 5, 2012 10:49:21 PM EST
>> To: =JeffH <[email-masked]>
>> Cc: xml2rfc list <[email-masked]>
>> Subject: Re: [xml2rfc] how to submit updates to the bibxml2 misc reference collection?
>>
>> AFAICT, nobody is doing this: I've submitted a number of references but none have ever showed up in the collection.  I've even offered to take over the job of updating the collection with no response (possibly because there is no one to take over /from/).
>>
>> _______________________________________________
>> xml2rfc mailing list
>> [email-masked]
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Alice Russo <[email-masked]>
Date: Mon, 17 Dec 2012 14:12:45 -0500

Hi Tony,

> I like the idea of opening up editing privileges, and might even consider making it bibxml2 itself that was opened up. However, there needs to be a bit of quality control on the changes before getting pushed out. For example, verification for proper BIBREF XML is a minimum.

If there is automated verification when committing a file, seems there would still be a later QC step. How about this separation?

- bibxml2/ is fairly static (e.g., updated yearly) and content has been checked.
- bibxml2exp/ is open for community editing, so it's used with awareness that its content has not been checked (beyond minimal verification) and is a moving target.

Perhaps once a year the content of bibxml2exp/ is checked, and good refs are copied over to bibxml2/.

Thanks,
Alice

On Dec 9, 2012, at 11:27 PM, Tony Hansen wrote:

> A couple IETFs ago, I tried unraveling the rat's nest that makes up the bibxml directories during the codesprint. My hope was to make sure that each of the references that reflected data coming from other SDOs actually used a feed from those other SDOs.
> 
> I like the idea of opening up editing privileges, and might even consider making it bibxml2 itself that was opened up. However, there needs to be a bit of quality control on the changes before getting pushed out. For example, verification for proper BIBREF XML is a minimum.
> 
>     Tony Hansen
> 
>> - Start an experiment with the Miscellaneous directory (
>> ) Rationale: it's the one that primarily comes up in discussion of 'how do I update this'. It contains  citations for documents by various SDOs.

---

From: Nico Williams <[email-masked]>
Date: Mon, 17 Dec 2012 13:43:32 -0600

> Perhaps once a year the content of bibxml2exp/ is checked, and good refs are copied over to bibxml2/.

Reference accuracy should be checked by the RFC-Editor for sure, no?
So who cares if there's bogus content in the bibxml directory, as long
as the RFC-Editor will eventually notice and can fix it then, it
should be OK, no?

One thing we may want is a repository that has only those references
that have been checked by the RFC-Editor in the process of publishing
an RFC that makes reference to them.  That way we can save the
RFC-Editor the work of doing this more than once per-entry.

Nico
--

---

From: Tony Hansen <[email-masked]>
Date: Mon, 17 Dec 2012 14:47:00 -0500

Alice, I think you're on the right track. Two issues come to mind:

*) Who should do the verification?

*) I think the frequency should be more often than once a year. Quarterly?

I also think it should be possible for someone to ask for a faster 
review of a particular entry.

     Tony

---

From: Glen Zorn <[email-masked]>
Date: Tue, 18 Dec 2012 07:04:47 +0700

On 12/18/2012 02:12 AM, Alice Russo wrote:

 >> consider making it bibxml2 itself that was opened up. However,
 >> there needs to be a bit of quality control on the changes before
 >> getting pushed out. For example, verification for proper BIBREF XML
 >> is a minimum.
 >
 > If there is automated verification when committing a file, seems
 > there would still be a later QC step. How about this separation?
 >
 > - bibxml2/ is fairly static (e.g., updated yearly) and content has
 > been checked. - bibxml2exp/ is open for community editing, so it's
 > used with awareness that its content has not been checked (beyond
 > minimal verification) and is a moving target.
 >

Never mind, I'll just keep on generating my own citations for the 
documents I use (e.g., IEEE 802.1X -- widely referenced in RFCs, 
citations submitted at least 3 times (by me, undoubtedly by others as 
well) but utterly absent from the archive) .  At least now I know not to 
waste my time trying to share them...

 > Thanks, Alice
 >> A couple IETFs ago, I tried unraveling the rat's nest that makes up
 >> the bibxml directories during the codesprint. My hope was to make
 >> sure that each of the references that reflected data coming from
 >> other SDOs actually used a feed from those other SDOs.
 >>
 >> consider making it bibxml2 itself that was opened up. However,
 >> there needs to be a bit of quality control on the changes before
 >> getting pushed out. For example, verification for proper BIBREF XML
 >> is a minimum.
 >>
 >> Tony Hansen
 >>
 >>> An idea for making use of various individuals' energy to improve
 >>> the citations library: - Start an experiment with the
 >>> Miscellaneous directory (
 >>> http://xml.resource.org/public/rfc/bibxml2/ ) Rationale: it's the
 >>> one that primarily comes up in discussion of 'how do I update
 >>> this'. It contains citations for documents by various SDOs. -
 >>> Keep the existing one in place. - Make a copy available that can
 >>> be updated by community members, while still being available via
 >>> rsync. (e.g., bibxml2exp/) - Announce experiment with disclaimer
 >>> about quality (as good as you make it). Point to examples of good
 >>> citations. - No gatekeeper on updates. - RPC role is
 >>> contributing, but not reviewing every change. (If the experiment
 >>> concludes and the decision is to replace the existing lib., more
 >>> quality control at that time.)
 >>>
 >>> Thanks, Alice
 >>>
 >>> Begin forwarded message:
 >>>
 >>>
 >>>> Date: December 5, 2012 10:49:21 PM EST To: =JeffH
 >>>> <[email-masked]>
 >>>>
 >>>>> How are updates to this collection being presently handled,
 >>>>> or are they being handled at all?
 >>>>>
 >>>> AFAICT, nobody is doing this: I've submitted a number of
 >>>> references but none have ever showed up in the collection.
 >>>> I've even offered to take over the job of updating the
 >>>> collection with no response (possibly because there is no one
 >>>> to take over /from/).
 >>>>
 >>>>
 >>>>> =JeffH _______________________________________________
 >>>>> xml2rfc mailing list [email-masked]
 >>>> _______________________________________________ xml2rfc mailing
 >>>> list
 >>>>
 >>>> [email-masked] https://www.ietf.org/mailman/listinfo/xml2rfc
 >>>>
 >>>>
 >>>>
 >>> _______________________________________________ TOOLS-DEVELOPMENT
 >>> mailing list
 >>>
 >> _______________________________________________ xml2rfc mailing
 >> list [email-masked]
 > _______________________________________________ xml2rfc mailing list
 > [email-masked] https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Nico Williams <[email-masked]>
Date: Mon, 17 Dec 2012 18:17:12 -0600

> *) Who should do the verification?

The RFC-Editor.  Duh -- they have to anyways.  :)

> I also think it should be possible for someone to ask for a faster review of
> a particular entry.

At RFC publication time, *not* periodically.

This way it's trivial: there's a repo we all contribute to with total
freedom and no checking whatsoever, possibly including garbage, and
there's a repo that the RFC-Editor contributes to only entries that
they've verified *because* they were referenced from I-Ds that made it
to the RFC-Editor queue.

Nico
--

---

From: Alice Russo <[email-masked]>
Date: Tue, 18 Dec 2012 11:20:08 -0500

> *) Who should do the verification?

Will talk more with the RFC Series Editor and the RFC Production Center (RPC) about this.  I see these potential roles for the RPC in this experiment:
- Add: commit new Misc. refs that are used in approved I-Ds.
- Edit: correct existing Misc. refs that are used in approved I-Ds.
- Review: periodic review of the diff between bibxml2 & bibxml2exp. Copy good refs over to bibxml2.

(Perhaps we could consider a ref that is added or edited by the RPC as already reviewed, so a ref could be committed to both bibxml2 and bibxml2exp at that time.)

> *) I think the frequency should be more often than once a year. Quarterly?

Was envisioning less frequency because it gives time for entries to be added and edited in the experimental directory by the community.  The more it gets used, the more it gets updated.  For example, if authors pull a ref into their draft, and it's not correct, then there's the motivation to fix it in the library. Then, when the periodic checking occurs, hopefully the refs are in better shape.

In response to Nico's suggestion, "At RFC publication time, *not* periodically" -- useful refs are in various I-Ds, and most I-Ds do not become RFCs, so I think *more* refs than just those in RFCs should be included in the library.  I.e., the hurdle should be 'the ref was added to the exp. directory and its content is correct', not 'the ref was used in an RFC'.

> review of a particular entry.

Why would some refs need to be reviewed quickly?

Thanks,
Alice