Subject: Re: [xml2rfc] Page break in xml2rfc

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Sat, 1 Dec 2012 09:29:05 -0500

While at it:
How do I repeat table heading accross pages?
Thanks!

Best regards: Zoltán Ördögh

On Fri, Nov 30, 2012 at 9:21 PM, Charles E. Perkins
<[email-masked]>wrote:

>
> Hello folks,
>
> How do I get a page break in xml2rfc?
>
> Alternatively, how do I protect a table from getting
> a page break in the middle?
>
> --
> Regards,
> Charlie P.
>
> ______________________________**_________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 02 Dec 2012 10:41:37 +0100

I wouldn't worry about page breaks; when the document is published as 
RFC, the RFC editor team will take care about the final formatting.

(The same applies to table headers).

Best regards, Julian

On 2012-12-01 15:29, Zoltán Ördögh (GMail) wrote:
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>     Hello folks,
>
>     _________________________________________________
>     xml2rfc mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/xml2rfc
>     <https://www.ietf.org/mailman/listinfo/xml2rfc>
>
>
>
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 02 Dec 2012 07:24:24 -0800

Hello Julian,

I get your point.  But RFC publication is the last step in the process.
In the meantime, there are many months or years of review and
revision, and each time anyone reads the document, it would be
easier if the formatting were done properly.  To put the other way,
if the document would formatted properly, a lot of people would
find their job easier.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: Dave Crocker <[email-masked]>
Date: Sun, 02 Dec 2012 10:00:01 -0800

> RFC, the RFC editor team will take care about the final formatting.

Given the goal of permitting xml2rfc's being able to generate final-form 
RFC layout automatically, this doesn't seem like good strategic advice.

In other words, I believe xml2rfc ought to allow the author enough 
control to specify what sequence is not to be broken by a page boundary.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: "John Levine" <[email-masked]>
Date: 2 Dec 2012 18:30:02 -0000

>control to specify what sequence is not to be broken by a page boundary.

Yes, but for tables more than a dozen lines long, it's often better to break
them across multiple pages, in which case it's rather nice to be able to
tell it repeat the headings on each page.

nroff has offered this facility via the tbl preprocessor since about
1978, after all.

I agree that we don't want xml2rfc to turn into yet another Turing complete
formatting language, but if it's going to replace nroff as the final tool
to produce RFCs, a few more well chosen features would make it a lot easier.

R's,
John

---

From: Julian Reschke <[email-masked]>
Date: Sun, 02 Dec 2012 19:45:02 +0100

On 2012-12-02 16:24, Charles E. Perkins wrote:
> ...

I would recommend to use something more readable for reviews (-> HTML).

Best regards, Julian

---

From: Dave Crocker <[email-masked]>
Date: Sun, 02 Dec 2012 10:50:08 -0800

> tell it repeat the headings on each page.

Your note is orthogonal to mine.  I was responding to the view that we 
can/should leave tweaking to the manual last step of RFC publication.

You are, essentially, suggesting that automated pagination should have 
some extra sophistication in the (automated) handling of particularly 
long sequences of a particular type.

d/

---

From: Julian Reschke <[email-masked]>
Date: Sun, 02 Dec 2012 19:54:41 +0100

> tell it repeat the headings on each page.

Is there a single case where you *don*t want to repeat the page headers 
on subsequent pages?

> to produce RFCs, a few more well chosen features would make it a lot easier.

Well, if we change to a default output format of HTML the issue goes 
away anyway...

Best regards, Julian

---

From: Russ Allbery <[email-masked]>
Date: Sun, 02 Dec 2012 12:33:38 -0800

> Well, if we change to a default output format of HTML the issue goes

I think HTML is an inferior output format for discussion of drafts on
working group mailing lists, since it's more difficult to quote and
discuss than plain text.  You end up doing a lot of copying and pasting
and manually adding quote marks, not to mention adjusting for the fact
that copy/paste of text from web pages via browsers usually ends up
producing unreadable, mangled formatting that has to be manually
corrected.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: "John R Levine" <[email-masked]>
Date: 2 Dec 2012 17:33:17 -0500

> Is there a single case where you *don*t want to repeat the page headers on 
> subsequent pages?

Well, there are some table-like things that don't have headers.  But I 
suppose you could treat that as repeating an empty header.

> Well, if we change to a default output format of HTML the issue goes away 
> anyway...

It does and it doesn't.  Even HTML docs sometimes get printed on sheets of 
paper, and the header issue arises again.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

---

From: Nico Williams <[email-masked]>
Date: Sun, 2 Dec 2012 17:47:53 -0600

> producing unreadable, mangled formatting that has to be manually

+1.

I really want to be able to read I-Ds/RFCs on ttys, using $PAGER (less
in my case) screen(1) cut-n-paste, quote trivially on mutt, be able to
say "the second sentence in the first paragraph on page 5" and be
understood, etcetera.  It is true that tty is limiting (no images, for
example), but not too much (Unicode is fine, as are line-drawing
chars), but I can use a PDF viewer or web browser for those cases
where there are images.

That is, I think we should encourage a canonical format that is all
[Unicode] text except for those cases where non-text art images are
important.

Nico
--

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Sun, 2 Dec 2012 19:03:20 -0500

> paper, and the header issue arises again.
I have not seen a printed RFC in a long, long time.
I rarely see printed documents at all nowadays - I guess nowadays documents
are only printed when they require a signature.
Bank statements are also printed generated HTML pages - and they print just
fine with/without tables.

---

From: "John R Levine" <[email-masked]>
Date: 2 Dec 2012 19:10:12 -0500

> are only printed when they require a signature.

It's rarely helpful to assume that your experience is typical of the 
entire world.

I print documents all the time and stick them in my briefcase to read on 
the plane and other places.  Particularly for us people with old tired 
eyes, paper is still a lot easier to read than screens.

Regards,

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 2 Dec 2012 16:16:36 -0800

As most people on this list know, there is a mailing list that is discussing what is supposed to be the format for Internet Drafts. THIS IS NOT THAT LIST.

Take this over to [email-masked].

To finish the thread: there is no way currently in xml2rfc to insert page breaks.

--Paul Hoffman

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 03 Dec 2012 09:16:21 +0000

> a page break in the middle?
To actually answer your question...

You can use the processing directive needLines to get the formatter to
check there is enough space for the table on the current page and throw
a page break if not, e.g.:
<?rfc needLines=12 ?> 

Unfortunately *you* need to count the number of lines needed.

Rgards,
Elwyn

---

From: Julian Reschke <[email-masked]>
Date: Mon, 03 Dec 2012 11:28:37 +0100

On 2012-12-02 23:33, John R Levine wrote:
>> Is there a single case where you *don*t want to repeat the page
>> headers on subsequent pages?
>
> It does and it doesn't.  Even HTML docs sometimes get printed on sheets
> of paper, and the header issue arises again.

Not if you have the proper CSS attached. Try the output of rfc2629.xslt.

Best regards, Julian

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 3 Dec 2012 13:18:48 +0000

Actually, you can insert a manual page break by e.g.

    <t>
      <vspace blankLines="999"/>
    </t>

Any large number will do, 999 just stands out.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: 03 December 2012 00:17
To: [email-masked] list
Subject: [xml2rfc] PLEASE STOP: Page break in xml2rfc

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

--Paul Hoffman

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Nico Williams <[email-masked]>
Date: Mon, 3 Dec 2012 13:17:32 -0600

> Take this over to [email-masked].

The tool discussions and the RFC format discussions necessarily
overlap sometimes.  It'd have been more useful to cross-post a reply
and set Reply-To: in this case.

Nico
--