Subject: [xml2rfc] Non IETF Xref reference examples

From: "Fedyk, Donald (Don)" <[email-masked]>
Date: Fri, 30 Nov 2012 00:22:08 +0000

Hi 

This may be an old topic but I scanned the archives and could not figure out how to put in references to non-RFCs. 

I'm updating an existing XML draft but the external references were hand edited. 

For external refs that show up in informative references: I found this sort of works:

     <reference anchor="r.8021Q" target="">
        <front>
          <title>8021Q</title>

          <author>
            <organization>"IEEE Standard for Local and metropolitan area Media
            Access Control (MAC) Bridges and Virtual Bridge Local Area
            Networks. IEEE Std 802.1Q"</organization>
          </author>

          <date year="2011"/>
        </front>
      </reference>

It produces this: 

  [r.8021Q]  "IEEE Standard for Local and metropolitan area Media
              Access Control (MAC) Bridges and Virtual Bridge Local Area
              Networks. IEEE Std 802.1Q", "8021Q", 2011.

I wanted to use 8021Q as the anchor but that failed. I found ref.8021Q worked and I found I could shorten it to the above. There is an extraneous "8021Q" that must come from the title. However if I put all the text in the title it shows up in the XREF text location. Is there a way around that?   I guess I'm not using it the way it was intended. 

Is there boiler plate for non IETF references somewhere? 

Thanks,
Don

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 29 Nov 2012 18:08:44 -0800

On Nov 29, 2012, at 4:22 PM, "Fedyk, Donald (Don)" <[email-masked]> wrote:

> I wanted to use 8021Q as the anchor but that failed. I found ref.8021Q worked and I found I could shorten it to the above.

This is because (I believe) that xref links can't start with a digit.

> There is an extraneous "8021Q" that must come from the title. However if I put all the text in the title it shows up in the XREF text location. Is there a way around that?   I guess I'm not using it the way it was intended. 

You are not (but don't feel bad: many of us fudge here). An example of something that has an author, a title and (for extra credit) a URL would be:

	 <reference anchor="ASIACJK" target="http://dot.asia/policies/DotAsia-CJK-IDN-Policies-COMPLETE--2011-05-04.pdf">
	    <front><title>.ASIA CJK (Chinese Japanese Korean) IDN Policies</title>
	       <author>
		  <organization>DotAsia Organisation</organization>
	       </author>
	       <date month="May" year="2011" />
	    </front>
	 </reference>

--Paul Hoffman

---

From: Julian Reschke <[email-masked]>
Date: Fri, 30 Nov 2012 13:46:28 +0100

> Is there boiler plate for non IETF references somewhere?

As Paul pointed out, anchors can not start with a digit (because they 
are XML IDs).

Otherwise, the "8021Q" is not extraneous; after all, that's what you 
specified as title. On the other hand, you have lots of stuff in the 
<organization> element that doesn't belong there.

Best regards, Julian

---

From: Alice Russo <[email-masked]>
Date: Fri, 30 Nov 2012 09:14:39 -0500

Don,

The citation libraries listed on http://xml.resource.org include references for non-IETF documents. After W3C, JSF, and 3GPP libraries is the "Miscellaneous" library (http://xml.resource.org/public/rfc/bibxml2/), which includes references for ANSI, FIPS, IEEE, ISO, and ITU documents, among others. Generally, these references can be used as a starting point and will require an update.

Example: http://xml.resource.org/public/rfc/bibxml2/_reference.IEEE.P802-1Q.1998.xml

Potentially updated to:
<reference anchor="IEEE.802.1Q-2011">
<front>
<title>IEEE Standard for Local and metropolitan area networks -- Media Access Control (MAC) Bridges and Virtual Bridged Local Area Networks</title>
<author>
<organization>IEEE</organization>
</author>
<date year="2011" />
</front>
<seriesInfo name="IEEE Std" value="802.1Q" />
</reference>

Thanks,

Alice Russo
RFC Production Center

On Nov 30, 2012, at 7:46 AM, Julian Reschke wrote:

> As Paul pointed out, anchors can not start with a digit (because they are XML IDs).
> 
> Otherwise, the "8021Q" is not extraneous; after all, that's what you specified as title. On the other hand, you have lots of stuff in the <organization> element that doesn't belong there.
> 
> Best regards, Julian
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "Fedyk, Donald (Don)" <[email-masked]>
Date: Fri, 30 Nov 2012 15:18:11 +0000

OK Thanks all,   The examples is what I was looking for. 
 
Don 

-----Original Message-----
From: Alice Russo [mailto:[email-masked]] 
Sent: Friday, November 30, 2012 9:15 AM
To: Fedyk, Donald (Don)
Cc: xml2rfc list
Subject: Re: [xml2rfc] Non IETF Xref reference examples

Don,

Potentially updated to:

Thanks,

Alice Russo
RFC Production Center