Subject: [xml2rfc] (no subject)

From: Randy Bush <[email-masked]>
Date: Wed, 28 Nov 2012 20:51:16 +0900

i am probably just not seeing it, and the diagnostic message is a bit
obscured.  some darned resource is wanted, but durned if i can see what.

xml2rfc draft-ietf-sidr-rpki-rtr-mib.xml
Traceback (most recent call last):
  File "/usr/local/bin/xml2rfc", line 4, in <module>
    import pkg_resources
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2603, in <module>
    working_set.require(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 666, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 565, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: xml2rfc==2.3.9
make: *** [all] Error 1

sources are

randy

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Nov 2012 13:14:26 +0100

It seems something is wrong with resolving the included <reference>s.

I never use them (because I think external dependencies are simply a bad 
idea), so I can't help you with that...

Best regards, Julian

On 2012-11-28 12:51, Randy Bush wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 Nov 2012 23:02:29 +0900

> It seems something is wrong with resolving the included <reference>s.

hmmm.  of course, this always used to work :)

$ env | grep XML
XML_LIBRARY=.:/Users/randy/refs/rfc:/Users/randy/refs/id

and 

$ ls -l /Users/randy/refs
total 0
drwxr-xr-x  56074 randy  staff  1906516 Oct 26 18:31 id
drwxr-xr-x   6592 randy  staff   224128 Oct 26 03:31 rfc

randy

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Nov 2012 15:07:18 +0100

> drwxr-xr-x   6592 randy  staff   224128 Oct 26 03:31 rfc

Does xml2rfc2 works the same way as the TCL version with respect to this?

Best regards, Julian

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 Nov 2012 23:11:11 +0900

fixed by reinstalling with brew as opposed to download.

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 Nov 2012 23:12:27 +0900

> Does xml2rfc2 works the same way as the TCL version with respect to this?

best as i remember, yes

randy