Subject: Re: [xml2rfc] differences between v1 and v2 (of xml2rfc)

From: Miek Gieben <[email-masked]>
Date: Thu, 1 Nov 2012 16:19:21 +0100

[ Quoting <[email-masked]> in "[xml2rfc] differences between v1 an..." ]
> Hello,
> 
> I'm comparing the output of xml2rfc v1.36 with v2.3.5 (see
> for yourself at: 
>     v1 version: miek.nl/downloads/draft.v1.txt
>     v2 version: miek.nl/downloads/draft.v2.txt
> 
> I like v2 as it is fast! The line numbers mentioned below are those
> of draft.v2.txt.

Just found at that there is a newer version of xml2rfc (version 2.3.9),
from http://pypi.python.org/pypi/xml2rfc/2.3.9.

Apparently xml.resource.org still lists 2.3.5 as the latest version. But
the good news: 2.3.9 looks very good in my tests. In fact I only see
two differences:

* In version 1, a link like "XML of xml2rfc [1]", will be referenced
  in an "URIs" section:

    [1]  <http://xml.resource.org/>

  This is completely missing in 2.3.9

* If you have a "<t hangText="Item to explain:"><vspace/>", the following
  text is put on a new line, but the position is dependent on the previous
  text. In v1 it is just indented 3 spaces.

Roman numerals works. Yeah!

grtz Miek

---

From: Miek Gieben <[email-masked]>
Date: Thu, 1 Nov 2012 16:19:21 +0100

grtz Miek

---

From: Miek Gieben <[email-masked]>
Date: Wed, 7 Nov 2012 09:31:25 +0100

[ Quoting <[email-masked]> in "Re: [xml2rfc] differences between v..." ]
>   text. In v1 it is just indented 3 spaces.

And to add to that. Including a reference and *not* referencing it in v1, leads
to an warning/error. In v2 is silently ignoring the reference.

 Regards,

-- 
    Miek Gieben                                               http://miek.nl

---

From: Miek Gieben <[email-masked]>
Date: Wed, 7 Nov 2012 09:31:25 +0100

Regards,

---

From: Julian Reschke <[email-masked]>
Date: Wed, 07 Nov 2012 10:03:53 +0100

> to an warning/error. In v2 is silently ignoring the reference.

I don't think the developers are following this mailing list, so yo 
really should raise tickets over here: 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/report>

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 07 Nov 2012 10:03:53 +0100

Best regards, Julian

---

From: Miek Gieben <[email-masked]>
Date: Wed, 7 Nov 2012 10:10:52 +0100

[ Quoting <[email-masked]> in "Re: [xml2rfc] differences between v..." ]
> <http://trac.tools.ietf.org/tools/xml2rfc/trac/report>

http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/70

 Regards,

---

From: Miek Gieben <[email-masked]>
Date: Wed, 7 Nov 2012 10:10:52 +0100

Regards,