Subject: [xml2rfc] TOC problem

From: Subir Das <[email-masked]>
Date: Thu, 12 Jul 2012 23:51:11 -0400

I am using the follwoing options in my source and using the online tool for
conversion.

<?rfc iprnotified="yes"?>
<?rfc toc="yes" ?>
<?rfc symrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no"?>
<?rfc inline="no"?>

Getting the following toc representation instead of section title should
be referenced  to page numbers:

Table of Contents

   1.  Convention used in this document  . . . . . . . . . . . . . ancho

   2.  Terminology and abbreviations used in this document . . . . Termi

   3.  Introduction  . . . . . . . . . . . . . . . . . . . . . . . ancho

Any help will be appreciated.

thanks,
-Subir

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Jul 2012 09:36:36 +0200

On 2012-07-13 05:51, Subir Das wrote:
> I am using the follwoing options in my source and using the online tool
> for conversion.
> ...

xml2rfc.tcl makes two passes, and what you see I think is the output of 
the first pass.

How do you run it? Do you see any error messages?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Jul 2012 15:22:29 +0200

> How do you run it? Do you see any error messages?

Debugged off-list.

Lesson, once again: run your files through a proper XML parser first 
(for instance, by opening it in a browser).

Best regards, Julian