Subject: [xml2rfc] spacing out

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 20:49:37 +0900

still running tcl <blush>.  maybe i will update tomorrow, especially if
it will get me through this one.

how do i get a list element that has more than one paragraph?  e.g.

    <list style='format 2.%d'>
      <t>I can not do a close of the t after this or it will create
        a new list element.  So I try
        <vspace /><vspace />
        But it does not work.  I do not get a space between the two
	paragraphs.</t>

produces

   2.1   I can not do a close of the t after this or it will create a
         new list element.  So I try
         But it does not work.  I do not get a space between the two
         paragraphs.

randy

---

From: Miek Gieben <[email-masked]>
Date: Thu, 14 Jun 2012 13:57:10 +0200

[ Quoting <[email-masked]> in "[xml2rfc] spacing out..." ]
>         But it does not work.  I do not get a space between the two

should't that be: <vspace BlankLines='1'>

 Regards,

-- 
    Miek Gieben                                                   http://miek.nl

---

From: Miek Gieben <[email-masked]>
Date: Thu, 14 Jun 2012 13:57:10 +0200

Regards,

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 21:00:53 +0900

> should't that be: <vspace BlankLines='1'>

it demanded <vspace BlankLines='1' />

and did the same, no fix

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 21:00:53 +0900

and did the same, no fix

randy

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 15:17:00 +0200

On 2012-06-14 13:49, Randy Bush wrote:
 > ...

Known vocabulary deficit. Would be good if we finally could get back to 
work on improving it.

That being said: the "compact" processing instructions might affect this 
(just an idea; haven't tried that).

Best regards, Julian

---

From: Tom Taylor <[email-masked]>
Date: Thu, 14 Jun 2012 09:33:14 -0400

That should be <vspace blankLines="1"/>. Small 'b' to start 
'blankLines'. Works for me all the time.

On 14/06/2012 8:00 AM, Randy Bush wrote:
>> should't that be:<vspace BlankLines='1'>
>
> it demanded<vspace BlankLines='1' />
>
> and did the same, no fix
>
> randy
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tom Taylor <[email-masked]>
Date: Thu, 14 Jun 2012 09:33:14 -0400

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 15:37:08 +0200

> 'blankLines'. Works for me all the time.

Oh, indeed.

Reminder: validate your input. xml2rfc is very weak at that.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 15:37:08 +0200

Oh, indeed.

Best regards, Julian

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 22:54:56 +0900

> 'blankLines'. Works for me all the time.

no love

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 22:54:56 +0900

no love

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 22:57:24 +0900

> 'blankLines'. Works for me all the time.

worked!  had to be very literal about the " / etc.  thanks!

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Jun 2012 22:57:24 +0900

randy

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 16:06:20 +0200

> worked!  had to be very literal about the " / etc.  thanks!

Again: run your input through proper XML parsers. xml2rfc.tcl is very 
"forgiving", which doesn't help finding bugs.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Jun 2012 16:06:20 +0200

Best regards, Julian

---

From: Randy Bush <[email-masked]>
Date: Fri, 15 Jun 2012 14:41:22 +0900

> Reminder: validate your input. xml2rfc is very weak at that.

trying to move to python version (on macos lion).  can not find where to
tell it my refs files are.  clue bat, please.

randy