Subject: [xml2rfc] How do I get a local xml2rfc install to find my local copy of the citation library?

From: Keith Hazelton <[email-masked]>
Date: Sat, 07 Apr 2012 12:30:02 -0500

I'm running xml2rfc locally on a Mac OS 10.6 host and I have downloaded the RFC citation library.  The citations are now in a folder, bibxml, in the same directory as my source .xml file AND another copy of bibxml is in the same directory as the xml2rfc executable. 

When I run xml2rfc with an xml input file that contains the following:

    <note title="Requirements Language">
      <t>The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
      "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
      document are to be interpreted as described in <xref
      target="RFC2119">RFC 2119</xref>.</t>
    </note>

I get 'unable to find external file "reference.RFC.2119.xml" or "reference.RFC.2119.xml.xml"'

How do I let xml2rfc know where the citation file is to be found?  

P.S. This source file converts properly and without error using the online xml2rfc service.

       Thanks in advance for your help,  --Keith

---

From: Miek Gieben <[email-masked]>
Date: Sat, 7 Apr 2012 19:59:05 +0200

[ Quoting <[email-masked]> in "[xml2rfc] How do I get a local xml2..." ]
> How do I let xml2rfc know where the citation file is to be found?  

You have to actually include the XML from the reference in your file:

            <?rfc include="reference.RFC.2119.xml"?>

Where the argument after the include= is a path name.

> P.S. This source file converts properly and without error using the online

prolly using some smart auto-include stuff (I don't know the specifics).

 Regards,

-- 
    Miek Gieben