Subject: [xml2rfc] accepting legitimate posts from non-members?

From: Dave CROCKER <[email-masked]>
Date: Thu, 09 Feb 2012 07:55:12 -0800

Folks,

G'day.  I'm wearing my xml2rfc list co-administrator hat.

There's a legitimate message being held by the list server, because the author 
is not a member of this list.  Rather than simply let the message through, I 
thought I'd ask you folks whether there is a 'policy' that should be in place 
that allows these to be handled automatically.

There are only three paths I can think of.

    1.  One is to allow anyone to post to this list.  The rate of bogus postings 
to this list has been quite small.  So I would expect the incremental hassle 
factor on you all to be small.

    2.  Another is to create a parallel "-discuss" list, or the like, that has 
open posting.  That means posters need to know about it and it means folks here 
need to look there.

    3.  Of course, the alternative is to leave things as they are, for the 
initial posting, and let the co-administrators manually allow such legitimate 
posts by 'outsiders' through.  The burden on us isn't all that high; there are 
probably fewer of these legitimate posts than of bogus ones...  On the other 
hand, it means that any follow-up with the author will also require manual 
permission.  (Hmmm.  Or we could allow such authors to have permanent 
authorization to post; that doesn't make them 'members', so they won't get 
regular mail, but they can post followups.)

Thoughts?

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Joe Abley <[email-masked]>
Date: Thu, 9 Feb 2012 11:01:05 -0500

On 2012-02-09, at 10:55, Dave CROCKER wrote:

>   1.  One is to allow anyone to post to this list.  The rate of bogus postings to this list has been quite small.  So I would expect the incremental hassle factor on you all to be small.
> 
>   2.  Another is to create a parallel "-discuss" list, or the like, that has open posting.  That means posters need to know about it and it means folks here need to look there.
> 
>   3.  Of course, the alternative is to leave things as they are, for the initial posting, and let the co-administrators manually allow such legitimate posts by 'outsiders' through.  The burden on us isn't all that high; there are probably fewer of these legitimate posts than of bogus ones...  On the other hand, it means that any follow-up with the author will also require manual permission.  (Hmmm.  Or we could allow such authors to have permanent authorization to post; that doesn't make them 'members', so they won't get regular mail, but they can post followups.)

I think (2) is unnecessary. I think (1) would probably be fine, and if it turned out not to be fine, as measured by a chorus of complaints, we could always revert to (3).

With respect to (3), if this is mailman I think there's a handy button for "allow this post, and any future posts from this person regardless of whether they are subscribed to the list". In the case where a post from a non-subscriber triggers an active thread, that can help stop the conversation becoming stilted and confusing due to moderator lag.

Joe

---

From: Scott Lawrence <[email-masked]>
Date: Thu, 09 Feb 2012 11:12:01 -0500

On 2012-02-09 10:55 , Dave CROCKER wrote:
> There's a legitimate message being held by the list server, because 
> the author is not a member of this list.  Rather than simply let the 
> message through, I thought I'd ask you folks whether there is a 
> 'policy' that should be in place that allows these to be handled 
> automatically.
>
>    1.  One is to allow anyone to post to this list.  The rate of bogus 
> postings to this list has been quite small.  So I would expect the 
> incremental hassle factor on you all to be small.
>
>    2.  Another is to create a parallel "-discuss" list, or the like, 
> that has open posting.  That means posters need to know about it and 
> it means folks here need to look there.
>
>    3.  Of course, the alternative is to leave things as they are, for 
> the initial posting, and let the co-administrators manually allow such 
> legitimate posts by 'outsiders' through.  The burden on us isn't all 
> that high; there are probably fewer of these legitimate posts than of 
> bogus ones...  On the other hand, it means that any follow-up with the 
> author will also require manual permission.  (Hmmm.  Or we could allow 
> such authors to have permanent authorization to post; that doesn't 
> make them 'members', so they won't get regular mail, but they can post 
> followups.)

I've always found that requiring subscription to post is a good 
regulator.  I'd rather not see that requirement dropped and would 
encourage the administrators not to make exceptions.   It's really not a 
burden for someone to subscribe even just for the time it takes to get 
an issue resolved.

I don't think that one should fork a list until it's clear that you've 
got too much traffic and a clear division of interest, which I think is 
not the case here (no on #2).

---

From: Nico Williams <[email-masked]>
Date: Thu, 9 Feb 2012 10:15:51 -0600

On Thu, Feb 9, 2012 at 10:12 AM, Scott Lawrence <[email-masked]> wrote:
> I've always found that requiring subscription to post is a good regulator.
>  I'd rather not see that requirement dropped and would encourage the
> administrators not to make exceptions.   It's really not a burden for
> someone to subscribe even just for the time it takes to get an issue
> resolved.

This is extremely obnoxious for IETF lists.  Must I really subscribe
to post, when I already subscribe to tens of IETF lists?  That's just
silly.  If you'll moderate a list then add non-subscribeds to the
whitelist as they post.

Ideally any subscriber to 5 or more IETF lists should not have to
subscribe to post to any other lists (modulo bans from posting).

Nico
--

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Feb 2012 17:24:12 +0100

On 2012-02-09 17:01 Joe Abley said:
>> that has open posting.  That means posters need to know about it
>> and it means folks here need to look there.
>> 
>> the initial posting, and let the co-administrators manually allow
>> such legitimate posts by 'outsiders' through.  The burden on us
>> isn't all that high; there are probably fewer of these legitimate
>> posts than of bogus ones...  On the other hand, it means that any
>> follow-up with the author will also require manual permission.
>> (Hmmm.  Or we could allow such authors to have permanent
>> authorization to post; that doesn't make them 'members', so they
>> won't get regular mail, but they can post followups.)
> 
> I think (2) is unnecessary. I think (1) would probably be fine, and
> if it turned out not to be fine, as measured by a chorus of
> complaints, we could always revert to (3).

+1

	Henrik

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 09 Feb 2012 08:29:15 -0800

> With respect to (3), if this is mailman I think there's a handy button for "allow this post, and any future posts from this person regardless of whether they are subscribed to the list". In the cas…

Right.  That's what prompted me to think of the parenthetical enhancement to 
manual acceptance.

d/

-- 

   Dave Crocker

---

From: Joe Abley <[email-masked]>
Date: Thu, 9 Feb 2012 11:37:02 -0500

> silly.  If you'll moderate a list then add non-subscribeds to the

Oh, I had not noticed that this list now lived on IETF mail infrastructure.

I believe it's straightforward to configure individual lists as "accept posts from addresses subscribed to any IETF list, otherwise hold for moderator approval". That'd be a good additional option.

I don't remember exactly how you configure this (it's been a while since I ran the IAB list) but it's effectively a reference to an external whitelist, which itself is the cat | uniq of all subscriber lists.

Joe

---

From: Tony Hansen <[email-masked]>
Date: Thu, 09 Feb 2012 11:53:24 -0500

On 2/9/2012 11:29 AM, Dave CROCKER wrote:
>> With respect to (3), if this is mailman I think there's a handy 
>> button for "allow this post, and any future posts from this person 
>> regardless of whether they are subscribed to the list". In the case 
>> where a post from a non-subscriber triggers an active thread, that 
>> can help stop the conversation becoming stilted and confusing due to 
>> moderator lag.
>
> Right.  That's what prompted me to think of the parenthetical 
> enhancement to manual acceptance.

When the posting is a response to a thread by someone else, this is the 
option I usually pick in similar situations .

However, if they are *starting* a thread, I think it's fair to require 
them to subscribe.

     Tony Hansen

---

From: Nico Williams <[email-masked]>
Date: Thu, 9 Feb 2012 11:03:46 -0600

On Thu, Feb 9, 2012 at 10:53 AM, Tony Hansen <[email-masked]> wrote:
> However, if they are *starting* a thread, I think it's fair to require them
> to subscribe.

That's fair.

Nico
--

---

From: Joe Abley <[email-masked]>
Date: Thu, 9 Feb 2012 12:12:57 -0500

>> However, if they are *starting* a thread, I think it's fair to require them

Seems to me that the objectives ought to be:

 (1) make it easy for people to raise issues about this tool in a sensible place
 (2) avoid annoying subscribers with (too much) spam

I'd be surprised if the sweet spot involved a requirement for people to subscribe to the list when they're not interested in following anything other than discussion about their own issue.

Joe

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 09 Feb 2012 10:06:15 -0800

> I'd be surprised if the sweet spot involved a requirement for people to subscribe to the list when they're not interested in following anything other than discussion about their own issue.

+1.

For a person interested in a single query, requiring subscription strikes me as 
an onerous barrier.  Subscription makes sense for folks who intend to have 
continuing involvement.

-- 

   Dave Crocker

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 09 Feb 2012 11:29:26 -0800

> I believe it's straightforward to configure individual lists as "accept posts from addresses subscribed to any IETF list, otherwise hold for moderator approval". That'd be a good additional option.

I am not aware of any existing mechanism for IETF lists or the underlying 
software it uses, to accomplish this.

d/
-- 

   Dave Crocker

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Feb 2012 08:40:32 +1300

On 2012-02-10 04:55, Dave CROCKER wrote:

> legitimate posts by 'outsiders' through.  

As long as you click the button to whitelist the poster, this is
a *very* low cost solution. The lists I administer have several
co-admins and the resulting workload is negligible, and the spam
load for subscribers is nil

Please don't open the list. It will be quiet at first but progressively
the spam will increase. I speak from experience.

   Brian

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 09 Feb 2012 11:58:24 -0800

Folks,

Although comments have represented the full range of possibilities -- always a 
shock, given the IETF's tendency towards narrow and conformist opinions -- I've 
seen enough of a pattern to believe the adequate (ie, safest) path for this list 
is to:

      a) keep regular posting limited to subscribers, and

      b) Allow the list administrators to mark authors of legitimate 
non-subscribers for continuing posting rights.

Thanks.

d/

-- 

   Dave Crocker

---

From: Glen Zorn <[email-masked]>
Date: Fri, 10 Feb 2012 14:41:09 +0700

On 2/10/2012 2:58 AM, Dave CROCKER wrote:
> Although comments have represented the full range of possibilities --
> always a shock, given the IETF's tendency towards narrow and conformist
> opinions -- I've seen enough of a pattern to believe the adequate (ie,
> safest) path for this list is to:
> 

Seems reasonable to me.

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Fri, 10 Feb 2012 10:33:47 -0500

How would the non-subscribers ever receive a response/follow up on the
topic they posted?

Best regards: Zoltán Ördögh

On Thu, Feb 9, 2012 at 2:58 PM, Dave CROCKER <[email-masked]> wrote:

> ______________________________**_________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>

---

From: Nico Williams <[email-masked]>
Date: Fri, 10 Feb 2012 09:44:25 -0600

On Fri, Feb 10, 2012 at 9:33 AM, Zoltán Ördögh (GMail) <[email-masked]> wrote:
> How would the non-subscribers ever receive a response/follow up on the topic
> they posted?

By getting Cc'ed.  Also by looking at the web archives of the list.

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 10 Feb 2012 09:19:40 -0800

"reply all".  they get cc'd.

d/

-- 

   Dave Crocker

---

From: Nico Williams <[email-masked]>
Date: Fri, 10 Feb 2012 11:46:35 -0600

> "reply all".  they get cc'd.

Which reminds me: never, ever configure a list to set Reply-To:.