Subject: [xml2rfc] Conversion errors

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Fri, 3 Feb 2012 14:56:48 -0500

Hi all,
I have a few issues, I try to put them in the same email.

Basic stuff:
I am using 1.3.6 offline (there's no newer offline version available for
download).
I am using 1.3.6 online, too (there's an error that that does not allow
running the development version; see attachment: xml2rfc-dev-error.png; see
transcript in 'PS' at the end of this mail).
I attached my draft so you can run some the same tests.

When I use 1.3.6 offline, I get this error:
artwork outdented 1 characters to avoid overrunning right margin around
input line 231
This is meaningless because I have no clue which line is too long - my
editor shows that all lines are shorted than 72.
So, I tried using the online tool (1.3.6).

With the default settings, I get this:
Unable to Validate File

INPUT: 417 ms (379 elems, 309 attrs, 7265 spaces, 28061 chars)
[Error] INPUT:693:25: The content of element type "front" is
incomplete, it must match
"(title,author+,date,area*,workgroup*,keyword*,abstract?,note*)".

To proceed, you should fix your input file.
You may also try doing the conversion with Strict Checking turned off.

------------------------------
Apache/2.2.21 (Debian) Server at xml.resource.org Port 80
This *looks* wrong to me because the structure does, in fact, match: title
(1x), author (1x), date (1x), area (1xEMPTY), workgroup (1xEMPTY), abstract
(1x), note (1x).
Something that might be work looking into.
Anyway, I go back, I change 'strict' to 'fast', and try again.
I get no messages of any kind. No errors, no warnings.

How can I figure out the reason for the figure being considered too wide?
Do I need to or is this fine?

Thank you.

PS. here's the transcript of the error from 2.2.3 in case it is useful:

Generating Text output in ASCII format Expanding internal references and
generating txt
------------------------------

Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5
Traceback (most recent call last):
  File "/home/tonyh/bin/xml2rfc", line 4, in <module>
    import pkg_resources
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2711,
in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 584, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: xml2rfc==2.2.3

------------------------------

File is gone -- did you click reload?
------------------------------
Apache/2.2.21 (Debian) Server at xml.resource.org Port 80
Best regards: Zoltán Ördögh

---

From: Julian Reschke <[email-masked]>
Date: Fri, 03 Feb 2012 23:25:26 +0100

On 2012-02-03 20:56, Zoltán Ördögh (GMail) wrote:
> running the development version; see attachment: xml2rfc-dev-error.png;
> see transcript in 'PS' at the end of this mail).

72 is too much :-)

> [Error] INPUT:693:25: The content of element type"front"  is incomplete, it must match"(title,author+,date,area*,workgroup*,keyword*,abstract?,note*)".
>
>
> Apache/2.2.21 (Debian) Server at xml.resource.org
> <http://xml.resource.org> Port 80
>
>
> This *looks* wrong to me because the structure does, in fact, match:
> title (1x), author (1x), date (1x), area (1xEMPTY), workgroup (1xEMPTY),
> abstract (1x), note (1x).

It's about the <front> element in the OMA-SPAMREP reference.

> Do I need to or is this fine?

If you don't reduce the width xml2rfc will outdent the artwork, which 
may look funny.

Also: you may want to remove <area/> and <workgroup/>; they are optional 
anyway.

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Tue, 14 Feb 2012 11:15:45 -0500

Hi Julian,
thank you, I fixed all issues.

Would it be possible to fix the invalid line numbers on the error messages?

Would it be possible to add more information to the error messages?
Say: Max. 69 characters per line allowed.

On Fri, Feb 3, 2012 at 5:25 PM, Julian Reschke <[email-masked]>wrote:

>> [Error] INPUT:693:25: The content of element type"front"  is incomplete,
>> it must match"(title,author+,date,**area*,workgroup*,keyword*,**
>> abstract?,note*)".
>>
>>
> If you don't reduce the width xml2rfc will outdent the artwork, which may
> look funny.
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 14 Feb 2012 18:02:13 +0100

> Would it be possible to fix the invalid line numbers on the error messages?

If you're willing to debug an unmaintained XML parser written in TCL, go 
ahead :-)

> On Fri, Feb 3, 2012 at 5:25 PM, Julian Reschke <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         [Error] INPUT:693:25: The content of element type"front"  is
>         incomplete, it must match"(title,author+,date,
>         area*,workgroup*,keyword*, abstract?,note*)".
>
>
>         <http://xml.resource.org>
>     If you don't reduce the width xml2rfc will outdent the artwork,
>     which may look funny.
>
>     Also: you may want to remove <area/> and <workgroup/>; they are
>     optional anyway.
>
>
>
>         Thank you.
>

---

From: Tom Taylor <[email-masked]>
Date: Tue, 14 Feb 2012 13:09:51 -0500

I considered the problem a while back. The trouble is that the TCL 
version reads in the XML input in such a way that it loses track of the 
line numbers in the original file.

On 14/02/2012 12:02 PM, Julian Reschke wrote:
>...

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Tue, 14 Feb 2012 13:39:41 -0500

Could it be replaced with libxml?
http://xmlsoft.org

On Tue, Feb 14, 2012 at 1:09 PM, Tom Taylor <[email-masked]>wrote:

> I considered the problem a while back. The trouble is that the TCL version
> reads in the XML input in such a way that it loses track of the line
> numbers in the original file.
>
>
> ______________________________**_________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>

---

From: Tom Taylor <[email-masked]>
Date: Tue, 14 Feb 2012 15:29:50 -0500

There's no point in doing that now that version 2 of XML2RFC is available.

On 14/02/2012 1:39 PM, Zoltán Ördögh (GMail) wrote:
> On Tue, Feb 14, 2012 at 1:09 PM, Tom Taylor<[email-masked]>wrote:
>

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Tue, 14 Feb 2012 16:37:34 -0500

It is? Hmmm. I still see 1.36 only - even after refreshing the page.
Could you provide a direct download link, please?
Thank you.

On Tue, Feb 14, 2012 at 3:29 PM, Tom Taylor <[email-masked]>wrote:

>> On Tue, Feb 14, 2012 at 1:09 PM, Tom Taylor<tom.taylor.stds@gmail.**com<[email-masked]>
>> >wrote:
>>
>>> version
>>>>  ______________________________****_________________
>>> xml2rfc mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/****listinfo/xml2rfc<https://www.ietf.org/mailman/**listinfo/xml2rfc>
>>> <https://www.**ietf.org/mailman/listinfo/**xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>>> >
>>>
>>>
>>

---

From: Tom Taylor <[email-masked]>
Date: Tue, 14 Feb 2012 20:00:18 -0500

http://xml.resource.org/authoring/xml2rfc2-dev.tgz

Current development release, version 2.2.3.

But the page that link is taken from says it is still buggy.

On 14/02/2012 4:37 PM, Zoltán Ördögh (GMail) wrote:
> On Tue, Feb 14, 2012 at 3:29 PM, Tom Taylor<[email-masked]>wrote:
>

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Tue, 14 Feb 2012 23:39:47 -0500

Hi Tom,
thank you.
This appears to be the source (Python) - which poses a problem because I
have no clue how to run it on my PC (no Python here).
Any chance to build a win32 or a TCL binary from this?
Thank you.

On Tue, Feb 14, 2012 at 8:00 PM, Tom Taylor <[email-masked]>wrote:

> http://xml.resource.org/**authoring/xml2rfc2-dev.tgz<http://xml.resource.org/authoring/xml2rfc2-dev.tgz>
>
>> On Tue, Feb 14, 2012 at 3:29 PM, Tom Taylor<tom.taylor.stds@gmail.**com<[email-masked]>
>> >wrote:
>>
>>>> On Tue, Feb 14, 2012 at 1:09 PM, Tom Taylor<tom.taylor.stds@gmail.***
>>>> *com<[email-masked]**>
>>>>
>>>>  wrote:
>>>>>
>>>>
>>>>>>  ______________________________******_________________
>>>>>>
>>>>> xml2rfc mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/******listinfo/xml2rfc<https://www.ietf.org/mailman/****listinfo/xml2rfc>
>>>>> <https://**www.ietf.org/mailman/****listinfo/xml2rfc<https://www.ietf.org/mailman/**listinfo/xml2rfc>
>>>>> >
>>>>> <https://www.**ietf.org/**mailman/listinfo/**xml2rfc<http://ietf.org/mailman/listinfo/**xml2rfc>
>>>>> <htt**ps://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>>>>> >
>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>

---

From: "John Levine" <[email-masked]>
Date: 15 Feb 2012 04:48:47 -0000

>have no clue how to run it on my PC (no Python here).

Python is a small interpreted language that is easy to install on Windows.
You can get installers here:

http://www.python.org/download/windows/

>Any chance to build a win32 or a TCL binary from this?

At this point, I hope people are putting effort into shaking the bugs
out of the new python version rather than fiddling with the old TCL.

-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: Tony Hansen <[email-masked]>
Date: Wed, 15 Feb 2012 00:14:49 -0500

The line numbers are invalidated because of the include processing that 
is performed in the first pass.

     Tony Hansen
     [email-masked]