Subject: [xml2rfc] abacknaur.org ?

From: Dave Crocker <[email-masked]>
Date: Tue, 28 Feb 2012 07:37:59 -0800

Folks,

This is a kind of market research query.

I periodically get queries about what ABNF parsers there are, and the IETF 
errata log now has an entry for a testing engine for ABNF.

I'm not aware of an ABNF homesite, which is the kind of place such things are 
usually listed.  If anyone knows of one, what is it's URL.

If no one knows of such a site, do you think it would be helpful to form one? 
abnf.* are taken.  My current thought is abacknaur.org but better choices are 
welcome.

Thoughts?

Thanks

d/

ps. no this isn't an ABNF list, but there isn't one.

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "John Levine" <[email-masked]>
Date: 28 Feb 2012 23:30:18 -0000

>abnf.* are taken.  My current thought is abacknaur.org but better choices are 

How about abnf.biz or, since you live in the US, abnf.us ?  Or a-bnf.com 
or a-bnf.org ?

Or perhaps the IETF could be persuaded to lend you abnf.ietf.org since
the IETF is by far the main place that cares about ABNF.

R's,
John

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Feb 2012 19:09:49 -0600

> the IETF is by far the main place that cares about ABNF.

It'd sure be nice if we had a standard way to extract ABNF (and other
things) from RFCs and have idnits check them for correctness on
upload.

The NFS RFCs, for example, encode XDR in the text of the RFC such that
a trivial Unix command-line can extract the XDR.  I think we should
encourage this approach for all syntax that is possible to validate.

There's enough opensource that the IETF tools team could easily
provide validators for ABNF, ASN.1, XDR, XML Schema, JSON Schema, and
so on.  Of course, putting that together will be a PITA.  But it'd
sure be nice!

Nico
--

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Tue, 28 Feb 2012 20:15:08 -0500

augmented.backus-naur.org

Best regards: Zoltán Ördögh

On Tue, Feb 28, 2012 at 8:09 PM, Nico Williams <[email-masked]>wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 29 Feb 2012 08:22:24 +0100

On 2012-02-29 02:09, Nico Williams wrote:
> On Tue, Feb 28, 2012 at 5:30 PM, John Levine<[email-masked]>  wrote:

http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#extract-artwork

> encourage this approach for all syntax that is possible to validate.

See above; put it into artwork and have a well-known type attribute.

> ...

Best regards, Julian

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 29 Feb 2012 08:34:01 +0000

Hi,

> things) from RFCs and have idnits check them for correctness on

it's far from a "standard way", but by idreview script (http://eggert.org/software/idreview) has some code for this, using Bill Fenner's bap/aex (http://code.google.com/p/bap/). Search for "abnf" in the script.

(No guarantees - I haven't really used the script since I stepped down from the IESG.)

Lars

---

From: Dave Crocker <[email-masked]>
Date: Wed, 29 Feb 2012 06:40:08 -0800

> the IETF is by far the main place that cares about ABNF.

Work in the IETF is a segment of a technology's lifecycle.  ABNF exists 
independent of the IETF, even if the IETF is the only place that uses it -- and 
I've no idea whether it is.  So I automatically think it's best to follow the 
usual model of having a 'home' for the technology that is independent.  If folks 
think otherwise, please speak up.

For example, abnf.ietf.org would probably be a less hassle than an independent 
site.   Since the site would need ongoing administration, less hassle is appealing.

But the basic question is whether this is worth the effort?

As for the name, a-bnf.org is in the direction I want when thinking about this 
more, but I'm concerned that the hyphen is too subtle.

augmentedbnf.org and augmented-bnf.org appear to both be available.

Thoughts?

d/

-- 

   Dave Crocker

---

From: Tony Li <[email-masked]>
Date: Wed, 29 Feb 2012 08:31:13 -0800

> Thoughts?

CNAMEs are cheap.  All of the above.

Tony