Subject: [xml2rfc-dev] Warning messages - How to address?

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 2 Feb 2022 10:38:03 -0800

I am seeing the following warning messages using the latest version of xml2rfc (3.12.1). Do not know how to address them. Can anyone help? Thanks.

% xml2rfc draft-ietf-netconf-https-notif-09.xml -o draft-ietf-netconf-https-notif-09.txt --text
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-other.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-other.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-other.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.
Warning: /usr/local/lib/python3.8/dist-packages/xml2rfc/templates/rfc2629-other.ent is no longer needed as the special processing of non-ASCII characters has been superseded by direct support for non-ASCII characters in RFCXML.

Mahesh Jethanandani
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Thu, 3 Feb 2022 08:15:15 +1300

Hi Mahesh

The tl;dr is that you do not need the DOCTYPE statement that includes a .ent file.  Read https://authors.ietf.org/en/templates-and-schemas#character-entities for a fuller explanation.

Jay

> On 3/02/2022, at 7:38 AM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Thu, 3 Feb 2022 09:31:55 +0200

> The tl;dr is that you do not need the DOCTYPE statement that includes a .ent file.  Read https://authors.ietf.org/en/templates-and-schemas#character-entities for a fuller explanation.

Maybe that could be added to the warning message?

Thanks,
Lars