Subject: Re: [xml2rfc-dev] --table-borders

From: Bob Briscoe <[email-masked]>
Date: Thu, 3 Feb 2022 02:06:43 +0000

Robert,

Coincidentally, I was just about to mail this list to ask about table 
borders when I saw this recent thread.

Q1. Is it possible to render an rfc xml v3 table with no horizontal 
borders except at a transition between header and body and at the 
top/bottom?
Example of what I'm looking for: Table 2 here: 
https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-accurate-ecn-15#section-3.1.2 
which was produced with v2 xml.

Q2. Is this table borders option you mention now supported? And if so, 
is it available in the code running at 
https://xml2rfc.tools.ietf.org/experimental.html ?
And what is the syntax, or where is it documented?

Guessing from what Henrik wrote in the ticket ( 
https://trac.ietf.org/trac/xml2rfc/ticket/527 ) it sounds like the 
mapping from v2 texttable style attribute to these v3 table borders is 
approximately as tabulated below (* = default):

v2	v3
---------------
all	full*
full*	light
headers	minimal
none	n/a?

If I'm right, I'm looking for how to use the 'light' border format.

Bob

On 28/01/2022 19:38, Robert Sparks wrote:
>
> On 1/28/22 1:22 PM, Alice Russo wrote:
>>> On Jan 26, 2022, at 2:48 PM, Robert Sparks <[email-masked]> 
>>> wrote:
>>>
>>>> Somebody wanted the —table-borders feature, or it wouldn’t have 
>>>> been implemented.
>>> The RPC asked Henrik to implement it as an experiment for a 
>>> document, and it ended up not being used.
>> To clarify, I submitted this ticket 
>> (https://trac.ietf.org/trac/xml2rfc/ticket/527), and -- in addition 
>> to the corresponding fix -- the table-borders option was created. 
>> IIRC, the RPC did not ask for the feature.
> Thanks for the clarification and apologies for my misrepresentation.
>>
>> As noted, it has never been used for producing an RFC.
>>
>> Thanks,
>> Alice
>> _______________________________________________
>> xml2rfc-dev mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/xml2rfc-dev
>
> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev

-- 
________________________________________________________________
Bob Briscoehttp://bobbriscoe.net/

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 3 Feb 2022 02:49:11 +0000

Robert,

With v3 rfc xml, is it possible to render a table (or figure) without 
any caption at all?
An example of what I'm trying to achieve:
This IANA section using v2 rfc xml: 
https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-accurate-ecn-15#section-7

With v2 rfc xml, tables or figures with no anchor or title were 
automatically not given a number or caption.
But with v3, one gets a caption saying, say, 'Table 5' on its own.

Thx in advance.

Bob

PS. Here are other similar examples of tables in IANA sections without a 
caption - they predate rfc xml
     https://www.rfc-editor.org/rfc/rfc5304.html#section-4
     https://datatracker.ietf.org/doc/html/rfc2474#section-6

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 3 Feb 2022 09:33:00 +0100

> But with v3, one gets a caption saying, say, 'Table 5' on its own.

-> <https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/14>

Best regards, Julian

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 3 Feb 2022 13:47:47 +0000

Thx Julian,

I'm not surprised this had already been raised - I searched for a couple 
of hours but didn't find anything - I probably should have searched harder.

In issue #14 that you pointed me to, I've suggested that this issue is 
not labelled as a feature request, given it is about restoring a feature 
that was in v2 and used in ~50% of cases, but omitted from v3.

Bob

---

From: Julian Reschke <[email-masked]>
Date: Thu, 3 Feb 2022 14:52:36 +0100

> that was in v2 and used in ~50% of cases, but omitted from v3.

And even in 2017.

I agree that this is a regression; the label was set by StPeter and I
have no sufficient privileges to change it.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Feb 2022 13:32:22 +0100

> have no sufficient privileges to change it.

And it isn’t changed yet.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Feb 2022 14:03:35 +0100

> And it isn’t changed yet.

The funny thing, of course, is that every RFC published since 8650 carries the suppress-title attribute on each figure and each table.  It is just always set to false.  So fixing this regression wouldn’t even need a grammar change; we would just need to remove the code that deletes suppress-title attributes in v2v3.py and delete line 984 and 985 in writers/base.py.

(Note that suppress-title is implemented in v2v3 for figures by simply stripping the <figure tag around an artwork.)

(It is also interesting that the attribute name suppress-title uses kebab-case and not camelCase.  Apparently, this was in xml2rfcv1, so I lack the archeology to trace this further.)

Grüße, Carsten