Subject: [xml2rfc-dev] xml2rfc unable to resolve recently-submitted IDs

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 6 Apr 2021 17:39:45 +0000

Hello, on 3/24/2021 I submitted two new -00 ID's found here:

https://datatracker.ietf.org/doc/draft-templin-6man-aero/
https://datatracker.ietf.org/doc/draft-templin-6man-omni/

The drafts have since undergone a couple of version updates since the
initial submission. When I try to cite them in an XML draft, however,
xml2rfc flags an error and reports:

Unable to resolve external request: "reference.I-D.templin-6man-aero"
Unable to resolve external request: "reference.I-D.templin-6man-omni"

Does xml2rfc need to be updated to pick up the new draft citations?

Thanks - Fred

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 6 Apr 2021 23:10:06 +0200

> https://datatracker.ietf.org/doc/draft-templin-6man-omni/

You might be running into issues around tools.ietf.org, which is not always updating at the rate needed.

You can use

https://datatracker.ietf.org/doc/bibxml3/draft-templin-6man-aero/xml
https://datatracker.ietf.org/doc/bibxml3/draft-templin-6man-omni/xml

as your bibxml references instead.

Grüße, Carsten

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 6 Apr 2021 21:59:00 +0000

Thanks Carsten, but I am not familiar with working directly with the bibxml3
files. Currently in my draft xml source file I have:

      <?rfc include="reference.I-D.templin-6man-aero"?>
      <?rfc include="reference.I-D.templin-6man-omni"?>

which are failing to find the references at the default locations. How do I
revise those entries to point to the alternate locations you provided?

Fred

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: Tuesday, April 06, 2021 2:10 PM
> To: Templin (US), Fred L <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: [EXTERNAL] Re: [xml2rfc] xml2rfc unable to resolve recently-submitted IDs
> 
> EXT email: be mindful of links/attachments.
> 
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Apr 2021 00:57:08 +0200

I hope someone who is more familiar with xml2rfc can answer this authoritatively.

When I was still using xml2rfc directly, I used the canonical way based on XML entities as described on slide 37 of
https://www.rfc-editor.org/materials/tools_ids_rfcs_94.pdf

Replace the URI after the SYSTEM with the one I gave below.

(Of course, I have been authoring I-Ds with kramdown-rfc for a decade now, and all this is handled behind the scene.)

However, I don’t know how much of the PI stuff (<?rfc…) survived into the RFCXMLv3 age, so maybe you want to switch to entities anyway.

Grüße, Carsten

> On 2021-04-06, at 23:59, Templin (US), Fred L <[email-masked]> wrote:
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 7 Apr 2021 14:54:33 +0000

On 4/6/2021, 5:11 PM, "xml2rfc-dev on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    You can use

I just delivered a fix to the bibxml3/bibxml-ids issue on the xml2rfc.tools.ietf.org servers.

	Tony

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 7 Apr 2021 15:21:31 +0000

Tony et al, thank you for your attention to this and for the helpful insights.

Fred

> From: HANSEN, TONY L [mailto:[email-masked]]
> Sent: Wednesday, April 07, 2021 7:55 AM
> To: Carsten Bormann <[email-masked]>; Templin (US), Fred L <[email-masked]>
> Cc: [email-masked]; [email-masked]; Robert Sparks <[email-masked]>; Henrik Levkowetz <[email-masked]>
> Subject: Re: [xml2rfc-dev] [xml2rfc] xml2rfc unable to resolve recently-submitted IDs
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 12 Apr 2021 15:33:28 +0000

> I just delivered a fix to the bibxml3/bibxml-ids issue on the xml2rfc.tools.ietf.org servers.

Hi Tony, it was working for a while after your posted this message but now
once again I am unable to resolve the new draft references. Has something
changed such that the system has reverted - if so, can you re-apply the fix?

Thanks - Fred

> Subject: [EXTERNAL] Re: [xml2rfc-dev] [xml2rfc] xml2rfc unable to resolve recently-submitted IDs
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 12 Apr 2021 17:10:41 +0000

I've been trying out various draft references and not seeing any problems.

I noticed a LOT of invalid draft references in the logs, using the wrong bibxml directories.

Can you share a bibxml3 or bibxml-ids reference that does not work properly?

Thanks

	Tony