Subject: [xml2rfc-dev] progressing RFC 7991 (and friends)

From: Julian Reschke <[email-masked]>
Date: Fri, 5 Jun 2020 13:14:21 +0200

Hi there,

I'd like to remind people over here that RFC 7991 (the V3 vocab spec) is
under active development, see:

   https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis

You can find an HTML version here:
<https://greenbytes.de/tech/webdav/draft-iab-rfc7991bis-latest.html>.
Plain text diffs compared to the latest published draft are over here:
<https://greenbytes.de/tech/webdav/draft-iab-rfc7991bis-latest-from-previous.diff.html>.

It would be nice to get some feedback about the issues we've closed far,
and also to collect more feedback in new issues.

Best regards, Julian

PS: there's no similar activity (yet) on the other v3 specs, but it
would be good to progress them as well.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 Jun 2020 14:41:26 +0200

Hi Julian,

what is the decision process (who are the WG chairs)?

> <https://greenbytes.de/tech/webdav/draft-iab-rfc7991bis-latest-from-previous.diff.html>.

To enable starting to work on this, a diff from RFC 7991 itself would be useful.

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Fri, 5 Jun 2020 15:07:06 +0200

> what is the decision process (who are the WG chairs)?

There is no WG, just interested people. All changes since 2020 have been
applied by John Levine (who is the document's official author since he
started as TRSE).

That said, I agree that more structure would be good here.

For now, I'd be happy if more people would be paying attention and
provide feedback.

> To enable starting to work on this, a diff from RFC 7991 itself would be useful.

Right now, we have
<https://greenbytes.de/tech/webdav/draft-iab-rfc7991bis-latest.html#rfc.section.E>,
and you can also check previous changes in:

https://tools.ietf.org/rfcdiff?url2=draft-iab-rfc7991bis-00.txt
https://tools.ietf.org/rfcdiff?url2=draft-iab-rfc7991bis-01.txt
https://tools.ietf.org/rfcdiff?url2=draft-iab-rfc7991bis-02.txt
https://tools.ietf.org/rfcdiff?url2=draft-iab-rfc7991bis-03.txt

That said, if you want a diff between "latest" and 7991, I can generate
that as well.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 5 Jun 2020 15:16:59 +0200

On 05.06.2020 15:07, Julian Reschke wrote:
> ... > That said, if you want a diff between "latest" and 7991, I can generate
> that as well.
> ...

Here you go:
<https://greenbytes.de/tech/webdav/draft-iab-rfc7991bis-latest-from-rfc7991.diff.html>
(linked from <https://greenbytes.de/tech/webdav/#draft-iab-rfc7991bis>).

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 Jun 2020 15:23:27 +0200

> applied by John Levine (who is the document's official author since he

OK, that works for me (while we wait for the below to happen).

> For now, I'd be happy if more people would be paying attention and

Will try to.

Just as a random data point, my biggest problem with V3 at the moment is that I only can use a subset of human names in acknowledgements or other running text (I want to use Vigenère ciphers! :-); doing some more work here would be appreciated.

(The other work that is sorely needed is embracing standard typography for English; I’m not holding my breath here.)

> That said, if you want a diff between "latest" and 7991, I can generate

Actually, what I’d *really* want is that, with the section numbering noise removed.
(I just looked at the diff you linked, and it is drowned in that kind o fnoise.)
[I said *what* I want, not that I have any idea how to get it.]

Thank you for keeping up this work!

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Fri, 5 Jun 2020 15:32:43 +0200

> Just as a random data point, my biggest problem with V3 at the moment is that I only can use a subset of human names in acknowledgements or other running text (I want to use Vigenère ciphers! :-);…

I agree that xml2rfc's approach to disallow non-ASCII except in very
limited cases is problematic.

It would be good open a ticket about that, even if the actual change in
xml2rfc causing this (the introduction of <u>) is still not part of RFC
7991, and thus (pedantically speaking) not really an issue in rfc7991bis.

> (The other work that is sorely needed is embracing standard typography for English; I’m not holding my breath here.)

Hyphens and quotes?

RFC 7991 really is agnostic about that; this would be input for the
revision of the style guide (which needs to happen as well, and in
coordination with 7991bis).

> [I said *what* I want, not that I have any idea how to get it.]

In that case, looking at the Changes section might give you a
easier-to-process summary.

Best regards, Julian

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 5 Jun 2020 11:11:27 -0400

> On Jun 5, 2020, at 9:32 AM, Julian Reschke <[email-masked]> wrote:
> 

It seems like we all agree on this but it never changes.

xml2rfc should not be doing any non-ascii checking anywhere.

v3 documents should be UTF-8.

Tom

---

From: Julian Reschke <[email-masked]>
Date: Fri, 5 Jun 2020 17:58:38 +0200

> v3 documents should be UTF-8.

All I can say is that my recollection of the discussions was that we did
not want to enforce anything about non-ASCII characters in grammar or
implementation.

<u> was first discussed as feature to make it easier to talk about
non-ASCII characters (automatically inserting long names, etc), with
which I agree. Disallowing non-ASCII outside <u> (and example
artwork/sourcecode) IMHO goes too far.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 Jun 2020 18:38:02 +0200

> v3 documents should be UTF-8.

Yes.  And there may still be a *style guide* entry to limit gratuitously going overboard on this, and requiring the document to be readable based on Latin reading skills only.
RFC 20 is not relevant in any case.

Grüße, Carsten

---

From: "John Levine" <[email-masked]>
Date: 5 Jun 2020 16:34:49 -0400

>That said, I agree that more structure would be good here.

At this point, we are still trying to catch up with the differences
between what's in 7991 and what's actually implemented in xml2rfc and
in published XML RFCs.

Once that's under control then we can address change management both
going forward and retrospectively.