Subject: [xml2rfc-dev] Unicode in references

From: "Martin Thomson" <[email-masked]>
Date: Thu, 12 Dec 2019 14:01:18 +1100

A recent change (I know not where, because the reference has been working for a while) resulted in the following warning:

draft-ietf-quic-tls.xml(1736): Error: Found non-ascii content in <seriesInfo> attribute value name="Advances in Cryptology – CRYPTO 2019"

This looks fine, until you realize that the apparent hyphen is instead an en-dash (U+2013).  I don't know if this was a change in the source reference, or whether this is a new change in xml2rfc, but I suspect that it is the latter.  xml2rfc produces this warning, but I'm seeing 2.36.0 (in CI) shows no such warning.  The text produced by xml2rfc 2.36 includes ASCII 45 (hyphen) for the same character.

Given that it is just a matter of time before this change makes it way to CI, I'd like to understand where this restriction came from.  And what I might do about it.

For reference, the DOI is 10.1007/978-3-030-26948-7_9 and this is the only non-ASCII character I was able to find in the reference other an "ö" in an author's first name (so that isn't ultimately rendered).

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 12 Dec 2019 07:36:15 +0100

Hi Martin,

This was a change in 2.37.0; attribute downcoding was too aggressive and
also affected attributes that legitimately could have non-ASCII content.

Clearly the change then went too far, and didn't downcode things that should
have been downcoded.

I'll use more discrimination in the upcoming bugfix release.

	Henrik