Subject: [xml2rfc-dev] consensus=true warning

From: "Martin Thomson" <[email-masked]>
Date: Mon, 18 Nov 2019 09:02:27 +0800

draft-ietf-quic-transport.xml(9): Warning: Setting consensus="true" for IETF STD document (this is not the schema default, but is the only value permitted for this type of document)

I don't think that this warning is useful, but I think that it could be indicative of a problem.  If this is NOT a problem, I don't want to see the warning.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Nov 2019 02:38:33 +0100

Hi Martin,

On 2019-11-18 02:02, Martin Thomson wrote:
> draft-ietf-quic-transport.xml(9): Warning: Setting consensus="true"
> for IETF STD document (this is not the schema default, but is the
> only value permitted for this type of document)
> 
> I don't think that this warning is useful, but I think that it could
> be indicative of a problem. If this is NOT a problem, I don't want to
> see the warning.

Provide a consensus setting in the file, and you won't see it.

This is the result of RFC 7998 requiring the preptool to set all attributes
that aren't set, but have a default value, to the default value.  Since the
tool should really not assert something that only the author is able
to properly say (does this document have consensus or not) there is a
warning.

	Henrik

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 18 Nov 2019 09:59:19 +0800

> to properly say (does this document have consensus or not) there is a

As the warning says, the only valid value is "true".  So why do I get a warning when I choose to rely on the default?  

Note that I also get this warning if I set the value to "false", but as I am generating Internet-Drafts, I don't believe that to be appropriate.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Nov 2019 03:04:41 +0100

On 2019-11-18 02:59, Martin Thomson wrote:
> As the warning says, the only valid value is "true".  So why do I get
> a warning when I choose to rely on the default?

Because the default is "false".

> Note that I also get this warning if I set the value to "false", but
> as I am generating Internet-Drafts, I don't believe that to be
> appropriate.

Right.  I think the schema authors made a mistake in giving this field a
default value.

	Henrik

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 18 Nov 2019 10:09:17 +0800

> Right.  I think the schema authors made a mistake in giving this field a

So you are saying that if I set a value of false explicitly, then you are unable to distinguish this from the default AND that this is my fault?

Or am I confused.

Also, where do you get the idea that status="standard" + consensus="false" is invalid?  That is always true for a draft.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Nov 2019 03:19:14 +0100

On 2019-11-18 03:09, Martin Thomson wrote:
> So you are saying that if I set a value of false explicitly, then you
> are unable to distinguish this from the default AND that this is my
> fault?

?? No, that's not at all what I'm trying to say.  I'm not trying to blame
you at all, in any way.  I'm trying to explain that the warning is there
as a result of having a default value for a field which probably should
not have one, and the preptool phase being required to set that value if
no value has been set.

> Or am I confused.
> 
> Also, where do you get the idea that status="standard" +
> consensus="false" is invalid?  That is always true for a draft.

The schema default values make no distinction between drafts and RFCs.

My preference would be to have a default value for this attribute, as it
causes multiple issues.  Since pretty much every issue I tried to bring
to this list because I saw that it needed change resulted in hours and
hours of interminable discussions, I had to choose between getting the v3
tools out, or sit and discuss forever.  The warning is my way of not
sweeping this issue under the mat.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Nov 2019 03:24:48 +0100

Correction:

> My preference would be to have a default value for this attribute, as it

My preference would be to NOT have a default value for this attribute ...

> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 Nov 2019 10:52:20 +0800

> Also, where do you get the idea that status="standard" + consensus="false" is invalid?  That is always true for a draft.

That is part of the schizophrenia we are suffering from:
RFCXMLv3 is designed for the publishing version of RFCs, but by far its largest use is for the authoring version of Internet-Drafts.  Until we get more explicit about these distinctions, we will run into many more of this kind of problems.

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Mon, 18 Nov 2019 06:24:05 +0100

> Also, where do you get the idea that status="standard" + consensus="false" is invalid?  That is always true for a draft.

FWIW: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/420>

I agree with Martin that the warning is not helpful, and in the case of
Internet Drafts, actually misleading.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 18 Nov 2019 06:26:17 +0100

On 18.11.2019 03:52, Carsten Bormann wrote:
> ...

FWIW, if the v3 design causes new issues for Internet Drafts, that's not
intentionally but an oversight.

Best regards, Julian