Subject: Re: [xml2rfc-dev] https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-10#section-3.1.21

From: Julian Reschke <[email-masked]>
Date: Fri, 1 Nov 2019 08:42:02 +0100

On 31.10.2019 16:21, Julian Reschke wrote:
> Re:
> <https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-10#section-3.1.21>:
>
>
>> 3.1.21.5.  Summary
>>
>>    The number of issues introduced with the move of the <seriesInfo>
>>    element and its re-purposing in order to fill functionality in the
>>    front of a document is wholly disproportionate with any added
>>    functionality.  The specification [RFC7991] does not provide any
>>    rationale for the changes, and there seems to be no major benefits to
>>    the new schema.
>>
>>    Proposal:  Do a rewrite of this that does not add new details to the
>>       already complex <seriesInfo> semantics, compared to the v2
>>       vocabulary, and does not make non-IETF reference files obsolete,
>>       but actually simplifies the model and use.
>>
>>       Limit the <seriesInfo> element to what is actually needed for use
>>       within <reference/>, and do not add new functionality related to
>>       the document <front>.  Deprecate any functionality not related to
>>       usage within <reference/>.
>>
>>       The easiest approach would be to simply revert to the v2 semantics
>>       and placement of <seriesInfo> elements, with documentation of
>>       that.
>
> I fully agree with this - we should go back to the definition in RFC
> 7749, and just add attribute to the rfc root element, if needed.
>
> (This will likely also affect the preptool spec, like many other changes)
>
> Best regards, Julian

...the downside being that this change would make published canonical
XML invalid (for instance, <https://www.rfc-editor.org/rfc/rfc8672.xml>).

Best regards, Julian

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 1 Nov 2019 10:47:39 -0700

Is it correct that this mail refers to the following use of <seriesInfo>?

          <seriesInfo name="Cryptology and Network Security" value="pp. 142-157"/>

Is there a preferred handling here?  Annotation?  The output is slightly different when using <annotation>.  

Using <seriesInfo> (published): 
   [Oreo]     Berkman, O., Pinkas, B., and M. Yung, "Firm Grip
              Handshakes: A Tool for Bidirectional Vouching", Cryptology
              and Network Security pp. 142-157, 2012.

Using <annotation>:
[Oreo]
Berkman, O., Pinkas, B., and M. Yung, "Firm Grip Handshakes: A Tool for Bidirectional Vouching", 2012. Cryptology and Network Security pp. 142-157.

Thanks,
Sandy 

> On Nov 1, 2019, at 12:42 AM, Julian Reschke <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev

---

From: Julian Reschke <[email-masked]>
Date: Fri, 1 Nov 2019 19:10:23 +0100

> Is it correct that this mail refers to the following use of <seriesInfo>?

Nope. This mail thread was about how RFC 7991 tries to re-purpose
seriesInfo to also control the metadata for the document itself.

(adjusting subject line)

>            <seriesInfoname="Cryptology and Network Security"value="pp.
> 142-157"/>
>

I would say using seriesInfo for this would be an abuse of the element.

> Using <annotation>:
> [Oreo]
>     Berkman, O., Pinkas, B., and M. Yung, "Firm Grip Handshakes: A Tool
>     for Bidirectional Vouching", 2012. Cryptology and Network Security
>     pp. 142-157.

Yes, <annotation> adds text to the end.

There <refcontent> (see
<https://greenbytes.de/tech/webdav/rfc7991.html#element.refcontent>).
However, RFC 7991 fails to state where it goes (before or after
<seriesInfo>). I believe xml2rfc puts it before, which doesn't help you
here.

See <https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/78>.

Best regards, Julian

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 1 Nov 2019 13:10:30 -0700

> On Nov 1, 2019, at 11:10 AM, Julian Reschke <[email-masked]> wrote:
> 

Ack - thanks for the clarification. 

> See <https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/78>.

Ah, I totally missed <refcontent>.  Thanks for highlighting this!

Sandy