Subject: [xml2rfc-dev] date format weirdness

From: Julian Reschke <[email-masked]>
Date: Tue, 1 Oct 2019 16:35:49 +0200

So,

in v3 mode, xml2rfc formats dates different from before, for instance:

"3 April 2020" instead of "April 3, 2020".

Is there a good reason for that?

I see that there's a command line switch (--legacy-date-format) to get
the traditional format back, but it only affects the text output, and
only the top level section, not the remainder of the boilerplate.

I'm not against change, but this really looks like a mess to me.

It would be great if we could either leave things the way they have been
for ages, or come up with a single format to be used everywhere (and
agreed by the relevant parties). And yes, a variant of ISO-8601 would be
great.

It would also be great if we could avoid having another knob to tune
things. It'll either get ignored, or lead to variation where we really
don't want it.

Best regards, Julian

PS: reported as <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/435>

---

From: Heather Flanagan <[email-masked]>
Date: Tue, 1 Oct 2019 13:00:05 -0700

> On Oct 1, 2019, at 7:35 AM, Julian Reschke <[email-masked]> wrote:
> 
> So,
> 

This came out of the discussion back in July, I think. Given all the other dates in the references (generally Month Year) adding the specific day at the front (a format commonly used by most of the world, if this is to be believed: https://en.wikipedia.org/wiki/Date_format_by_country) seems reasonable. 

> only the top level section, not the remainder of the boilerplate.

I can’t find the details on this one, but I expect that’s more my inability to sift through all the information instead of the information not existing. I also suspect that this is an attempt to be flexible enough to meet all possible use cases. 

> agreed by the relevant parties). And yes, a variant of ISO-8601 would be

Agreed.

> things. It'll either get ignored, or lead to variation where we really

I am going to put DMY format in the style guide for referencing I-Ds; that’s my stake in the ground for now in response to the request for a specific day for I-D references. If we decide on a universal date standard across the board, that’s great but it’s going to take a while to come to consensus on it.

-Heather

---

From: Julian Reschke <[email-masked]>
Date: Tue, 1 Oct 2019 22:43:57 +0200

> This came out of the discussion back in July, I think. Given all the other dates in the references (generally Month Year) adding the specific day at the front (a format commonly used by most of the…

Again, a change is ok (although I'd prefer just to do ISO-8601). But if
you do a change, please coordinate it (internet drafts as opposed to
RFCs), and document it somewhere.

> I can’t find the details on this one, but I expect that’s more my inability to sift through all the information instead of the information not existing. I also suspect that this is an attempt to be…

I'm at a loss how changing the format in one of multiple places
addresses a use case :-).

> I am going to put DMY format in the style guide for referencing I-Ds; that’s my stake in the ground for now in response to the request for a specific day for I-D references. If we decide on a unive…

Well, that's yet another change. The status quo is that in references,
the day of month does not appear at all.

Do you think anybody would be supposed to use YYYY-MM and YYYY-MM-DD?

Best regards, Julian

---

From: Heather Flanagan <[email-masked]>
Date: Tue, 1 Oct 2019 13:57:13 -0700

> On Oct 1, 2019, at 1:43 PM, Julian Reschke <[email-masked]> wrote:
> 

Chickens vs eggs have been challenging, but you’re point is well taken.

> addresses a use case :-).

I have seen stranger things, but in this case, I still can’t find the justification.

> Do you think anybody would be supposed to use YYYY-MM and YYYY-MM-DD?

I don’t know. Let’s ask! 
/me goes over to rfc-interest

-Heather