Subject: [xml2rfc-dev] Issues during SVG conversion

From: Brian E Carpenter <[email-masked]>
Date: Wed, 9 Oct 2019 14:18:14 +1300

Hi,

Using the convertor at https://xml2rfc.tools.ietf.org/experimental.html, I get errors on two SVG elements that I believe are valid and conformant with RFC 7996. The SVG file passes the conformance check at https://xml2rfc.tools.ietf.org/experimental.html.

INPUT(366): Error: Invalid attribute stroke for element rect, at /rfc/middle/section[1]/figure[3]/artwork/*/*[7]/*/*/*/*/*[1]/*/*[1]

The SVG element is:

<rect class="BoundingBox" stroke="none" fill="none" x="7223" y="4047" width="15749" height="4446"/>

If I delete 'stroke="none"' the error message disappears, but I don't believe there is an error in the original SVG. That one I can work around, but:

INPUT(468): Error: Element text has extra content: tspan, at /rfc/middle/section[1]/figure[3]/artwork/*/*[7]/*/*/*/*/*[2]/*/*[97]/*

The SVG element is:

<text class="TextShape"><tspan class="TextParagraph" font-family="sans-serif" font-size="635px" font-weight="400"><tspan class="TextPosition" x="7600" y="15163"><tspan fill="black" stroke="none">CBOR</tspan></tspan></tspan></text>

Nested tspans appear to be completely legal, and since my drawing tool generated them, there is no workaround.

I can supply the full files on request.

(I'm not on the -dev list.)

Regards
   Brian Carpenter

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 9 Oct 2019 08:10:17 +0200

Hi Brian,

> I can supply the full files on request.

Yes, please send files.  I suspect this could be a result of the restricted
SVG schema used.

Best regards,

	Henrik