Subject: [xml2rfc-dev] rfc2629 xslt question

From: Tom Pusateri <[email-masked]>
Date: Wed, 6 Mar 2019 21:45:37 -0500

When using markdown-rfc2629 to generate XML and rfc2629.xslt and friends to create a standalone XML file, I notice that my Appendix A Section gets a header of just A.

Meanwhile, the TXT and HTML versions generated by XML2RFC get a header of Appendix A.

You can see it here online:

https://tools.ietf.org/id/draft-pusateri-dnssd-update-proxy-01.xml (Scroll to the end)

and after grabbing the latest versions from greenbytes.de, the same thing happens locally.

Is this intentional or just an oversight?

Thanks,
Tom

---

From: Julian Reschke <[email-masked]>
Date: Thu, 7 Mar 2019 05:27:00 +0100

On 07.03.2019 03:45, Tom Pusateri wrote:
> ...

I believe it's an oversight. See 
<https://tools.ietf.org/html/rfc7322#section-4.9>.

Working on it.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 7 Mar 2019 14:40:29 +0100

On 07.03.2019 05:27, Julian Reschke wrote:
>> When using markdown-rfc2629 to generate XML and rfc2629.xslt and 
>> friends to create a standalone XML file, I notice that my Appendix A 
>> Section gets a header of just A.
>>

...done.

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 7 Mar 2019 10:36:07 -0500

> On Mar 7, 2019, at 8:40 AM, Julian Reschke <[email-masked]> wrote:
> 
>> I believe it's an oversight. See <https://tools.ietf.org/html/rfc7322#section-4.9>.
>> Working on it.
>> Best regards, Julian
> 
> ...done.

Thanks!

Just tried it. It fixed the Section Title but not the generated index.

Tom

---

From: Julian Reschke <[email-masked]>
Date: Thu, 7 Mar 2019 16:38:59 +0100

> Just tried it. It fixed the Section Title but not the generated index.

It also doesn't change the ToC...

I'm not sure that this should affect the index.

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 7 Mar 2019 10:46:58 -0500

> On Mar 7, 2019, at 10:38 AM, Julian Reschke <[email-masked]> wrote:
> 

Sorry, I meant the TOC not index. 

Tom