Subject: Re: [xml2rfc-dev] v3 XML template feature request

From: Tom Pusateri <[email-masked]>
Date: Wed, 20 Feb 2019 10:58:34 -1000

> On Jan 28, 2019, at 8:44 PM, Carsten Bormann <[email-masked]> wrote:
> 
> On Jan 29, 2019, at 00:12, Tom Pusateri <[email-masked]> wrote:
>> 
>> Carsten,
>> 
>> I’ve tried TextMate 2 on macOS, vim, and Sublime Text. All have Markdown modes but the distinctions between sections, subsections,  and paragraphs just aren’t enough for me.
> 
> I’m not working daily with these but some of these may have parameters for making the distinction stand out more.
> 
>> Yes, agree that XML is too much noise but the whitespace distinctions in Markdown and the terse separators are not sufficient separators for me. Collapsing would also be nice but that’s not an option for Markdown in any editor I’ve seen.
> 
> Markdown-mode in Emacs certainly does collapsing (TAB key).
> (Unfortunately, that does not tolerate the way kramdown usually takes anchors on sections.)
> 
>> AsciiDoc doesn’t seem any better in this sense.
>> 
>> Yes, JSON is probably not the right thing but whitespace based formatting is not either.
> 
> Clearly, a lot of people think the markdown syntax works well…
> Maybe it also helps to use “setext” style headers, as in
> 
> Introduction
> ============
> 
> As opposed to the terser “atx” style:
> 
> # Introduction
> 
> Grüße, Carsten
> 

As a follow-up, there has arisen another reason that makes kramdown-rfc2629, mmark.nl <http://mmark.nl/>, and any other tools that the RFC editor isn’t using less than ideal.

During an AUTH48 stage of publication for a draft I was a co-author that used kdramdown-rfc2629, we got back from the RFC editor an edited XML version that they wanted us to modify. Since the source was in Markdown, by them switching the source to XML, we now lost all edit history moving forward. We put their XML version in our github repository but now all future edits have to use their XML file.

Separately, they continue to email back and forth edits and so trying to keep a repository of XML changes alone is a problem…

Tom

---

From: Julian Reschke <[email-masked]>
Date: Wed, 20 Feb 2019 22:03:43 +0100

On 20.02.2019 21:58, Tom Pusateri wrote:
> ...
> As a follow-up, there has arisen another reason that makes 
> kramdown-rfc2629, mmark.nl <http://mmark.nl>, and any other tools that 
> the RFC editor isn’t using less than ideal.
> 
> During an AUTH48 stage of publication for a draft I was a co-author that 
> used kdramdown-rfc2629, we got back from the RFC editor an edited XML 
> version that they wanted us to modify. Since the source was in Markdown, 
> by them switching the source to XML, we now lost all edit history moving 
> forward. We put their XML version in our github repository but now all 
> future edits have to use their XML file.
> 
> Separately, they continue to email back and forth edits and so trying to 
> keep a repository of XML changes alone is a problem…
> ...

You could replay all editorial changes in the markdown source.

Best regards, Julian (yes; I've done that before)