Subject: [xml2rfc-dev] RFC 7991 issue #35: <li> can't contain a block quote

From: Paul Hoffman <[email-masked]>
Date: Wed, 3 Oct 2018 23:17:20 +0000

(From Miek Gieben)

The <li> element https://tools.ietf.org/html/rfc7991#section-2.29 can contain quite a bit of block elements, except <blockquote> (among others I think). Why?

In v2 xml ones usually works around this by mimicking the layout by abusing another element. Seems strange to do this here as well.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 3 Oct 2018 23:20:53 +0000

> In v2 xml ones usually works around this by mimicking the layout by abusing another element. Seems strange to do this here as well.

If I remember correctly, the idea was that list items are already indented, and indenting blockquotes in a list item might cause weird output. In retrospect, that doesn't seem like a great argument.

Does anyone still want to prohibit blockquotes in <li>?

--Paul Hoffman

---

From: Jim Schaad <[email-masked]>
Date: Wed, 3 Oct 2018 19:23:01 -0700

> -----Original Message-----
> From: xml2rfc-dev <[email-masked]> On Behalf Of Paul
> Hoffman
> Sent: Wednesday, October 3, 2018 4:21 PM
> To: XML Developer List <[email-masked]>
> Subject: Re: [xml2rfc-dev] [Ext] RFC 7991 issue #35: <li> can't contain a
block
> quote
> 
> > The <li> element https://tools.ietf.org/html/rfc7991#section-2.29 can
contain
> quite a bit of block elements, except <blockquote> (among others I think).
Why?
> >
> > In v2 xml ones usually works around this by mimicking the layout by
abusing
> another element. Seems strange to do this here as well.
> 
> If I remember correctly, the idea was that list items are already
indented, and
> indenting blockquotes in a list item might cause weird output. In
retrospect,
> that doesn't seem like a great argument.

That would be really odd if you did "t blockquote t" as that would actually
have an indentation difference.

> Does anyone still want to prohibit blockquotes in <li>?

I don't.

jim

---

From: Julian Reschke <[email-masked]>
Date: Thu, 4 Oct 2018 08:36:43 +0200

> Does anyone still want to prohibit blockquotes in <li>?

+1 to allow it...

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 6 Oct 2018 18:05:17 +0200

>> Does anyone still want to prohibit blockquotes in <li>?

+1

	Henrik