Subject: Re: [xml2rfc-dev] xml2rfc GUI alpha

From: Josh Bothun <[email-masked]>
Date: Thu, 18 Aug 2011 11:26:56 -0700

Hi Henrik,

On Aug 17, 2011, at 4:32 AM, Henrik Levkowetz wrote:

> Hi Mike, Josh,
> 
> Possibly there's some information missing related to the comments/questions
> quoted below.
> 
> There is an online repository of references available in 5 subdirectories
> of a specific URL (as I mentioned in a previous email without going into
> the location of it, as I didn't realize that this might not be known).
> Well, the URL is this, with the listed subdirectories:
> 
>   http://xml.resource.org/public/rfc/
> 		bibxml/			# contains RFC references
> 		bibxml2/		# contains ANSI and other Std refs
> 		bibxml3/		# contains draft references
> 		bibxml4/		# contains W3C references
> 		bibxml5/		# contains 3GPP references
> 
> So given that there is one canonical URL for the online reference library,
> it should be possible to try to pull also a reference not specified by
> a http:// path from the internet and cache it locally, which is what I think
> Tony was hoping for.

We can indeed support this, but I have a couple of questions about the specifics of the behavior.  Namely,

1. Should the application look for the reference in online library before, after, or instead of looking in local library? ($XML_LIBRARY or otherwise explicitly set in the GUI)
2. Is the behavior for handling <!ENTITY> and <?rfc include> instructions identical, or are there differing rules for each?

> 
> If you put in support for doing this, it would probably be a good idea to
> make the online library url configurable in the Preferences, too.
> 
> 

Certainly, it will likely be grouped under the 'References' tab.

-Josh

> Best regards,
> 
> 	Henrik
> 
> 
> 
> On 2011-08-17 07:32 Mike Biglan said:
>> Hi Tony,
>> 
>> We were just hoping to clarify your note below:
>> 
>>> "It insists on using a local citation library instead of being able to pull down the files over the internet. This should at least be an option. Another option is to pull files down from the internet to fill in a local cache's version of the citation library."
>> 
>> 
>> Our understanding is that there are two ways that an XML document can reference another document:
>> 	1. From an <ENTITY> declaration.
>> 	2. From an <?rfc include> instruction.
>> 
>> Both of these methods have identical behavior, which is the following:
>> 
>> 	- If the path requested starts with "http://", then it IS pulled down from the internet and cached, or loaded from the cache if it exists.  The citation library is not consulted.
>> 	- If the path requested does not start with "http://", then the filename attempts to load from the citation library (on the command line version, it consults environment variable $XML_LIBRARY, on the GUI version, there is a setting for the library location)
>> 	- Finally, if the path does not start with http:// and it was not found in the citation library, the document is looked for in the same directory as the input XML file.
>> 
>> If this behavior is not correct then please do let us know how this should function and we'll get this resolved.
>> 
>> Thanks,
>> 
>> Mike
>> 
>> 
>> On Aug 12, 2011, at 8:08 AM, Henrik Levkowetz wrote:
>> 
>>> Hi Mike,
>>> 
>>> Enclosed are some comments from Tony on the Windows version.
>>> 
>>> 
>>> Best regards,
>>> 
>>> 	Henrik
>>> <Re: Fwd: xml2rfc GUI alpha.eml>
>> 
>>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 18 Aug 2011 21:55:37 +0200

Hi Josh,

On 2011-08-18 20:26 Josh Bothun said the following:
> 1. Should the application look for the reference in online library
> before, after, or instead of looking in local library? ($XML_LIBRARY
> or otherwise explicitly set in the GUI)

Locally first, if that fails, online (unless the reference has an
absolute path -- then it's fully defined and we don't mess with it).

> 2. Is the behavior for handling<!ENTITY> and<?rfc include>
> instructions identical, or are there differing rules for each?

I think identical, but Tony may know better.

> Certainly, it will likely be grouped under the 'References' tab.

Splendid.  Thanks :-)

Best regards,

	Henrik