Subject: [xml2rfc-dev] moving forward with xml2rfc.tcl

From: Tony Hansen <[email-masked]>
Date: Fri, 07 May 2010 08:51:58 -0400

Syed, do you still have time in your schedule to do some xml2rfc hacking?

     Tony

---

From: "Ali, Syed Wasim" <[email-masked]>
Date: Fri, 7 May 2010 10:15:38 -0400

I will make the time. I have been meaning to get back into it. Please, let
me know what to look into next.

thanks.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 07 May 2010 16:29:51 +0200

On 07.05.2010 16:15, Ali, Syed Wasim wrote:
> ...

The most important one for the *RFC Editor* should be 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6> -- however it 
may make sense to contact the RFC Editor to make sure that nobody else 
is already looking into this.

If you just want to get your hands dirty, 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/9> might be a good 
candidate to get familiar with the source.

Best regards, Julian

---

From: Tony Hansen <[email-masked]>
Date: Fri, 07 May 2010 10:55:56 -0400

Let me paraphrase what's in ticket/6:

1) add the consensus=yes|no tag to <rfc>

2) when <?rfc rfcedstyle="yes"?>, depending on the submissionType, 
category and consensus values, generate
    a) different headers
    b) different Status of this Memo
    c) different Copyright Notice

3) some combinations are probably undefined

For the expected output, see 
http://greenbytes.de/tech/webdav/draft-reschke-hab-latest.html#rfc.section.3

     Tony

On 5/7/2010 10:29 AM, Julian Reschke wrote:
> <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/9> might be a 
> good candidate to get familiar with the source.
>
> Best regards, Julian

---

From: Alice Hagens <[email-masked]>
Date: Fri, 7 May 2010 11:00:45 -0400

Julian,

Yes, resolving ticket 6 (the changes to header and "Status of This Memo" text per RFC 5741) would be extremely helpful.  No one on the RFC Editor side is looking into making the changes. (However, we are happy to discuss or further document the requirements, which I sent a message about on 4/13 to xml2rfc-dev.)

Thanks,
Alice
[for the RFC Editor]

On May 7, 2010, at 10:29 AM, Julian Reschke wrote:

> The most important one for the *RFC Editor* should be <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6> -- however it may make sense to contact the RFC Editor to make sure that nobody else is already looking into this.
> 
> If you just want to get your hands dirty, <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/9> might be a good candidate to get familiar with the source.
> 
> Best regards, Julian
> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev
>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 07 May 2010 17:06:00 +0200

> category and consensus values, generate

Hm, no. It should solely depend on whether a RFC is generated or not 
(that is, the presence of /rfc/@number).

> c) different Copyright Notice

Yes.

Best regards, Julian

---

From: Tony Hansen <[email-masked]>
Date: Fri, 07 May 2010 11:10:43 -0400

Julian, thanks for the confirmations and correction.

So instead of looking for rfcedstyle="yes", look to see if <rfc> has a 
number= attribute.

Syed, is this enough to get started?

     Tony

---

From: Alice Hagens <[email-masked]>
Date: Fri, 7 May 2010 11:59:19 -0400

Yes, good point, Julian. If <rfc>'s number attribute is present, it's an RFC.

Here is a summary of 'Status of This Memo' combinations from the RFC Editor's perspective, in terms of the values of submissionType, category, and consensus. (Below, where a consensus value is not listed, it is irrelevant.)  They are numbered to correspond to the SoTM text on http://www.rfc-editor.org/rfc-style-guide/status-memos.txt.

submissionType-category-consensus
---------------------------------

1.  IETF-std-yes 
2.  IETF-bcp-yes      
3.  IETF-exp-yes      
4.  IETF-exp-no       
5.  IETF-historic-yes 
6.  IETF-historic-no  
7.  IETF-info-yes     
8.  IETF-info-no      
9.  IAB-historic      
10. IAB-info 
11. IRTF-exp-yes      use workgroup element.
12. IRTF-exp-no       use workgroup element.
13. IRTF-exp          no workgroup element present.
14. IRTF-historic-yes use workgroup element.
15. IRTF-historic-no  use workgroup element.
16. IRTF-historic     no workgroup element present.
17. IRTF-info-yes     use workgroup element.
18. IRTF-info-no      use workgroup element.
19. IRTF-info         no workgroup element present.    
20. Independent-exp   
21. Independent-historic
22. Independent-info 

> c) different Copyright Notice

Copyright Notice is not mentioned in the list above. It seems determined by submissionType, and an indicator whether these should be added:

 - the 6.c.iii legend (pre-5378) - we currently do this by setting ipr='pre5378Trust200902' (This is an exception case, where the ipr value is not ignored for an RFC.)

 - the 6.c.i legend (no derivative works) - currently ipr='noDerivativesTrust200902' is ignored when the document is an RFC so we do not have a way to add this legend.

(Already submissionType="Independent", "IRTF", or "IAB" yields the correct copyright notice for the alternate streams from TLP 4.0.)

Please let me know if there are questions.

Thanks,
Alice

On May 7, 2010, at 11:10 AM, Tony Hansen wrote:

> So instead of looking for rfcedstyle="yes", look to see if <rfc> has a number= attribute.
> 
>> Hm, no. It should solely depend on whether a RFC is generated or not (that is, the presence of /rfc/@number).
>> 
>>> a) different headers