Subject: [xml2rfc-dev] next up for xml2rfc.tcl

From: Tony Hansen <[email-masked]>
Date: Tue, 06 Apr 2010 15:25:27 -0400

I think the next step up for xml2rfc that we discussed will be to get 
the RFC boilerplate up to snuff.

Alice, Julian, do you have a handle on what's left to do for that?

     Tony

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Apr 2010 21:58:52 +0200

> Alice, Julian, do you have a handle on what's left to do for that?

See <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6>, which also 
has a partial patch.

rfc2629.xslt already has the code, and 
<http://tools.ietf.org/html/draft-reschke-hab-06> illustrates the 
expected results.

Best regards, Julian

---

From: Alice Hagens <[email-masked]>
Date: Tue, 13 Apr 2010 19:24:55 -0400

Hi Tony,

> See <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6>, which also has a partial patch.

Need more details for this one?  For background, here's the thread when Julian sent out proposed DTD changes to generate the new header and Status of This Memo text, and I sent a couple comments. 

http://lists.xml.resource.org/pipermail/xml2rfc/2009-December/003807.html
http://lists.xml.resource.org/pipermail/xml2rfc/2009-December/003808.html
http://lists.xml.resource.org/pipermail/xml2rfc/2009-December/003809.html

Julian wrote:
> <http://tools.ietf.org/html/draft-reschke-hab-06> illustrates the expected results.

Additionally, this page shows the SoTM possibilities (Sandy and Julian iterated on this, so I believe the 2 are in sync):
http://www.rfc-editor.org/rfc-style-guide/status-memos.txt

Example use cases:

1) For "IETF Standards Track w/ consensus":
Could be as simple as:
<rfc number="XXXX" category="std">

Or if we were to be explicit about the defaults:
<rfc number="XXXX" category="std" consensus="yes" submissionType="IETF">

2) For "IRTF Informational w/ RG consensus":
<rfc number="XXXX" category="info" consensus="yes" submissionType="IRTF">
...
<workgroup>Internet Congestion Control Research Group</workgroup>

3) For "IAB Informational"
<rfc number="XXXX" category="info" submissionType="IAB">

4) For "Independent Submission Informational"
<rfc number="XXXX" category="info" submissionType="independent">

Please let me know if I can provide more information.

Thanks,
Alice

On Apr 6, 2010, at 3:58 PM, Julian Reschke wrote:

> See <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/6>, which also has a partial patch.
> 
> rfc2629.xslt already has the code, and <http://tools.ietf.org/html/draft-reschke-hab-06> illustrates the expected results.
> 
> Best regards, Julian
> _______________________________________________
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev
>