Subject: Re: [websec] #12: Remove dependencies on HTTPbis and depend on RFC2616 only

From: =JeffH <[email-masked]>
Date: Tue, 26 Jul 2011 07:16:39 -0700

StPete asked...
 > On 7/24/11 9:22 PM, websec issue tracker wrote:
 >> #12: Remove dependencies on HTTPbis and depend on RFC2616 only
 >>
 >>  -strict-transport-sec has various dependencies (e.g. STS header field
 >>  ABNF) on HTTPbis.
 >>
 >>  HTTPbis may not complete in a timeframe workable for having -strict-
 >>  transport-sec go to RFC, so we should remove dependencies on HTTPbis, and
 >>  depend on RFC2616 only.
 >
 > Jeff, just curious: what do you perceive as the likely timeframe for
 > publication of both HSTS and HTTPbis?

As I related in the websec wg session yesterday, httpbis is trying to get into 
WG Last Call by the end of 2011, which is a slip from what they were targeting 
as of last fall...

So I decided we shouldn't wait for them (unfortunately). And no one pushed back 
on that in the session yesterday.

=JeffH

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 26 Jul 2011 10:42:57 -0400

On 7/26/11 10:16 AM, =JeffH wrote:
> As I related in the websec wg session yesterday, httpbis is trying to
> get into WG Last Call by the end of 2011, which is a slip from what they
> were targeting as of last fall...
> 
> So I decided we shouldn't wait for them (unfortunately). And no one
> pushed back on that in the session yesterday.

Yep, just checking.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/