Subject: [Webpush] Existing implementations of the push service

From: Lucas Jenß <[email-masked]>
Date: Thu, 21 Jul 2016 17:08:56 +0200

Hello everyone,

I’ve been looking for existing (possibly partial?) implementations of the push service, but was unable to find anything. I’m aware of the following list:

https://github.com/web-push-libs <https://github.com/web-push-libs> (node.js, Java, Python, PHP)
https://github.com/GoogleChrome/web-push-encryption <https://github.com/GoogleChrome/web-push-encryption> (node.js)
https://github.com/Martijnc/gowebpush <https://github.com/Martijnc/gowebpush> (Go)
https://github.com/zaru/webpush <https://github.com/zaru/webpush> (Ruby)
https://github.com/beverloo/webcrypto-push-encryption <https://github.com/beverloo/webcrypto-push-encryption> (JS, Web Crypto)
https://github.com/gauntface/simple-push-demo/tree/master/src/scripts/encryption <https://github.com/gauntface/simple-push-demo/tree/master/src/scripts/encryption> (JS, Web Crypto)

But these all seem to be applications/libraries either receiving or sending push notifications, often interacting with GCM. I’m probably missing something or searching for the wrong thing, I suppose. Would somebody be so kind as to point me into the right direction?

Best regards,
Lucas

---

From: jr conlin <[email-masked]>
Date: Thu, 21 Jul 2016 08:23:38 -0700

I'm not quite sure I follow what you're looking for.

If you're interested in running your own Push Service, our code is
available at:
https://github.com/mozilla-services/autopush
This is the full server we use, but please understand that we do rely on
AWS services for a fair bit of our processing. If you want to set up a
personal server, it's reasonably straight forward to do. Likewise, it
should be possible to factor in more "stand-alone" elements like the
database, but you'll want to fork it for that.

If you are looking to use WebPush to send subscriptions, the libraries
below will help. They don't do things like handle subscription
management or scaling up large distributions, but each of those tend to
have problems and concerns that are unique to each provider.

Is that what you're looking for?

On 7/21/2016 8:08
 AM, Lucas Jenß wrote:
> Hello everyone,
>
> I’ve been looking for existing (possibly partial?) implementations of
> the push service, but was unable to find anything. I’m aware of the
> following list:
>
> https://github.com/web-push-libs (node.js, Java, Python, PHP)
> https://github.com/GoogleChrome/web-push-encryption (node.js)
> https://github.com/Martijnc/gowebpush (Go)
> https://github.com/zaru/webpush (Ruby)
> https://github.com/beverloo/webcrypto-push-encryption (JS, Web Crypto)
> https://github.com/gauntface/simple-push-demo/tree/master/src/scripts/encryption (JS,
> Web Crypto)
>
> But these all seem to be applications/libraries either receiving or
> sending push notifications, often interacting with GCM. I’m probably
> missing something or searching for the wrong thing, I suppose. Would
> somebody be so kind as to point me into the right direction?
>
> Best regards,
> Lucas
>
>
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush

---

From: Lucas Jenß <[email-masked]>
Date: Thu, 21 Jul 2016 17:48:18 +0200

Something like autopush was indeed what I was looking for, thanks.

Cheers,
Lucas

> On 21 Jul 2016, at 17:23, jr conlin <[email-masked]> wrote:
> 
> If you're interested in running your own Push Service, our code is available at:
> https://github.com/mozilla-services/autopush <https://github.com/mozilla-services/autopush>
> This is the full server we use, but please understand that we do rely on AWS services for a fair bit of our processing. If you want to set up a personal server, it's reasonably straight forward to do. Likewise, it should be possible to factor in more "stand-alone" elements like the database, but you'll want to fork it for that. 
> 
> If you are looking to use WebPush to send subscriptions, the libraries below will help. They don't do things like handle subscription management or scaling up large distributions, but each of those tend to have problems and concerns that are unique to each provider.
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/webpush <https://www.ietf.org/mailman/listinfo/webpush>
>