Subject: [Webpush] Delivery receipts support

From: Martin Thomson <[email-masked]>
Date: Sat, 4 Jun 2016 09:19:37 +1000

Costin (on github) said:
> Since we have open issues with receipts - can we not make it mandatory ? It's very unlikely all implementations will be able to support the receipts any time soon, at least not as push promises.

We discussed this in the past.  At that time, we decided to make
support of delivery receipts mandatory.  Do people want to reopen that
issue?

Note that I don't believe that any implementation currently supports
receipts.  I had expected that to be a temporary situation, but if
people expect that this will be a problem, now would be a good time to
hear of it.

---

From: Costin Manolache <[email-masked]>
Date: Sat, 04 Jun 2016 00:59:11 +0000

We can accept messages that request receipts - and we do support sending
the
receipts. Just not the receipts that are in the spec :-)

In the past we assumed it's only an issue of getting a raw http2
 framer/stack - but with the issues around flow control it may take a bit
longer.

If it is acceptable to say that accepting messages with receipts is
mandatory, but
using the specific h2+promises receipt monitoring is optional - I think
it's fine.

On Fri, Jun 3, 2016 at 4:19 PM Martin Thomson <[email-masked]>
wrote:

> Costin (on github) said:
> > Since we have open issues with receipts - can we not make it mandatory ?
> It's very unlikely all implementations will be able to support the receipts
> any time soon, at least not as push promises.
>
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush
>

---

From: Elio Damaggio <[email-masked]>
Date: Tue, 7 Jun 2016 00:45:51 +0000

I would prefer not to reopen this.

For context, at the time it was decided to avoid making this optional in order to avoid fragmentation, especially possible for multiplatform apps.
In my times at Notification Hubs, this was a critical feature that many customers have to implement on their own, using their own channel, and negatively affecting battery life with additional connections.

For additional context, Azure Mobile Engagement (https://azure.microsoft.com/en-us/services/mobile-engagement/) and similar products (https://www.urbanairship.com/), all would be able to leverage receipts.

-----Original Message-----
From: Webpush [mailto:[email-masked]] On Behalf Of Martin Thomson
Sent: Friday, June 3, 2016 4:20 PM
To: [email-masked]
Subject: [Webpush] Delivery receipts support

> Since we have open issues with receipts - can we not make it mandatory ? It's very unlikely all implementations will be able to support the receipts any time soon, at least not as push promises.

We discussed this in the past.  At that time, we decided to make support of delivery receipts mandatory.  Do people want to reopen that issue?

Note that I don't believe that any implementation currently supports receipts.  I had expected that to be a temporary situation, but if people expect that this will be a problem, now would be a good time to hear of it.

_______________________________________________
Webpush mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fwebpush&data=01%7c01%7celioda%40microsoft.com%7c8be5a9d4b6a649ef606e08d38c058cf2%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=gfZh5%2bqsN4fxcZ1JsgFp4Jk7WZwkr%2bSWwvZ7b245PrM%3d

---

From: Brian Raymor <[email-masked]>
Date: Wed, 8 Jun 2016 20:11:53 +0000

If there is no further discussion today, I plan make the edit that I proposed in https://github.com/webpush-wg/webpush-protocol/pull/10