Subject: [Webpush] Status for webpush-05 WGLC

From: Brian Raymor <[email-masked]>
Date: Mon, 6 Jun 2016 21:15:30 +0000

I really appreciate all the detailed reading and thought that went into the feedback.

Thanks for helping to improve the draft.

Going forward, I would make one small request. Could we use separate mail subjects

for separate topics? It's a bit difficult to track conversations when all the subject lines are

"Non-blocking comments on -05" ;-) That said, if I've missed capturing or addressing your

issue, please let me know.

My goal is to publish webpush-06 on or before 6/13 if consensus is reached. We have until 7/8

to publish further drafts for IETF96.

These open issues need more working group discussion:

*  Adds that receipt support is mandatory.

https://github.com/webpush-wg/webpush-protocol/pull/104

Receipts have been required since the -00 draft from July 2015 - https://tools.ietf.org/html/draft-ietf-webpush-protocol-00#section-6.2

Related threads on the mailing list:

http://www.ietf.org/mail-archive/web/webpush/current/msg00565.html

http://www.ietf.org/mail-archive/web/webpush/current/msg00573.html

*  Allow push service to reject messages < 4K

https://github.com/webpush-wg/webpush-protocol/issues/109

Related thread on the mailing list:

http://www.ietf.org/mail-archive/web/webpush/current/msg00572.html

These open issues are more editorial in nature:

*  Optional message encryption and push message examples

Issue: https://github.com/webpush-wg/webpush-protocol/issues/106

PR: https://github.com/webpush-wg/webpush-protocol/pull/107

When we added "The ciphertext of the push message is included in the body of the request." during WGLC, the examples

no longer matched the description. I'm leaning towards clear text examples for clarity with a pointer to an example

of encrypted content in Martin's optional draft.

*  Make it a bit more obvious which is the send resource.

https://github.com/webpush-wg/webpush-protocol/pull/105

Costin writes - "push resource" is confusing me every time - "push" is used in all other resources.

Please share your suggestions in the PR.

*  proxy uc

https://github.com/webpush-wg/webpush-protocol/pull/96

Herve provided further clarification for the Canon scenarios. Costin has pending

feedback that needs to be addressed.

---

From: Brian Raymor <[email-masked]>
Date: Tue, 14 Jun 2016 17:00:59 +0000

Update - All issues are closed. The last open PR is in review and ready to merge today.

I plan to publish webpush-06 later today after reviewing the current draft. 

From: Webpush [mailto:[email-masked]] On Behalf Of Brian Raymor
Sent: Monday, June 6, 2016 2:16 PM
To: [email-masked]
Subject: [Webpush] Status for webpush-05 WGLC

*  proxy uc