Subject: [Webpush] Make it a bit more obvious which is the send resource

From: Brian Raymor <[email-masked]>
Date: Fri, 10 Jun 2016 21:28:06 +0000

https://github.com/webpush-wg/webpush-protocol/pull/105

Costin noted - "push resource" is confusing me every time - "push" is used in all other resources.

The original text:

The push service MUST provide a URI for the push resource
corresponding to the push message subscription in a link relation of
type "urn:ietf:params:push".

Bikeshed follows.

Would adding "delivery" clarify the use? This would match how we currently describe the process when
the application server sends a message. It requests "delivery":

The push service MUST provide a URI for the push *delivery* resource
corresponding to the push message subscription in a link relation of
type "urn:ietf:params:push:delivery".

5. Requesting Push Message Delivery
An application server requests the delivery of a push message by
sending a HTTP POST request to a push *delivery* resource

---

From: Brian Raymor <[email-masked]>
Date: Mon, 13 Jun 2016 17:04:52 +0000

I'm not hearing a strong desire to rename "push resource" to "push delivery resource" as a clarification during WGLC.

Closed https://github.com/webpush-wg/webpush-protocol/pull/105.

-----Original Message-----
From: Webpush [mailto:[email-masked]] On Behalf Of Brian Raymor
Sent: Friday, June 10, 2016 2:28 PM
To: [email-masked]
Subject: [Webpush] Make it a bit more obvious which is the send resource

The original text:

Bikeshed follows.

_______________________________________________
Webpush mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/webpush