Subject: [Webpush] Different status codes for negative Push Message Receipts

From: Idel Pivnitskiy <[email-masked]>
Date: Tue, 7 Jun 2016 01:56:06 +0300

I've created an issue on GitHub, related to this discussion:

https://github.com/webpush-wg/webpush-protocol/issues/110

Could be useful for an AS to know what happened with push message / UA.

Best regards,
Idel Pivnitskiy
--
Twitter: @idelpivnitskiy <https://twitter.com/idelpivnitskiy>
GitHub: @idelpivnitskiy <https://github.com/idelpivnitskiy>

---

From: Brian Raymor <[email-masked]>
Date: Tue, 7 Jun 2016 23:15:09 +0000

> Could be useful for an AS to know what happened with push message / UA.

I’ve added my comments to the issue.

Thanks,
...Brian

---

From: Benjamin Bangert <[email-masked]>
Date: Tue, 7 Jun 2016 17:08:48 -0700

I have also added comments to the issue, would it be more appropriate
to discuss it here?

On Tue, Jun 7, 2016 at 4:15 PM, Brian Raymor <[email-masked]> wrote:
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush

---

From: Brian Raymor <[email-masked]>
Date: Thu, 9 Jun 2016 23:05:26 +0000

We've struggled mightily in the past to identify the best status codes for these scenarios, including:

* New status codes for webpush
* 5xx status codes
* Using 417 and Expect
* Acknowledgement-Data

A sample of related conversations:

http://www.ietf.org/mail-archive/web/webpush/current/msg00351.html
http://www.ietf.org/mail-archive/web/webpush/current/msg00362.html
https://github.com/webpush-wg/webpush-protocol/issues/17
https://github.com/webpush-wg/webpush-protocol/issues/42
https://github.com/webpush-wg/webpush-protocol/issues/49

It's my impression that we comprehensively exhausted the topic prior to WGLC unless there are new scenarios
to address.

Thoughts?

...Brian

---

From: Brian Raymor <[email-masked]>
Date: Fri, 10 Jun 2016 21:03:46 +0000

Closed https://github.com/webpush-wg/webpush-protocol/issues/110

-----Original Message-----
From: Webpush [mailto:[email-masked]] On Behalf Of Brian Raymor
Sent: Thursday, June 9, 2016 4:05 PM
To: Benjamin Bangert <[email-masked]>
Cc: [email-masked]; Idel Pivnitskiy <[email-masked]>
Subject: Re: [Webpush] Different status codes for negative Push Message Receipts

Thoughts?

...Brian