Subject: Re: [Webpush] Require the TTL header

From: Brian Raymor <[email-masked]>
Date: Tue, 16 Feb 2016 22:44:50 +0000

On Sat, Feb 6, 2016 at 12:48 PM, Costin Manolache <[email-masked]> wrote:

> I assume 202 (Accepted) would be better for TTL=0 if the service is not actually storing the message.

My reading of 202 (Accepted) is that it's intended for asynchronous operations:

http://tools.ietf.org/html/rfc7231#section-6.3.3

   The 202 response is intentionally noncommittal.  Its purpose is to
   allow a server to accept a request for some other process (perhaps a
   batch-oriented process that is only run once per day) without
   requiring that the user agent's connection to the server persist
   until the process is completed.  The representation sent with this
   response ought to describe the request's current status and point to
   (or embed) a status monitor that can provide the user with an
   estimate of when the request will be fulfilled.

I suggest that we require the TTL - https://github.com/webpush-wg/webpush-protocol/issues/76 -
but maintain the current behavior where a Location is returned even for TTL=0.   There are already
special cases in the text for TTL=0 indicating that the resource may be deleted before the user agent can
acknowledge a message.  

As I noted in my earlier response to Ben, the Location resource is also subsequently required for the
synthesized GET:

https://tools.ietf.org/html/draft-ietf-webpush-protocol-03#section-7.1

   Each push message is pushed as the response to a synthesized GET
   request sent in a PUSH_PROMISE.  This GET request is made to the push
   message resource that was created by the push service when the
   application server requested message delivery.

...Brian

---

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Feb 2016 06:32:36 +1100

This matches my understanding and seems like a reasonable plan.

If you aren't persisting anything, and you don't need a good message
identifier (because you are fully proprietary on the other side), just
crank out a random number and tack it onto a junk URL.

On 17 February 2016 at 09:44, Brian Raymor <[email-masked]> wrote:
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush

---

From: Costin Manolache <[email-masked]>
Date: Wed, 17 Feb 2016 11:38:15 -0800

>    estimate of when the request will be fulfilled.
This is pretty much what webpush is doing - accepts the request, and some
other
process ( the connection side ) may deliver it later :-)
However it may be confusing, so I'm fine either way.

> I suggest that we require the TTL -
> https://github.com/webpush-wg/webpush-protocol/issues/76 -

+1

Costin

---

From: Brian Raymor <[email-masked]>
Date: Fri, 19 Feb 2016 18:09:35 +0000

I've closed the "Require the TTL" issue - https://github.com/webpush-wg/webpush-protocol/issues/76 - with - https://github.com/webpush-wg/webpush-protocol/pull/77 .

From: Costin Manolache [mailto:[email-masked]] 
Sent: Wednesday, February 17, 2016 11:38 AM
To: Brian Raymor <[email-masked]>
Cc: Costin Manolache <[email-masked]>; [email-masked]
Subject: Re: [Webpush] Require the TTL header

On Tue, Feb 16, 2016 at 2:44 PM, Brian Raymor <[email-masked]> wrote:

This is pretty much what webpush is doing - accepts the request, and some other 
process ( the connection side ) may deliver it later :-)
However it may be confusing, so I'm fine either way.

+1

Costin

...Brian