Subject: [Webpush] I-D Action: draft-ietf-webpush-protocol-03.txt

From: [email-masked]
Date: Wed, 03 Feb 2016 18:12:42 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web-Based Push Notifications Working Group of the IETF.

        Title           : Generic Event Delivery Using HTTP Push
        Authors         : Martin Thomson
                          Elio Damaggio
                          Brian Raymor
	Filename        : draft-ietf-webpush-protocol-03.txt
	Pages           : 30
	Date            : 2016-02-03

Abstract:
   A simple protocol for the delivery of realtime events to user agents
   is described.  This scheme uses HTTP/2 server push.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-webpush-protocol/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-webpush-protocol-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-webpush-protocol-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Raymor <[email-masked]>
Date: Thu, 4 Feb 2016 02:34:03 +0000

-03 incorporates pull requests from Martin, including the changes to subscription sets for Herve's scenarios (explicit correlation from the user agent) and the new push message updates section (message collapsing).

In addition, the Push-Receipt header field  has been transitioned to a link relation type which closes https://github.com/webpush-wg/webpush-protocol/issues/61 ...

-----Original Message-----
From: Webpush [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, February 3, 2016 6:13 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Webpush] I-D Action: draft-ietf-webpush-protocol-03.txt

Abstract:

_______________________________________________
Webpush mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/webpush