Subject: Re: [Webpush] Use Case related to subscription sets

From: Brian Raymor <[email-masked]>
Date: Sat, 9 Jan 2016 01:05:44 +0000

Is there any further feedback on Martin's pull request?

https://github.com/webpush-wg/webpush-protocol/pull/67

If there are no objections, I'd like to merge into the webpush draft early next week.

...Brian

-----Original Message-----
From: Hervé Ruellan [mailto:[email-masked]] 
Sent: Tuesday, November 24, 2015 10:22 AM
To: Martin Thomson <[email-masked]>
Cc: Benjamin Bangert <[email-masked]>; [email-masked]; Brian Raymor <[email-masked]>
Subject: Re: [Webpush] Use Case related to subscription sets

Thanks for the pull request.

I find it a good compromise: it covers our use-case while still encouraging UA to reuse subscription sets.

Hervé

On 24/11/15 00:19, Martin Thomson wrote:
> On 23 November 2015 at 13:46, Brian Raymor <[email-masked]> wrote:
> > Perhaps the combination of "user agent decides" with "push service *encourages*"
> > by limiting concurrent HTTP/2 streams is the potential compromise.
>
> That's where I'm headed.  Though I'm also adding "spec *encourages*"
> by using the word MUST.  I don't think that we get any gains for the
> important scenarios if we don't provide at least some encouragement to
> aggregate into a set.
>
> I've added text to the PR that explains what the push service might do
> to punish user agents that don't allow for aggregation.  It's relying
> on the same magical anti-DoS stuff again, which is hardly ever
> perfect, but often adequate in practice.
>
> Here I expect that looking at the connection will work to catch
> genuine but innocent mistakes.  The bad guys are always going to be
> harder to pin down.
>

---

From: Hervé Ruellan <[email-masked]>
Date: Mon, 11 Jan 2016 17:33:46 +0100

The PR brings a good solution for our use case of a client acting as a proxy. I've got no objections merging it, on the contrary.

Hervé

---

From: Costin Manolache <[email-masked]>
Date: Mon, 11 Jan 2016 17:16:55 +0000

It's even more complicated if you consider that a camera may have it's
own wifi connection ( watches are in this situation). Another example is
'multiple profiles/users' on the same device, sharing a single TCP
connection.

No objections - but it's one of the most difficult problems, implementing
it efficiently is tricky.

I suggest considering the same authentication mechanism that we discussed
for app servers
in the case of UAs - i.e. a JWT, signed with UA-generated key. Would
eliminate some
ambiguity, and make it a bit more clear what happens in cases of multiple
paths to reach
the final device ( camera/watch/etc).

Costin

On Mon, Jan 11, 2016 at 4:33 PM, Hervé Ruellan <[email-masked]>
wrote:

> The PR brings a good solution for our use case of a client acting as a
> proxy. I've got no objections merging it, on the contrary.
>
> Hervé
>
>
>> I find it a good compromise: it covers our use-case while still
>> encouraging UA to reuse subscription sets.
>>
>> Hervé
>>
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush
>