Subject: [Webpush] Niceness or urgency of messages

From: Brian Raymor <[email-masked]>
Date: Sat, 9 Jan 2016 01:37:59 +0000

There's an active conversation occurring today in the "Niceness or urgency of messages" github issue:

  https://github.com/webpush-wg/webpush-protocol/issues/28

I appreciate all the comments and encourage the WebPush WG to review ... but let's also bring substantive discussions to the mailing list.

Shida and Joe - would it make sense for the WebPush WG to adopt the HTTPbis experiment - http://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0027.html - discussion and resolution of issues in the issue tracker itself?

Thanks,
...Brian

---

From: Costin Manolache <[email-masked]>
Date: Sat, 9 Jan 2016 10:41:48 -0800

Any way to get github to forward the bug updates to the mailing list ? Or
is there a separate subscription to get all
updates on the bugs ?

Costin

On Fri, Jan 8, 2016 at 5:37 PM, Brian Raymor <[email-masked]>
wrote:

>
>
> There’s an active conversation occurring today in the “Niceness or urgency
> of messages” github issue:
>
>
>
> I appreciate all the comments and encourage the WebPush WG to review ...
> but let’s also bring substantive discussions to the mailing list.
>
>
>
> Shida and Joe – would it make sense for the WebPush WG to adopt the
> HTTPbis experiment -
> http://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0027.html -
> discussion and resolution of issues in the issue tracker itself?
>
>
>
> Thanks,
>
> …Brian
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush
>
>

---

From: Shida Schubert <[email-masked]>
Date: Sun, 31 Jan 2016 23:38:05 -0800

Hi Brian;

I am not brave enough to say, let’s follow HTTPbis footsteps quite yet. First of all, I don’t think we face the same problem as HTTPbis is facing which is driving them to experiment with the new work mode.

HTTPbis is working on many different extensions resulting in filling up people’s mailbox with discussions that are likely irrelevant to those unrelated. This is especially true for implementors who may be focused on a specific entity (browser, SDK, proxy, server etc.) in the HTTP. On the contrary, in webpush, we are working on the core protocol, although we have 3 drafts that are actively discussed, they are all for the single milestone (core protocol), so most if not all that are discussed on the mailing list should be relevant to those interested in webpush (probably an over simplification, but I hope you get my point..). 

I do think github is a fantastic tool to track issues, progresses and enhance collaboration (through commit/pull-request etc.) and as a result improve the overall speed of development. 

After reading your comment, I looked into the difference in number of participants for the ML / number of watchers on github (Which were quite significant), I also looked into whether names of the contributors in both github and ML matches, as we all know the contributors are the real movers but quite a few names didn’t exist on github.

I think for now we need to strike a balance of contributors not having have to waste their energy keeping the WG in loop but making sure some of the critical changes discussed on github is distributed on the ML.  

I do want to encourage the WG participants who are contributing on the list that are not yet “watch”ing the issues on github to do so. 

Thanks & Regards
Shida as co-chair

> On Jan 8, 2016, at 5:37 PM, Brian Raymor <[email-masked]> wrote:
> 
>  
> There’s an active conversation occurring today in the “Niceness or urgency of messages” github issue:
>  
>   https://github.com/webpush-wg/webpush-protocol/issues/28 <https://github.com/webpush-wg/webpush-protocol/issues/28>
>  
> I appreciate all the comments and encourage the WebPush WG to review ... but let’s also bring substantive discussions to the mailing list.
>  
> Shida and Joe – would it make sense for the WebPush WG to adopt the HTTPbis experiment -http://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0027.html <http://lists.w3.org/Archives/Public/ietf-http-wg/2015OctDec/0027.html> - discussion and resolution of issues in the issue tracker itself?
>  
> Thanks,
> …Brian
>  
>  
>  
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/webpush <https://www.ietf.org/mailman/listinfo/webpush>