Subject: [Webpush] draft-chiussi-webpush-subscription-less-framework-01 and request for feedback on Subscription Management

From: Fabio Chiussi <[email-masked]>
Date: Sun, 1 Nov 2015 18:27:40 -0800

Hi All,

I submitted a new draft: draft-chiussi-webpush-subscription-less-framework-01,
which I will briefly present at the WG meeting tomorrow. This draft
discusses two issues: i) a number of relevant use cases for webpush may
benefit from a "relaxed" model of subscription, and ii) there is an
emerging need for global management of webpush traffic across applications.

As a possible solution for both issues, this draft advocates the
introduction of a notion of trusted "Subscription Authority" in charge of
controlling webpush traffic to each UA.

Beyond the specific solution proposed in this draft, I would like to
solicit feedback from the mailing list on the more general issue of
Subscription Management, which we can discuss tomorrow at the meeting.
Specifically, any comments would be greatly appreciated on the following.

1. For the reasons outlined in the draft, Subscription Management seems a
very relevant practical issue that needs to be addressed.

2. In the current core protocol WG document, Subscription Management is
only addressed in passing, by assuming some kind of control policy in
assigning the subscriptions. At this time, neither the issues and use cases
related to Subscription Management, nor the possible solutions have been
fully studied in the draft. I think this is simply due to the fact that the
core protocol design, for obvious reasons, has been the focus of the work
so far, and there has not been sufficient time yet to fully address other
relevant issues, such as Subscription Management

3. However, the state of the work on the core protocol design has reached
sufficient maturity that the WG should start considering to address some of
these other topics as well. Subscription Management seems a critical and
urgent one, since it has very important practical ramifications. The
solution proposed in this draft is simply one of possible candidates, and
Subscription Management certainly deserves a more comprehensive study, and
possibly develop a framework for Subscription Management. Because of its
practical relevancy, subscription Management should become a WG item.

I'll compile any comments that the mailing list may have on these topics,
and bring them forward for discussion at the meeting tomorrow.

Thanks,
Fabio

---

From: Benjamin Bangert <[email-masked]>
Date: Mon, 2 Nov 2015 09:11:08 -0800

Is there a link to this document I can read?

Thanks,
Ben

On Sun, Nov 1, 2015 at 6:27 PM, Fabio Chiussi <[email-masked]>
wrote:

> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush
>
>

---

From: Brian Raymor <[email-masked]>
Date: Mon, 2 Nov 2015 21:30:39 +0000

https://datatracker.ietf.org/doc/draft-chiussi-webpush-subscription-less-framework/

From: Webpush [mailto:[email-masked]] On Behalf Of Benjamin Bangert
Sent: Tuesday, November 3, 2015 2:11 AM
To: Fabio Chiussi <[email-masked]>
Cc: [email-masked]
Subject: Re: [Webpush] draft-chiussi-webpush-subscription-less-framework-01 and request for feedback on Subscription Management

On Sun, Nov 1, 2015 at 6:27 PM, Fabio Chiussi <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

I submitted a new draft: draft-chiussi-webpush-subscription-less-framework-01, which I will briefly present at the WG meeting tomorrow. This draft discusses two issues: i) a number of relevant use cases for webpush may benefit from a "relaxed" model of subscription, and ii) there is an emerging need for global management of webpush traffic across applications.

As a possible solution for both issues, this draft advocates the introduction of a notion of trusted "Subscription Authority" in charge of controlling webpush traffic to each UA.

Beyond the specific solution proposed in this draft, I would like to solicit feedback from the mailing list on the more general issue of Subscription Management, which we can discuss tomorrow at the meeting. Specifically, any comments would be greatly appreciated on the following.

1. For the reasons outlined in the draft, Subscription Management seems a very relevant practical issue that needs to be addressed.

2. In the current core protocol WG document, Subscription Management is only addressed in passing, by assuming some kind of control policy in assigning the subscriptions. At this time, neither the issues and use cases related to Subscription Management, nor the possible solutions have been fully studied in the draft. I think this is simply due to the fact that the core protocol design, for obvious reasons, has been the focus of the work so far, and there has not been sufficient time yet to fully address other relevant issues, such as Subscription Management

3. However, the state of the work on the core protocol design has reached sufficient maturity that the WG should start considering to address some of these other topics as well. Subscription Management seems a critical and urgent one, since it has very important practical ramifications. The solution proposed in this draft is simply one of possible candidates, and Subscription Management certainly deserves a more comprehensive study, and possibly develop a framework for Subscription Management. Because of its practical relevancy, subscription Management should become a WG item.

I'll compile any comments that the mailing list may have on these topics, and bring them forward for discussion at the meeting tomorrow.

Thanks,
Fabio

_______________________________________________
Webpush mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/webpush

---

From: Fabio Chiussi <[email-masked]>
Date: Mon, 2 Nov 2015 15:25:37 -0800

Hi,

Sorry for not adding the link, the document is listed in the WG page.
http://datatracker.ietf.org/doc/draft-chiussi-webpush-subscription-less-framework/

Thanks,
Fabio