Subject: Re: [Webpush] some comments and feedback on the draft-thomson-webpush-protocol-00

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Wed, 24 Jun 2015 22:40:38 +0000

On Thursday, Jun 18, 2015, Darshak Thakore <[email-masked]> wrote:

> Push message prioritization - Would it make sense to use the Prefer header instead of the TTL header. This would allow carrying prioritization info for 
> messages (the prioritization is only relative to the application server's own set of messages) to be carried in the Prefer header (e.g. Prefer: priority=5, wait=10).
> Also the wait 0 can be used to indicate the equivalent of TTL 0 or we can even define a new preference token.

Dan Druta raised the question of priorities earlier on the mailing list. The thread starts:
  https://mailarchive.ietf.org/arch/msg/webpush/7ltW-kU9katoRX6J0hlv-QAFplM

There's also a related issue open on our github:
  https://github.com/unicorn-wg/webpush-protocol/issues/28
which references - https://tools.ietf.org/html/draft-thomson-http-nice-02 - as an option to explore.

It would be helpful to first clarify use cases and requirements as Dan concluded in the earlier
thread?

---

From: Darshak Thakore <[email-masked]>
Date: Wed, 1 Jul 2015 01:03:50 +0000

I did look at that thread and the issue.
I¹m not necessarily suggesting that we solve the prioritization problem in
this draft itself. I agree that we first need to gather use cases and
requirements.
All I was suggesting for now is that given that the Prefer header is a
good candidate to carry such information, can we for now also use it to
carry the TTL semantics instead of defining a new header.

Darshak

On 6/24/15, 4:40 PM, "Brian Raymor (MS OPEN TECH)"
<[email-masked]> wrote:

>> Push message prioritization - Would it make sense to use the Prefer
>>header instead of the TTL header. This would allow carrying
>>prioritization info for
>> messages (the prioritization is only relative to the application
>>server's own set of messages) to be carried in the Prefer header (e.g.
>>Prefer: priority=5, wait=10).

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2015 21:08:40 -0700

> carry the TTL semantics instead of defining a new header.

Generally speaking, I believe Prefer to be better suited to requesting
variations in request handling; whereas this is an example of
information that describes the resource itself.  That said, I'm not
wed to the idea of a new header; Prefer: ttl=10 would work.