Subject: [Webpush] Review draft-nakajima-webpush-problem-statement-00

From: Eduardo Gueiros <[email-masked]>
Date: Mon, 23 Mar 2015 00:15:53 -0600

General Overview

In general, I haven’t necessarily found major issues with he draft besides
grammar errors. I have, however a few inquiries as stated below.

No Major issues

Minor issues

- In the abstract the following statement “…delivering events based on the
registration…” Shouldn’t the subscription be included as well? If an
application registers but does not subscribe for a resource it won’t get
anything.

- Suggestion:
Change: “Emergency Alerting notification”
To: “Emergency Notifications”

- 3.1 paragraph 4

If a device is not connected (3GPP, Wifi…or otherwise without means to
access remote data) how could emergency notifications be derived (e.g.
Desktop without ethernet or wifi)? What do you propose?

- There is some general clarification needed in the text and I have
suggested modifications in the ‘Nits & Grammar’ section of this review.

Nits & Grammar

Abstract, paragraph 1
> Web Push protocol provides a means of delivering the events to
> clients based on the registration made by the application.

Proposed text for clarification and grammar:

 The Web Push Protocol [I-D.thomson-webpush-http2] provides means of
delivering events to clients based on registration and subscriptions made
the an application.

Abstract, paragraph 1
> Also, the emergency alert notification system has been developed and
> deployed widely with mobile phones or smartphones, but has not deployed >
to Web-only devices.

Proposed text for clarification and grammar:

 Emergency notification systems have been developed and deployed to mobile
phones, but not to web-only devices.

Abstract, paragraph 2

> This document outlines various existing emergency alert notification
> system in other protocols and use cases with their requirements.

Proposed text:

 This document outlines various existing emergency notification systems,
their protocols and use cases, and explains how Web Push can help pushing
emergency notifications to web-only devices.

Introduction, paragraph 2
>Also, emergency alerting is an apparently important feature of
>  telecommunication network such as cellular networks, allowing the
>  governments or authorities to send a warnings of natural disaster or
>  accident.

Proposed text for clarification and grammar:

 Emergency notifications is an important feature of telecommunications
networks such as cellular networks, allowing governments and public safety
entities to send many types of warnings (eg. natural disasters, abductions,
accidents, etc).

1. Introduction, paragraph 3
> emergency notification system

Proposed text for clarification and grammar:

emergency notification systems

3.1 paragraph 2
> and merged into Public Warning System (PWS)

Proposed text for clarification and grammar:

and merged into the/a Public Warning System

3.1 paragraph 2
>PWS provides several functions for example:

Proposed text for clarification and grammar:

PWS provides several functions, for example:

3.1 paragraph 3
> Addition to PWS, some work has been made to distribute the emergency
> alerting notification on different network.

Proposed text for clarification and grammar:

In addition to PWS, some work has been done to send emergency notifications
through different networks.

3.1 paragraph 4
> Those previous contributions have been made to develop the method to
> distribute an emergency alerting notification.

Comment:

The phrase is not clear. You already stated previously that work has been
done.

3.1 paragraph 5
Comment:

Are you suggesting Web Push to handle spacial data in order to deliver
location based events? If a client is mobile, it would require the client
to update their subscription with their current location on a timely manner
in order to receive accurate notifications. This might be slightly out of
the scope as Web Push as it’s purpose is simply to push an event based on
the subscription. The means and computations through which the event is
generated is apart from the Web Push, in my opinion.

3.2 paragraph 2
> Digital signage has widely deployed among the world.

Suggested change:

Digital signage has been widely deployed around the world.

3.2 paragraph 2
> Signage located at public area such as train station or street play a
> significant role in natural disaster or accident by providing the
> evacuation alert or correct informations.

Suggested change:

Signage located in public areas, such as on train stations or on the
street, play a significant role in natural disaster or accidents by
providing evacuation alerts or useful information.

3.2 paragraph 2
> Recent few years W3C worked on Web-based signage which
> has Web browser is embedded, allowing to display or play Web content.
>  Disaster use case is proposed in W3C Web-based Signage Scenarios and
>  Use Cases [SignageUseCase].

Suggested change:

In recent years, the W3C has worked on Web-based signage which has a web
browser embedded, allowing it to display web content. The disaster
notification use case is proposed in the W3C Web-based Signage Scenarios
and Use Cases [SignageUseCase].

3.2 paragraph 3
Comment:

So, are you suggesting using Web Push for “minor” notifications instead of
using the more “over-the-top” PWS approach? I agree. PWS should be used for
emergency or general notifications from public entities. If a user desires
to know precipitation levels in an area, the user should be able to
subscribe with a service that provides that data.

Regards,

Eduardo Gueiros
Jive Communications, Inc
egueiros at jive.com

---

From: Hirotaka Nakajima <[email-masked]>
Date: Tue, 24 Mar 2015 17:11:31 +0900

Hi Eduardo,

Thank you for the feedback!

> - In the abstract the following statement “…delivering events based on the registration…” Shouldn’t the subscription be included as well? If an application registers but does not subscribe for a resource it won’t get anything.
Subscription should be needed.

> To: “Emergency Notifications”
Some documents on IETF or other documents used “Emergency Alerting notification” however I think “Emergency Notifications” is more common so I would change the term.

> - 3.1 paragraph 4
> 
> If a device is not connected (3GPP, Wifi…or otherwise without means to access remote data) how could emergency notifications be derived (e.g. Desktop without ethernet or wifi)? What do you propose?
The motivation of this document is to let the IP-only device to receive the emergency notifications.
(The device which has 3G connectivity can get an alert from 3G Cell and more geo-graphically accurate than Geo IP-based alerting)

So I would like to propose that using webpush as a transport of the emergency notification to non-Cellular devices (e.g. Web-based signage, TV, automobile, etc..)

> Nits & Grammar
Thank you so much!
I made a changes to the draft on GitHub.
https://nunnun.github.io/webpush-problem-statement/

> 3.1 paragraph 5
> Comment:
> 
> Are you suggesting Web Push to handle spacial data in order to deliver location based events? If a client is mobile, it would require the client to update their subscription with their current location on a timely manner in order to receive accurate notifications. This might be slightly out of the scope as Web Push as it’s purpose is simply to push an event based on the subscription. The means and computations through which the event is generated is apart from the Web Push, in my opinion.

The basic idea is delivering the Earthquake Tsunami Notification to Web devices through IP-network (not using 3GPP).
As you pointed that requires the devices to update their location many times and that cause huge power consumptions and that is exactly out of scope.

> 3.2 paragraph 3
> Comment:
> 
> So, are you suggesting using Web Push for “minor” notifications instead of using the more “over-the-top” PWS approach? I agree. PWS should be used for emergency or general notifications from public entities. If a user desires to know precipitation levels in an area, the user should be able to subscribe with a service that provides that data.
In Japan, Earthquake Tsunami Warning System has deployed over the cellular network.
However, that mechanism has abused by the mobile operators to send an advertisement with non-emergency channel and that cause mis-alerting.
So I would propose that web push should have some mechanism of priority to identify the message’s class. (Emergency? Critical? or just important)

Thank you so much for your comment!

Best,
Hiro

> On Mar 23, 2015, at 3:15 PM, Eduardo Gueiros <[email-masked]> wrote:
> 
> General Overview
> 
> In general, I haven’t necessarily found major issues with he draft besides grammar errors. I have, however a few inquiries as stated below.
> 
> No Major issues
> 
> Minor issues
> 
> - In the abstract the following statement “…delivering events based on the registration…” Shouldn’t the subscription be included as well? If an application registers but does not subscribe for a resource it won’t get anything.
> 
> - Suggestion:
> If a device is not connected (3GPP, Wifi…or otherwise without means to access remote data) how could emergency notifications be derived (e.g. Desktop without ethernet or wifi)? What do you propose?
> 
> - There is some general clarification needed in the text and I have suggested modifications in the ‘Nits & Grammar’ section of this review.
> 
> Nits & Grammar
> 
> Abstract, paragraph 1
>  The Web Push Protocol [I-D.thomson-webpush-http2] provides means of delivering events to clients based on registration and subscriptions made the an application.
> 
> Abstract, paragraph 1
> > deployed widely with mobile phones or smartphones, but has not deployed > to Web-only devices.
> 
>  Emergency notification systems have been developed and deployed to mobile phones, but not to web-only devices.
> 
> Abstract, paragraph 2
> 
>  This document outlines various existing emergency notification systems, their protocols and use cases, and explains how Web Push can help pushing emergency notifications to web-only devices.
> 
>  Emergency notifications is an important feature of telecommunications networks such as cellular networks, allowing governments and public safety entities to send many types of warnings (eg. natural disasters, abductions, accidents, etc).
> 
> In addition to PWS, some work has been done to send emergency notifications through different networks.
> 
> 3.1 paragraph 4
> The phrase is not clear. You already stated previously that work has been done.
> 
> 3.1 paragraph 5
> Comment:
> 
> Are you suggesting Web Push to handle spacial data in order to deliver location based events? If a client is mobile, it would require the client to update their subscription with their current location on a timely manner in order to receive accurate notifications. This might be slightly out of the scope as Web Push as it’s purpose is simply to push an event based on the subscription. The means and computations through which the event is generated is apart from the Web Push, in my opinion.
> 
> 3.2 paragraph 2
> Signage located in public areas, such as on train stations or on the street, play a significant role in natural disaster or accidents by providing evacuation alerts or useful information.
> 
> 3.2 paragraph 2
> In recent years, the W3C has worked on Web-based signage which has a web browser embedded, allowing it to display web content. The disaster notification use case is proposed in the W3C Web-based Signage Scenarios and Use Cases [SignageUseCase].
> 
> 3.2 paragraph 3
> Comment:
> 
> So, are you suggesting using Web Push for “minor” notifications instead of using the more “over-the-top” PWS approach? I agree. PWS should be used for emergency or general notifications from public entities. If a user desires to know precipitation levels in an area, the user should be able to subscribe with a service that provides that data.
> 
> Regards,
> 
> Eduardo Gueiros
> Jive Communications, Inc
> egueiros at jive.com
>