Subject: [Webpush] Channel status question

From: Daniel Bevenius <[email-masked]>
Date: Fri, 5 Dec 2014 14:32:33 +0100

I was wondering about what should be included in the returned status for a
channel, mentioned in section 6 [1]:
"Clients can check the status of individual channels by sending GET
requests to the channel URI."

Is this a simple return status code of 200/404, or should there be other
information included like when the channel expires?

Thanks,

/Daniel

[1] https://tools.ietf.org/html/draft-thomson-webpush-http2-01#section-6

---

From: Martin Thomson <[email-masked]>
Date: Fri, 5 Dec 2014 09:52:22 -0800

> information included like when the channel expires?

The idea here is that the client can request the last message that was
sent on that channel.  That definitely needs work.