Subject: Re: [Webpush] Comment on charter and HTTP

From: Costin Manolache <[email-masked]>
Date: Wed, 1 Oct 2014 20:45:50 -0700

On Mon, Sep 29, 2014 at 11:29 AM, Martin Thomson <[email-masked]>
wrote:

> On 29 September 2014 10:43, Elio Damaggio <[email-masked]> wrote:
> > I read the charter, and, as stated, it includes any “push” protocol for
> > arbitrary devices. Does the charter include low-powered devices, such as
> > embedded systems (think IoT, “Smart things”, etc.)?
>
> The overall architecture will probably suit, but the protocol might
> not.  The immediate goal is to enable this for things with web
> browsers, so I'd imagine that some choices will be made that are
>

Things "with web browsers" include phones - and saving battery is quite
critical there.
For example GCM includes quite a few optimizations for this.

Costin

> suboptimal for IoT devices (or at least, not aggressive enough in the
> power/processing cost savings direction).  It's probably not wise to
> try to solve for too wide a range of devices; I've seen that go very
> poorly.
>
> That doesn't mean that we can't eventually considering widening the
> net a little.  But I personally want to ensure that we have a really
> good solution for browsers first and foremost.
>
> What I was envisaging with my proposal was that this would serve as a
> baseline, from which customized protocols could be bootstrapped.  For
> instance, if you are talking to a server, you could hint that you can
> talk some as-yet-unspecified, super-power-saving protocol, at which
> point the push server switches over to that instead.  Of course, the
> protocol also works over COAP with some small modifications, which
> might be more practical short term goal.  None of that is in the
> charter though.
>
> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush
>

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Oct 2014 09:14:16 -0700

> For example GCM includes quite a few optimizations for this.

Absolutely, but if we build a solution that is good for a light
switch, that could be a different sort of proposition.

---

From: Daniel Appelquist <[email-masked]>
Date: Thu, 2 Oct 2014 22:04:55 +0100

> On 2 Oct 2014, at 17:14, Martin Thomson <[email-masked]> wrote:
> 

+1 on keeping the work focused to "things with web browsers" and not the more general iot / embedded devices cases, which implies a different set of requirements.

Dan

---

From: Costin Manolache <[email-masked]>
Date: Thu, 2 Oct 2014 14:17:54 -0700

On Thu, Oct 2, 2014 at 9:14 AM, Martin Thomson <[email-masked]>
wrote:

> switch, that could be a different sort of proposition

"Things with a battery that could run a browser or other http-based apps"
is a good target.
I think taking battery into account is critical - for phones, tablets and
even laptops.

IOT and light switch is indeed a different problem - but most of the times
the switches
are still connected to 'something that can run http' and act as a proxy to
their non-IP
protocols.

Costin

---

From: Elio Damaggio <[email-masked]>
Date: Thu, 2 Oct 2014 21:20:24 +0000

+1.

That is correct. A lot of IoT scenarios are achieved using a gateway (with an “http-based app”) which relays communications to the lower powered “things”.

From: Costin Manolache [mailto:[email-masked]]
Sent: Thursday, October 2, 2014 2:18 PM
To: Martin Thomson
Cc: Elio Damaggio; [email-masked]; [email-masked]
Subject: Re: [Webpush] Comment on charter and HTTP

On Thu, Oct 2, 2014 at 9:14 AM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

"Things with a battery that could run a browser or other http-based apps" is a good target.
I think taking battery into account is critical - for phones, tablets and even laptops.

IOT and light switch is indeed a different problem - but most of the times the switches
are still connected to 'something that can run http' and act as a proxy to their non-IP
protocols.

Costin

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 2 Oct 2014 15:26:55 -0700

My impression is that the scoping issue discussed in this thread is covered by the existing charter text (which highlights battery-powered devices) plus the proposed addition of specifying that the WG will work on an “HTTP-based” protocol. Shout if you disagree.

Alissa

On Oct 2, 2014, at 2:20 PM, Elio Damaggio <[email-masked]> wrote:

> On Thu, Oct 2, 2014 at 9:14 AM, Martin Thomson <[email-masked]> wrote:

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Oct 2014 16:55:25 -0700

On 2 October 2014 15:26, Alissa Cooper <[email-masked]> wrote:
> My impression is that the scoping issue discussed in this thread is covered
> by the existing charter text (which highlights battery-powered devices) plus
> the proposed addition of specifying that the WG will work on an “HTTP-based”
> protocol. Shout if you disagree.

Yep.  Saying HTTP-based is almost orthogonal, but it does cut out the
absolute bottom end.

Better efficiency for everything that needs efficiency is a stretch,
but if we can make it better for a low-end phone, we're probably still
making it better for all other devices on Costin's list.  ...and maybe
even for those devices that are attached to a power plant by a long
piece of metal.

---

From: Costin Manolache <[email-masked]>
Date: Fri, 3 Oct 2014 10:33:34 -0700

As long as "HTTP-based" doesn't explicitly exclude the use of non-HTTP
protocols in
 parts of the system implementation - I think all is good.
Beside battery, the 'chattiness' and bandwidth usage are important on
mobile networks, so some parts
may need to be optimized for the last mile.

Costin