Subject: [Webpush] Stephen Farrell's Block on charter-ietf-webpush-00-01: (with BLOCK)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 02 Oct 2014 08:05:23 -0700

Stephen Farrell has entered the following ballot position for
charter-ietf-webpush-00-01: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/charter-ietf-webpush/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I'm sorry, despite some discussion I still do not get the 
position here wrt security and privacy, nor the likely
outcomes.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 2 Oct 2014 09:27:05 -0700

I was hoping this would resolve in the back-and-forth, but let me try to take a stab:

I think it’s important to give the community working on this problem some flexibility in terms of how security requirements will be met — might require application support, might require API updates, might require protocol support, or some combination of those. At a minimum, applications can always arrange for e2e encryption of pushed data regardless of what the protocol supports, including for the multicast case. So I think we could add something along the following lines to the charter:

"The output of the WG should be able to support end-to-end integrity and confidentiality protections for the data being pushed, as well as the ability to prevent the push server from associating users with applications.”

Does that help?

Alissa

On Oct 2, 2014, at 8:05 AM, Stephen Farrell <[email-masked]> wrote:

> _______________________________________________
> Webpush mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webpush

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Oct 2014 09:30:42 -0700

> "The output of the WG should be able to support end-to-end integrity and confidentiality protections for the data being pushed, as well as the ability to prevent the push server from associating us…

That is something I can buy in to.

Adding "HTTP-based" is also OK.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 2 Oct 2014 10:40:25 -0700

I had some further off-line discussion with Stephen to work in a few more clarifications, and here is what I suggest as a result:

"The WG will aim to minimize the amount of additional information that is revealed to the push notification service.  It must be possible for the application to apply end-to-end security mechanisms so that messages sent via the push notification service cannot be read or modified by the push notification service.  The WG will also consider additional privacy protections, including the ability to prevent the push notification service from gleaning other types of information, such as the association between an application and a specific user.”

I think for the “HTTP-based” bit we can do the following in the charter 3rd para:

s/This working group will develop a protocol/This working group will develop an HTTP-based protocol/

I’d like to get these changes posted in a day or two assuming Stephen’s concerns are satisfied and there are no further objections.

Thanks,
Alissa

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Oct 2014 10:54:47 -0700

> "The WG will aim to minimize the amount of additional information that is revealed to the push notification service.  It must be possible for the application to apply end-to-end security mechanisms…

Sure, I was certainly intending to do that.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 02 Oct 2014 19:00:01 +0100

On 2 October 2014 18:40:25 IST, Alissa Cooper <[email-masked]> wrote:
>I had some further off-line discussion with Stephen to work in a few
>more clarifications, and here is what I suggest as a result:
>
>"The WG will aim to minimize the amount of additional information that
>is revealed to the push notification service.  It must be possible for
>the application to apply end-to-end security mechanisms so that
>messages sent via the push notification service cannot be read or
>modified by the push notification service.  The WG will also consider
>additional privacy protections, including the ability to prevent the
>push notification service from gleaning other types of information,
>such as the association between an application and a specific user.”

Lovely. Happy to unblock on that basis once back online.

Ta,
S.

>I’d like to get these changes posted in a day or two assuming Stephen’s
>concerns are satisfied and there are no further objections.
>
>Thanks,
>Alissa
>
>>> "The output of the WG should be able to support end-to-end integrity
>and confidentiality protections for the data being pushed, as well as
>the ability to prevent the push server from associating users with
>applications.”
>>

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 3 Oct 2014 08:55:22 -0700

I’ve updated the charter text: http://datatracker.ietf.org/doc/charter-ietf-webpush/

Once Stephen unblocks, I’ll send this to the secretariat for chartering.

Alissa