Subject: webDAV apple open source

From: Syl-J CALIMPUSAN <[email-masked]>
Date: Wed, 8 Feb 2012 17:40:23 -0800

I am having a hard time compiling the webDAV apple open source codes.  I am
missing NetFS/NetFSPrivate.h header files.  Anyone has access to that file?

Thanks.

---

From: Syl-J CALIMPUSAN <[email-masked]>
Date: Fri, 10 Feb 2012 09:12:41 -0800

Yes, where can I get the header file NetFSPrivate.h?

On Fri, Feb 10, 2012 at 1:02 AM, <[email-masked]> wrote:

> **
> Excuse me? Is that a question?
>
> I am having a hard time compiling the webDAV apple open source codes.  I
> am missing NetFS/NetFSPrivate.h header files.  Anyone has access to that
> file?
>
> Thanks.
>

---

From: Jim Luther <[email-masked]>
Date: Fri, 10 Feb 2012 10:45:28 -0800

You're asking your question in the wrong place. This mailing list is for webdav protocol questions and not for specific implementations of a product that uses the WebDAV protocol. You should really direct questions specific to Apple's file system implementations to [email-masked] which you can sign up for at <https://lists.apple.com/mailman/listinfo/filesystem-dev>.

However, in this case you're lucky because I used to work on the webdavfs code base (that was about 7 years ago) and I haven't ever unsubscribed from this mailing list.

In Mac OS 10.6 (SnowLeopard), network file system team at Apple unified the authentication/mount GUI for all of the network file systems shipped with the OS. The GUI code is in the NetFS framework, but that code is not public API -- that's why you don't have access to <NetFS/NetFSPrivate.h>. You could argue that those parts of NetFS should be API, but I can't help you with that.

However, you should be able to build the project by commenting out "#include <NetFS/NetFSPrivate.h>" and modify the code that gets the credentials from NetFS. You'll lose the GUI for getting credentials. Another alternative would be to get the older webdavfs sources (pre-10.6) to see how it implemented the GUI for credentials and then spend a bunch of time bringing those changes to the current source base.

That said, the reason we made the webdavfs source code open was as example code for programmers wanting to implement their own file systems for Mac OS. The source code wasn't published so that programmers could modify it and build it.

Good luck,
Jim

On Feb 10, 2012, at 9:12 AM, Syl-J CALIMPUSAN <[email-masked]> wrote:

>> I am having a hard time compiling the webDAV apple open source codes.  I am missing NetFS/NetFSPrivate.h header files.  Anyone has access to that file?
>> 
>> Thanks.
>>