Subject: [video-codec] Benjamin Kaduk's Discuss on draft-ietf-netvc-requirements-09: (with DISCUSS and COMMENT)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Thu, 13 Jun 2019 06:23:20 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-netvc-requirements-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netvc-requirements/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I support Roman's Discuss.

I am sympathetic to the tsv-art reviewer's concerns that this document
is focused on video technology of 5 years ago and may lack relevant in
the current world.  I don't intend to hold a Discuss point for any
specific resolution, but I do think the IESG should discuss whether this
concern affects the value of publishing this document as an RFC.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 2.1

What do "PAM" and "RA" mean?  Moving Appendix A earlier (before Section
2) or referring to it from the Introduction would be helpful.  Note that
RFC style is to expand on first use...

       . High Dynamic Range (HDR), Wide Color Gamut (WCG), high
          resolution (currently, up to 4K), high frame-rate content are
          important use cases, the codec should be able to encode such
          content efficiently.

nits: missing "and" in serial list, and the last comma is a comma splice.

Section 2.5

[Google didn't help me find reference [9].]

Section 2.6

The (long) list in Section 2.5 includes "cloud gaming"; how much overlap
does that have with this service?

Section 3.1, 3.2

What is the difference between "General Requirements" and "Basic
Requirements"?

ection 3.2.1

Is "Exemplary input source formats" supposed to just be an example, or
an indication of the pinnacle of possible values?

Section 4.1

   Initially, for the codec selected as a reference one (e.g., HEVC or
   VP9), a set of 10 QP (quantization parameter) values should be
   specified (in a separate document on Internet video codec testing)
   and corresponding quality values should be calculated. [...]

This seems to suggest ("Initially", "for the codec selected") that the
evaulation requirements are not yet complete.  Are they intended to be a
single set of requirements for the codec's development, or customized to
some per-application requirements?  (Is there a reference needed to
ongoing work to solidify these requirements?)

   QP'k = argmin { abs(Q'i(QP'i) - Qk(QPk)) },
          i in R

I would suggest defining the argmin function.

It's surprising to see no reference to draft-ietf-netvc-testing from
this document.

Section 6

I don't see much need for a "Conclusions" section of this nature, in
this document.

Appendix B

Defining (e.g.) "high dynamic range" and "wide color gamut" with respect
to "normal" or "conventional" mechanisms does not really provide a
stable and archival reference for comparison.

---

From: Filippov Alexey <[email-masked]>
Date: Thu, 13 Jun 2019 14:37:27 +0000

Dear Benjamin, all,

Thank you a lot for commenting our draft.

> I support Roman's Discuss.
Got it and try to answer the raised question as soon as possible.

> I am sympathetic to the tsv-art reviewer's concerns that this document is focused on video technology of 5 years ago and may lack relevant in the current world.
I'd like to comment the tsv-art reviewer's concerns. According to my understanding, the review is focused on the fact that support for quality and resolution scalability is not mandatory. These types of scalability are important but usually some price in terms of compression performance should be paid for their support. So, if it is efficiently implemented in a candidate codec (i.e. "with compression efficiency penalty up to 5% of BD-rate increase per layer" as pointed out in Section 3.3.2), they will be in the main profile. Otherwise, " a separate profile is needed ...". In my opinion, supporting for quality and resolution scalability without taking into account compression efficiency penalty may prevent successful adoption of NETVC codec by industry.

Another concern raised by the tsv-art reviewer is that support for screen content coding tools is not explicitly mentioned.
I absolutely agree that absence of these tools will harm compression performance of a candidate codec. So, if these tools are not used in a codec, it can't be competitive as compared to other candidate codecs. It will become apparent while testing it (by the way, the testing draft contains screen content materials). On the other hand, we shouldn't insist on supporting for specific screen content tools that would restrict the freedom of codec developers.

Please note that these and other concerns were addressed in my response:
https://mailarchive.ietf.org/arch/msg/tsv-art/RpypjqRJD_Njens-SYwdpRRQFU0

--
Best regards,
Alexey Filippov

-----Original Message-----
From: Benjamin Kaduk via Datatracker [mailto:[email-masked]] 
Sent: Thursday, June 13, 2019 4:23 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Mo Zanaty <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Benjamin Kaduk's Discuss on draft-ietf-netvc-requirements-09: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I am sympathetic to the tsv-art reviewer's concerns that this document is focused on video technology of 5 years ago and may lack relevant in the current world.  I don't intend to hold a Discuss point for any specific resolution, but I do think the IESG should discuss whether this concern affects the value of publishing this document as an RFC.

Section 2.1

What do "PAM" and "RA" mean?  Moving Appendix A earlier (before Section
2) or referring to it from the Introduction would be helpful.  Note that RFC style is to expand on first use...

Section 2.5

Section 2.6

The (long) list in Section 2.5 includes "cloud gaming"; how much overlap does that have with this service?

Section 3.1, 3.2

What is the difference between "General Requirements" and "Basic Requirements"?

ection 3.2.1

Is "Exemplary input source formats" supposed to just be an example, or an indication of the pinnacle of possible values?

Section 4.1

This seems to suggest ("Initially", "for the codec selected") that the evaulation requirements are not yet complete.  Are they intended to be a single set of requirements for the codec's development, or customized to some per-application requirements?  (Is there a reference needed to ongoing work to solidify these requirements?)

It's surprising to see no reference to draft-ietf-netvc-testing from this document.

Section 6

I don't see much need for a "Conclusions" section of this nature, in this document.

Appendix B

Defining (e.g.) "high dynamic range" and "wide color gamut" with respect to "normal" or "conventional" mechanisms does not really provide a stable and archival reference for comparison.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 14 Jun 2019 16:07:05 -0500

> https://mailarchive.ietf.org/arch/msg/tsv-art/RpypjqRJD_Njens-SYwdpRRQFU0

I did not your previous response, which is much appreciated.
Unfortunately, this is far from my area of expertise, so my main goal here
was to raise the question to the IESG at a whole, and having done that, I
have changed my ballot position to No Objection.  It would be great to hear
more from Bernard when he has time, and I think Adam is going to work on
getting that to happen.

-Ben