Subject: Re: [video-codec] IETF 100 NETVC meeting minutes

From: Jonatan Samuelsson <[email-masked]>
Date: Tue, 2 Jan 2018 14:10:05 +0100

Dear Mo, all,

Thanks for sharing the notes from the NETVC session at IETF 100.

I have a question related to the milestones, and in particular the 
"Submit reference implementation to IESG" and "Submit codec 
specification to IESG". It is noted that the milestone dates will be 
updated to 2018. Is it possible to follow the work being performed 
related to the completion of these two activities? Is the development 
being performed in a publicly available repository?

Best Regards Jonatan

Divideon
             Creators of xvc.io <https://xvc.io/>

*Jonatan Samuelsson*
Co-founder and CEO
Telephone: +467 21 88 21 69
Email: [email-masked] 
<mailto:[email-masked]>
https://www.divideon.com

On 2017-11-16 07:42, Mo Zanaty (mzanaty) wrote:
> The meeting minutes for the NETVC session at IETF 100 in Singapore 
> have been posted to:
>
> https://datatracker.ietf.org/doc/minutes-100-netvc/
>
> Please review and send any clarifications or corrections by Nov 27.
>
> Thanks to Nathan Egge for taking these notes.
>
> Mo
>
>
>
> _______________________________________________
> video-codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/video-codec

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Wed, 3 Jan 2018 05:11:45 +0000

Hi Jonatan,

The milestones for a codec specification and reference implementation require a single candidate, not multiple. So far, we do not have a single, merged codebase or specification submitted as a candidate for these milestones. The Daala and Thor codebases which have been submitted as candidates are available in public repositories, but have not been merged into a single candidate. Those teams have also been working in another public repository (AOM AV1) to merge their designs, but that codebase has not been proposed as a candidate codec by any proponent to date.

Best regards,
Mo

From: Jonatan Samuelsson <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 2, 2018 at 8:10 AM
To: mzanaty <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [video-codec] IETF 100 NETVC meeting minutes

Dear Mo, all,

I have a question related to the milestones, and in particular the "Submit reference implementation to IESG" and "Submit codec specification to IESG". It is noted that the milestone dates will be updated to 2018. Is it possible to follow the work being performed related to the completion of these two activities? Is the development being performed in a publicly available repository?

Best Regards Jonatan

[Divideon]
            Creators of xvc.io<https://xvc.io/>

Jonatan Samuelsson
Co-founder and CEO
Telephone: +467 21 88 21 69
Email: [email-masked]<mailto:[email-masked]>
https://www.divideon.com

On 2017-11-16 07:42, Mo Zanaty (mzanaty) wrote:
The meeting minutes for the NETVC session at IETF 100 in Singapore have been posted to:

Mo

_______________________________________________
video-codec mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/video-codec

---

From: Jonatan Samuelsson <[email-masked]>
Date: Thu, 4 Jan 2018 12:59:25 +0100

Dear Mo, all,

Thank you for the quick response. I am not really familiar with the 
working group's processes and ways of working, but I understand from 
your response that the group is still open to consider new candidate 
proposals. I assume at some point there will be a (final) evaluation to 
determine which candidate best meets the requirements chartered for the 
working group?

Best Regards Jonatan

Divideon

*Jonatan Samuelsson*
Co-founder and CEO

On 2018-01-03 06:11, Mo Zanaty (mzanaty) wrote:
> Hi Jonatan,
>
> The milestones for a codec specification and reference implementation 
> require a single candidate, not multiple. So far, we do not have a 
> single, merged codebase or specification submitted as a candidate for 
> these milestones. The Daala and Thor codebases which have been 
> submitted as candidates are available in public repositories, but have 
> not been merged into a single candidate. Those teams have also been 
> working in another public repository (AOM AV1) to merge their designs, 
> but that codebase has not been proposed as a candidate codec by any 
> proponent to date.
>
> Best regards,
> Mo
>
>
> From: Jonatan Samuelsson <[email-masked] 
> <mailto:[email-masked]>>
> To: mzanaty <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
>> [email-masked]://www.ietf.org/mailman/listinfo/video-codec
>

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Fri, 5 Jan 2018 04:47:32 +0000

Hi Jonatan,

That is correct, the working group can consider new candidate proposals. It would be preferable if proponents can determine if their candidates can be merged, but if that is not possible, you are also correct that a comparative evaluation would be necessary.

Best regards,
Mo

Date: Thursday, January 4, 2018 at 6:59 AM

Dear Mo, all,

Thank you for the quick response. I am not really familiar with the working group's processes and ways of working, but I understand from your response that the group is still open to consider new candidate proposals. I assume at some point there will be a (final) evaluation to determine which candidate best meets the requirements chartered for the working group?

Best Regards Jonatan

[Divideon]

Jonatan Samuelsson
Co-founder and CEO

Best regards,
Mo

Dear Mo, all,

Best Regards Jonatan

[Divideon]

Jonatan Samuelsson
Co-founder and CEO

Mo

---

From: Jonatan Samuelsson <[email-masked]>
Date: Mon, 8 Jan 2018 12:15:05 +0100

Dear Mo, all,

Thanks for the clarification. I will consider to prepare a candidate 
proposal for the upcoming IETF meeting. Please let me know if there are 
any specific deadlines or requirements related to a contribution (in 
addition to what is available at 
https://datatracker.ietf.org/wg/netvc/about/) to keep in mind when 
preparing the proposal.

Best Regards Jonatan

Divideon

*Jonatan Samuelsson*
Co-founder and CEO

On 2018-01-05 05:47, Mo Zanaty (mzanaty) wrote:
> Hi Jonatan,
>
> That is correct, the working group can consider new candidate 
> proposals. It would be preferable if proponents can determine if their 
> candidates can be merged, but if that is not possible, you are also 
> correct that a comparative evaluation would be necessary.
>
> Best regards,
> Mo
>
> proposals. I assume at some point there will be a (final) evaluation 
> to determine which candidate best meets the requirements chartered for 
> the working group?
>
> Best Regards Jonatan
>
> Divideon
>> submitted as candidates are available in public repositories, but 
>> have not been merged into a single candidate. Those teams have also 
>> been working in another public repository (AOM AV1) to merge their 
>> designs, but that codebase has not been proposed as a candidate codec 
>> by any proponent to date.
>>
>> Best regards,
>> Mo
>>
>>

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Mon, 8 Jan 2018 20:04:35 +0000

Hi Jonatan,

March 5 is the deadline for new drafts/contributions for IETF 101.
https://datatracker.ietf.org/meeting/important-dates/
2018-03-05 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59. Upload using the ID Submission Tool.

In addition to the NETVC charter, contributors should also be aware of the general requirements (related to Intellectual Property Rights) described in the IETF Note Well and the RFCs that it references (RFC 5378 and RFC 8179).
https://www.ietf.org/about/note-well.html

Best regards,
Mo

Date: Monday, January 8, 2018 at 6:15 AM

Dear Mo, all,

Thanks for the clarification. I will consider to prepare a candidate proposal for the upcoming IETF meeting. Please let me know if there are any specific deadlines or requirements related to a contribution (in addition to what is available at https://datatracker.ietf.org/wg/netvc/about/) to keep in mind when preparing the proposal.

Best Regards Jonatan

[Divideon]

Jonatan Samuelsson
Co-founder and CEO

Best regards,
Mo

Dear Mo, all,

Best Regards Jonatan

[Divideon]

Jonatan Samuelsson
Co-founder and CEO

Best regards,
Mo

Dear Mo, all,

Best Regards Jonatan

[Divideon]

Jonatan Samuelsson
Co-founder and CEO

Mo