Subject: Re: [video-codec] Call for review comments: draft-ietf-netvc-requirements

From: Filippov Alexey <[email-masked]>
Date: Tue, 2 Feb 2016 10:46:45 +0000

Dear Andrew, dear Greg,

Thank you so much for your comments and recommendations!

I agree with you that these frame-rates (presented in Table 2 in BT.2020-2) should be included into Table 1 of draft-ietf-netvc-requirements. However, I'd like to emphasize that all the tables presented in section 2 of draft-ietf-netvc-requirements provide just the most frequent use-cases and do not cover every use-case. So, I agree with James that variable frame-rate should be supported. Another question to be discussed is where it should be supported (in the NETVC codec or in a container).

Evidently, Andrew is absolutely right that the highest frame-rate should be limited in Table 6. In my opinion, the maximum frame-rate should depend on resolution to meet the complexity requirement.

--
Best regards,
Alexey Filippov

---

From: Thomas Daede <[email-masked]>
Date: Mon, 29 Feb 2016 12:24:42 -0800

I think the information in each section might be presented better as a
simpler table. In most of the cases, all of the entries under framerate
are the same, and also all of the entries under PAM are the same. For
example, for Video Sharing, you could do something like this:

+--------------+---------------------+
| Resolution   | 64x360 - 3840x2160  |
+--------------+---------------------+
| Frame Rate   | 24-60fps            |
+--------------+---------------------+
| Pixel Format | YUV 4:2:0           |
+--------------+---------------------+
| PAM          | RA                  |
+--------------+---------------------+

Or put it in the bulleted list, or move all of the bulleted list
parameters into the table.

On 02/02/2016 02:46 AM, Filippov Alexey wrote:
> I agree with you that these frame-rates (presented in Table 2 in
> BT.2020-2) should be included into Table 1 of
> draft-ietf-netvc-requirements. However, I’d like to emphasize that all
> the tables presented in section 2 of draft-ietf-netvc-requirements
> provide just the most frequent use-cases and do not cover every
> use-case. So, I agree with James that variable frame-rate should be
> supported. Another question to be discussed is where it should be
> supported (in the NETVC codec or in a container).
> 
>  
> 
> Evidently, Andrew is absolutely right that the highest frame-rate should
> be limited in Table 6. In my opinion, the maximum frame-rate should
> depend on resolution to meet the complexity requirement.
> 
>  
> 
> --
> 
> Best regards,
> 
> Alexey Filippov
> 
>  
> 
> 
> 
> _______________________________________________
> video-codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/video-codec
>