Subject: Re: [video-codec] Daala deringing filter vs Thor constrained low pass filter

From: Dake He <[email-masked]>
Date: Mon, 2 Nov 2015 10:35:26 +0000

‎In the results reported in the document, does the reference codec have deblocking enabled? Maybe this was addressed before. But I cannot seem to locate it.

Best,
Dake
  Original Message
From: Jean-Marc Valin
Sent: Thursday, October 29, 2015 1:39 PM
To: Mohammad AlSaleh; [email-masked]
Subject: Re: [video-codec] Daala deringing filter vs Thor constrained low pass filter

On 10/29/2015 12:41 PM, Mohammad AlSaleh wrote:
> Looking at chapel subjectively, I think an option to use a weaker
> filter would be helpful.
>
> Generally, the filter gives good subjective results. But some of
> the details might get lost (e.g. the last steps leading to the chapel).

It isn't really a matter of stronger vs weaker filter. The encoder can
turn the deringing filter on/off for every superblock, so any issue
would come down to how the encoder made the decision to keep the
filtered superblock. For example, the distortion function could be
missing something, or the encoder could be deciding to "sacrifice" some
region of the superblock to make another region better.

Cheers,

        Jean-Marc

_______________________________________________
video-codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/video-codec

---

From: Jean-Marc Valin <[email-masked]>
Date: Mon, 2 Nov 2015 08:54:45 -0500

Daala does not have a deblcking filter, but rather a lapping
post-filter. Deringing is applied after the lapping post-filter.

Cheers,

	Jean-Marc

On 11/02/2015 05:35 AM, Dake He wrote:
> ‎In the results reported in the document, does the reference codec
> have deblocking enabled? Maybe this was addressed before. But I
> cannot seem to locate it.
> 
> Best, Dake Original Message From: Jean-Marc Valin Sent: Thursday,
> October 29, 2015 1:39 PM To: Mohammad AlSaleh;
> [email-masked] Subject: Re: [video-codec] Daala deringing
> filter vs Thor constrained low pass filter
> 
> 
>> Looking at chapel subjectively, I think an option to use a
>> weaker filter would be helpful.
>> 
> It isn't really a matter of stronger vs weaker filter. The encoder
> can turn the deringing filter on/off for every superblock, so any
> issue would come down to how the encoder made the decision to keep
> the filtered superblock. For example, the distortion function could
> be missing something, or the encoder could be deciding to
> "sacrifice" some region of the superblock to make another region
> better.
> 
> Cheers,
> 
> Jean-Marc
> 
> _______________________________________________ video-codec mailing
> list [email-masked] 
> _______________________________________________ video-codec mailing
> list [email-masked]

---

From: Minhua Zhou <[email-masked]>
Date: Mon, 2 Nov 2015 16:12:24 +0000

So the deringing filter is also used as a post-filter, i.e. not in the prediction loop?  

Regards,

Minhua

-----Original Message-----
From: video-codec [mailto:[email-masked]] On Behalf Of Jean-Marc Valin
Sent: Monday, November 02, 2015 5:55 AM
To: Dake He; Jean-Marc Valin; [email-masked]
Subject: Re: [video-codec] Daala deringing filter vs Thor constrained low pass filter

Daala does not have a deblcking filter, but rather a lapping post-filter. Deringing is applied after the lapping post-filter.

Cheers,

	Jean-Marc

On 11/02/2015 05:35 AM, Dake He wrote:
> have deblocking enabled? Maybe this was addressed before. But I cannot 
> seem to locate it.
> 
> October 29, 2015 1:39 PM To: Mohammad AlSaleh; [email-masked] 
>> Generally, the filter gives good subjective results. But some of the 
>> details might get lost (e.g. the last steps leading to the chapel).
> 
> missing something, or the encoder could be deciding to "sacrifice" 
> some region of the superblock to make another region better.
> 
> Cheers,
> 
> Jean-Marc
>

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Mon, 02 Nov 2015 12:00:15 -0800

> So the deringing filter is also used as a post-filter, i.e. not in the prediction loop?

Both filters are in-loop.