Subject: [video-codec] Fwd: New Version Notification for draft-davies-netvc-irfvc-00.txt

From: "Thomas Davies (thdavies)" <[email-masked]>
Date: Tue, 20 Oct 2015 07:46:45 +0000

I submitted the following draft which describes a method of synthesising new reference frames for video coding, and how that is done in Thor.

Regards

Thomas

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Date: 19 October 2015 17:12:42 BST
To: Thomas Davies <[email-masked]<mailto:[email-masked]>>, Thomas Davies <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-davies-netvc-irfvc-00.txt

A new version of I-D, draft-davies-netvc-irfvc-00.txt
has been successfully submitted by Thomas Davies and posted to the
IETF repository.

Name:        draft-davies-netvc-irfvc
Revision:    00
Title:        Interpolated reference frames for video coding
Document date:    2015-10-19
Group:        Individual Submission
Pages:        8
URL:            https://www.ietf.org/internet-drafts/draft-davies-netvc-irfvc-00.txt
Status:         https://datatracker.ietf.org/doc/draft-davies-netvc-irfvc/
Htmlized:       https://tools.ietf.org/html/draft-davies-netvc-irfvc-00

Abstract:
  This document describes the use of interpolated reference frames in
  video coding in general, and in the Thor video codec in particular.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Yushin Cho <[email-masked]>
Date: Tue, 20 Oct 2015 10:47:59 -0700

Hi Thomas,

I have some questions.
1) In subsection "3.2.  Motion estimation process",
   "Since F does not exist the motion estimation process consists of
   matching blocks B+mv0 in R0 with blocks B+mv1 in R1."
Does 'B' there probably mean each block in frame F? It was not defined anywhere.

2) Once interpolated reference frame F is obtained, which I understand
will spend some bits
unless all 16x16 blocks can be skipped, a regular motion estimation on
top of frame F
with target original input frame is performed?
As implied by "The aim is to create a reference frame that is
temporally co-located with
the current frame being predicted," in "1. Introduction".

3) Lastly, is the interpolated reference frame F only used for B-frame,
since frame F itself is anyway motion compensated bi-directionally,
i.e. past and future frames (or the other way), R0 and R1,
though the current frame can be coded as a P-frame style once F is provided?

Thanks,
Yushin

On Tue, Oct 20, 2015 at 12:46 AM, Thomas Davies (thdavies) <
[email-masked]> wrote:

> I submitted the following draft which describes a method of synthesising
> new reference frames for video coding, and how that is done in Thor.
>
> Regards
>
> Thomas
>
>
>
> Begin forwarded message:
>
> *From:* <[email-masked]>
> *Date:* 19 October 2015 17:12:42 BST
> *To:* Thomas Davies <[email-masked]>, Thomas Davies <
> [email-masked]>
> *Subject:* *New Version Notification for draft-davies-netvc-irfvc-00.txt*
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-davies-netvc-irfvc-00.txt
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
> _______________________________________________
> video-codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/video-codec
>
>

-- 
Thanks!
Yushin

---

From: Thomas Davies <[email-masked]>
Date: Wed, 21 Oct 2015 09:46:57 +0100

Hi Yushin

On 20/10/15 18:47, Yushin Cho wrote:
> Does 'B' there probably mean each block in frame F? It was not defined anywhere

Yes.
> .
> 2) Once interpolated reference frame F is obtained, which I understand will spend some bits
> unless all 16x16 blocks can be skipped, a regular motion estimation on top of frame F
There are no bits spent on the interpolated reference frame. Yes, a 
regular ME is done after that. In our code the two MEs are different, 
but really the conventional ME should make use of candidates derived 
from the interpolation.

> As implied by "The aim is to create a reference frame that is temporally co-located with
Yes, I've tried it and it doesn't give gains. I think this is because 
the interpolation is "pull" from references rather than "push" + infill. 
"Pull" has the advantage that there is no infilling to do , and for the 
bidirectional case it's usually not desirable as good references can be 
found on both sides of a motion discontinuity. But with 1-sided 
interpolation i.e. extrapolation, at motion discontinuities there is no 
information for revealed areas, so some kind of infilling is needed. 
Hence moving edges tend to be truncated with this method. Perhaps some 
of the Daala inpainting work could be applied in this context.

best regards

Thomas

> Thanks,
> Yushin
>
> On Tue, Oct 20, 2015 at 12:46 AM, Thomas Davies (thdavies) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I submitted the following draft which describes a method of
>     synthesising new reference frames for video coding, and how that
>     is done in Thor.
>
>     Regards
>
>     Thomas
>
>
>
>     Begin forwarded message:
>
>>     *From:* <[email-masked] <mailto:[email-masked]>>
>>     *To:* Thomas Davies <[email-masked]
>>     <mailto:[email-masked]>>, Thomas Davies <[email-masked]
>>     <mailto:[email-masked]>>
>>     until the htmlized version and diff are available at
>>     tools.ietf.org <http://tools.ietf.org>.
>>
>>     The IETF Secretariat
>>
>
>     [email-masked] <mailto:[email-masked]>