Subject: [video-codec] Interlacing support

From: Thomas Daede <[email-masked]>
Date: Tue, 7 Jul 2015 11:20:59 -0700

I don't think we should support interlacing in the netvc bitstream. I
bring this up because draft-filippov-netvc-requirements-01 still
specifies some interlaced modes.

Arguments against interlacing:
- Requires extra features to encode efficiently. HEVC has dropped MBAFF,
libvpx has never supported interlacing.
- Moves deinterlacer complexity to the encoder, which is an easier place
to offload complexity
- There are no internet-connected interlaced displays in common usage

If anyone has counterarguments, I'd like to hear them.

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Tue, 07 Jul 2015 11:29:35 -0700

> - There are no internet-connected interlaced displays in common usage

I'll add one more: brings into play a large amount of additional IPR to 
avoid.

---

From: "Krupiczka, Andrew" <[email-masked]>
Date: Tue, 7 Jul 2015 18:43:02 +0000

Hello everyone,
Yes, unlike H.264 the HEVC doesn't provide any encoding tools specific to the interlaced format sourced content.
Not to say, the 1080i format is well alive and still very important for some broadcasters and markets due to operational distribution infrastructure.
Even, if the interlaced format content is to be encoded it can always be deinterlaced prior and as noted no need for re-interlacing it back for display devices.
Best regards, 
Andrew

-----Original Message-----
From: video-codec [mailto:[email-masked]] On Behalf Of Timothy B. Terriberry
Sent: Tuesday, July 07, 2015 2:30 PM
To: [email-masked]
Subject: Re: [video-codec] Interlacing support

Thomas Daede wrote:
> - Requires extra features to encode efficiently. HEVC has dropped 
> MBAFF, libvpx has never supported interlacing.
> - Moves deinterlacer complexity to the encoder, which is an easier 
> place to offload complexity

I'll add one more: brings into play a large amount of additional IPR to avoid.

_______________________________________________
video-codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/video-codec

---

From: Mohammed Raad <[email-masked]>
Date: Tue, 7 Jul 2015 23:00:13 +0200

I agree, I don't see a reason for supporting interlace in future video
codecs.

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Tue, 7 Jul 2015 21:55:49 +0000

+1

On Jul 7, 2015, at 5:00 PM, Mohammed Raad <[email-masked]<mailto:[email-masked]>> wrote:

I agree, I don't see a reason for supporting interlace in future video codecs.

On 7 Jul 2015 21:29, "Timothy B. Terriberry" <[email-masked]<mailto:[email-masked]>> wrote:
Thomas Daede wrote:

_______________________________________________
video-codec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/video-codec
_______________________________________________
video-codec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/video-codec