Subject: [video-codec] Minor comments on draft-fuldseth-netvc-thor-00

From: "Timothy B. Terriberry" <[email-masked]>
Date: Tue, 07 Jul 2015 14:03:38 -0700

In section 8.1.1, step 4, the calculations of c' and d' are supposed to 
use subtractions instead of additions, right?

A similar question applies to the calculation of c' in 8.2.1 step 3.

In Table 3 in Section 9.2.6, index 9 should code (run=2,level>1), right?

---

From: "Arild Fuldseth (arilfuld)" <[email-masked]>
Date: Wed, 8 Jul 2015 20:36:40 +0000

Tim,

Yes, you are right on all points.

Thank you for pointing that out.

Regards,

Arild

-----Original Message-----
From: video-codec [mailto:[email-masked]] On Behalf Of Timothy B. Terriberry
Sent: 7. juli 2015 23:04
To: [email-masked]
Subject: [video-codec] Minor comments on draft-fuldseth-netvc-thor-00

In section 8.1.1, step 4, the calculations of c' and d' are supposed to use subtractions instead of additions, right?

_______________________________________________
video-codec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/video-codec

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Thu, 9 Jul 2015 16:11:59 +0000

Another correction in section 9.2.6:
Table 3, Index=2 should show abs(coeff)=4 and level=4.
Figure 10, the last 0 should be removed.
All corrections will be updated in a new draft version once submission
reopens.

Mo

On 7/8/15, 4:36 PM, video-codec on behalf of Arild Fuldseth (arilfuld)
<[email-masked] on behalf of [email-masked]> wrote:

Tim,

Regards,

Arild

-----Original Message-----
From: video-codec [mailto:[email-masked]] On Behalf Of
Timothy B. Terriberry
Sent: 7. juli 2015 23:04
To: [email-masked]
Subject: [video-codec] Minor comments on draft-fuldseth-netvc-thor-00

---

From: Yushin Cho <[email-masked]>
Date: Fri, 10 Jul 2015 11:51:06 -0700

More erratas found:

In 8.1.2. 
Delocking —> Deblocking

In 9.2.5
is the sort —> is to sort

> On Jul 9, 2015, at 9:11 AM, Mo Zanaty (mzanaty) <[email-masked]> wrote:
>

---

From: Jean-Marc Valin <[email-masked]>
Date: Fri, 10 Jul 2015 15:00:49 -0400

I see in section 4 that there are only 8 intra modes including DC,
rather than 9. I didn't understand why "upright" is missing, nor what
"The upright and upleft directions are exactly 45 degrees" means in that
context. Can you explain?

Cheers,

	Jean-Marc

---

From: "Arild Fuldseth (arilfuld)" <[email-masked]>
Date: Sat, 11 Jul 2015 16:53:05 +0000

Dear Yushin,

Thank you for pointing out these typos.

Regards,

Arild

-----Original Message-----
From: Yushin Cho [mailto:[email-masked]] 
Sent: 10. juli 2015 20:51
To: Arild Fuldseth (arilfuld)
Cc: [email-masked]
Subject: Re: [video-codec] Minor comments on draft-fuldseth-netvc-thor-00

More erratas found:

In 8.1.2. 
Delocking —> Deblocking

In 9.2.5

> In section 8.1.1, step 4, the calculations of c' and d' are supposed 
> to use subtractions instead of additions, right?
>

---

From: "Arild Fuldseth (arilfuld)" <[email-masked]>
Date: Sat, 11 Jul 2015 16:56:40 +0000

For the time being, we have decided to limit the number of intra prediction modes to 8. In our simulations, the upright mode provides less coding gain than the other 8 modes. The quote is a typo. It should read:

 "The upleft direction is exactly 45 degrees"

Regards,

Arild

-----Original Message-----
From: Jean-Marc Valin [mailto:[email-masked]] 
Sent: 10. juli 2015 21:01
To: Mo Zanaty (mzanaty); Arild Fuldseth (arilfuld); Timothy B. Terriberry; [email-masked]
Subject: Re: [video-codec] Minor comments on draft-fuldseth-netvc-thor-00

I see in section 4 that there are only 8 intra modes including DC, rather than 9. I didn't understand why "upright" is missing, nor what "The upright and upleft directions are exactly 45 degrees" means in that context. Can you explain?

Cheers,

	Jean-Marc