Subject: [video-codec] Temporal characteristics of screensharing

From: Jonathan Lennox <[email-masked]>
Date: Wed, 22 Jul 2015 22:17:17 +0000

Hi, all —

As requested, I’m posting to the list my comment at the mic today about the temporal characteristics of screensharing.

The characteristic I was describing is not universal to everything that’s described as “screensharing,” but it’s notable in the common use case of presentation sharing and the like.

The characteristic I’m thinking of is that the video stays static or nearly static for long but unpredictable periods of time (showing the slide), and then many parts of the image change all at once with little or no commonality with the previous image (changing the slide). But there may also be periods of time with more traditional video-like behavior (animations and the like).

---

From: Thomas Daede <[email-masked]>
Date: Fri, 24 Jul 2015 00:23:21 +0200

OK. From my understanding, it should be very easy to get high
performance from this sort of content in a constant-quality mode. The
tricky part is doing this with CBR rate control constraints.

Do the CBR bounds specified in the presentation make sense (300ms bucket
allowed for deviations)? If so, I think that test case is sufficient.

On 07/23/2015 12:17 AM, Jonathan Lennox wrote:
> _______________________________________________
> video-codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/video-codec
>