Subject: [Tools-implementation] Rough draft of message to the community re Zulip and Matrix

From: Robert Sparks <[email-masked]>
Date: Mon, 21 Sep 2020 14:20:11 -0500

All -

First, note that Glen is offline this week, and I do not expect him to 
see any of this conversation until he returns. But please don't wait for 
him to refine this. I would like to have it in a form that we can send 
by early next week.

Please point out (and offer text for) missing things that need to be 
addressed in this initial message.

====

We are deploying trials of the matrix and zulip chat services to gain
operational experience and get community feedback about how well these 
services
meet the need for IETF related chat.

The installs currently have almost no local configuration or customization.
Over the next few weeks, we will be exploring reconfiguring them to use
datatracker credentials for sign-in, and explore bridging between these 
systems,
Slack, and Jabber.

The secretariat is operating each instance. We've chosen this path for these
trials over third party hosting to learn what would be needed if the 
community
felt self-hosting was important in the longer term.

The services can be found at matrix-trial1.ietf.org and 
zulip-trial1.ietf.org.

Any matrix client can be used with the trial matrix server. We are also 
hosting
an instance of the element web client at matrix-trial1.ietf.org.

Similarly any zulip client can be used with the trial zulip server, 
which has a
built in web interface.

Around December, we will assess our experiences and the feedback received to
inform what chat services we provide in the future and how we will operate
them. In January, these trial instances will be taken down. We do not 
intend to
preserve or migrate any account configuration or chat history from the trial
instances as we move forward.

This does add to the potentially confusing large number of places 
conversation
might take place. We hope to address that with some level of bridging, 
at least
with Jabber, but have been cautioned by the respective development 
communities
that bridging between Zulip and Matrix is unsatisfying since the 
conversation
models in the two applications are so different.

The chat services are intended to be explorational and informal. However,
please treat them as contexts where participation rules apply (See
https://www.ietf.org/about/note-well/).

We are not, at this time, planning to host jabber accounts. We may 
revisit that
as an option as we continue to gather more feedback.

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Sep 2020 16:10:56 -0400

Robert:

Comments below.

Russ

> On Sep 21, 2020, at 3:20 PM, Robert Sparks <[email-masked]> wrote:
> 
> All -
> 
> First, note that Glen is offline this week, and I do not expect him to see any of this conversation until he returns. But please don't wait for him to refine this. I would like to have it in a form that we can send by early next week.
> 
> Please point out (and offer text for) missing things that need to be addressed in this initial message.
> 
> ====
> 
> operational experience and get community feedback about how well these services

Is thee a sentence or two you can add about the things that we hope will be better than the current solution?

We expect the chat to support face-to-face IETF meetings, virtual meetings, interim meetings, and virtual hallway discussions.  We should say that all of these are dimensions to consider.

> datatracker credentials for sign-in, and explore bridging between these systems,
> Slack, and Jabber.
> 
> trials over third party hosting to learn what would be needed if the community
> The services can be found at matrix-trial1.ietf.org and zulip-trial1.ietf.org.
> 
> Any matrix client can be used with the trial matrix server. We are also hosting

... there is also a web client available at matrix-trial1.ietf.org. 

It currently refuses to create an account with "common" names that are easy to guess.  This does not seem ideal for the IETF community.

This should tell people what convention we want to use for these accounts.

> 
> Similarly any zulip client can be used with the trial zulip server, which has a
> built in web interface.

It currently uses your email address, which is not bad for the IETF.  However, I never got the email when I tried to create an account.  Probably needs plumbing into the IETF mail system.

This should tell people that their email address will be used, and ask them ti use the email address known to the datatracker.

> inform what chat services we provide in the future and how we will operate

Where do we want them to provide feedback?

> them. In January, these trial instances will be taken down. We do not intend to
> This does add to the potentially confusing large number of places conversation
> might take place. We hope to address that with some level of bridging, at least
> with Jabber, but have been cautioned by the respective development communities
> that bridging between Zulip and Matrix is unsatisfying since the conversation

... IETF participation ...

Some would argue that NOTE WELL applies to contributes, not participation.  You may want to word smith to avoid that tussle.

> We are not, at this time, planning to host jabber accounts. We may revisit that

---

From: Robert Sparks <[email-masked]>
Date: Mon, 21 Sep 2020 15:18:31 -0500

a couple of quick responses inline

> This should tell people what convention we want to use for these accounts.

Expand please?

I don't think this initial message should be speaking at the level of 
"what your account name can look like". I also don't think we want to 
try to start changing the configuration to route around this kind of 
issue (unless we're forced to to make progress). Letting people see 
these kinds of edges are part of why we're running this as a trial set 
of services.

> It currently uses your email address, which is not bad for the IETF.  However, I never got the email when I tried to create an account.

Something we'll have to wait for Glen to get back online for to diagnose.

>   Probably needs plumbing into the IETF mail system.
>

Well, as we get a week or two in, we may integrate accounts with the 
datatracker anyhow, so it may be moot.

But I don't think we should wait on getting that integration working 
beforew we start getting feedback. I've already called out that we will 
be making changes like that.

> Where do we want them to provide feedback?
I think tools-discuss

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Sep 2020 16:23:36 -0400

The zulip client email did come, but it took a long time.  The next screen has Glen's email address.  Shouldn't it have [email-masked] <mailto:[email-masked]>?

Russ

> On Sep 21, 2020, at 4:10 PM, Russ Housley <[email-masked]> wrote:
> 
> Robert:
> 
> Comments below.
> 
> Russ
> 
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Sep 2020 16:29:25 -0400

> On Sep 21, 2020, at 4:18 PM, Robert Sparks <[email-masked]> wrote:
> 
> I don't think this initial message should be speaking at the level of "what your account name can look like". I also don't think we want to try to start changing the configuration to route around this kind of issue (unless we're forced to to make progress). Letting people see these kinds of edges are part of why we're running this as a trial set of services.

Do we want them to use their email address or some handle?  I was surprised that "housley" was rejected.  I think we want to tell people enough that they do not get surprised.

> Something we'll have to wait for Glen to get back online for to diagnose.

It came, but it took a long time.  We may want to tell people to expect that ...

> Well, as we get a week or two in, we may integrate accounts with the datatracker anyhow, so it may be moot.
> 
> But I don't think we should wait on getting that integration working beforew we start getting feedback. I've already called out that we will be making changes like that.

It will be easy if the user names are the same.  It will be a bigger pain if they have to make a new account.

> -- 
> Tools-implementation mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-implementation

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Sep 2020 08:29:34 +1200

> On 22/09/2020, at 8:10 AM, Russ Housley <[email-masked]> wrote:
> 
> Robert:
> 
> Comments below.
> 
> Russ
> 
> 

"We have clear evidence from the IETF 107 post-meeting survey  (https://www.ietf.org/media/documents/ietf-107-survey-results.pdf <https://www.ietf.org/media/documents/ietf-107-survey-results.pdf>) that many IETF participants find jabber a significant problem  This is partly due to difficulties in finding a free jabber service and partly due to client issues.  There are two paths to try to resolve these problems, one is to improve the IETF jabber service and the other is to switch to an alternative groupchat solution.  The community has already taken a step on the latter path with the introduction of an IETF Slack space, and we want to ensure that this path is properly explored by widening the range of options to well established free/open source tools." 

> ... there is also a web client available at matrix-trial1.ietf.org <http://matrix-trial1.ietf.org/>. 
> 

I suggest "treat them as contexts where contribution rules apply" as 'contribution' is specifically defined to include groupchat messages.

Jay

> 
>> https://www.ietf.org/about/note-well/ <https://www.ietf.org/about/note-well/>).
>> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Sep 2020 13:18:47 -0500

I think this reflects the comments so far, with the exception of not 
talking about the potential delay for the zulip email message. Lets wait 
for Glen to have an opportunity to look/tweak before we talk about that.

-----

We have clear evidence from the IETF 107 post-meeting survey
(https://www.ietf.org/media/documents/ietf-107-survey-results.pdf) that many
IETF participants find jabber a significant problem.  This is partly due to
difficulties in finding a free jabber service and partly due to client
issues.  There are two paths to try to resolve these problems, one is to
improve the IETF jabber service and the other is to switch to an alternative
groupchat solution.  The community has already taken a step on the latter
path with the introduction of an IETF Slack space, and we want to ensure 
that
this path is properly explored by widening the range of options to well
established free/open source tools.

The installs currently have almost no local configuration or customization.
Over the next few weeks, we will be exploring reconfiguring them to use
datatracker credentials for sign-in, and explore bridging between these
systems, Slack, and Jabber. One consequence of these explorations is that
there will  likely be times, outside of meetings, when accounts will be
disrupted or even removed and will have to be recreated. Initially, we
suggest you use an email address for the username on each service.

Any matrix client can be used with the trial matrix server. There is also a
web client available at at matrix-trial1.ietf.org.

We would like feedback on how well each client meets chat needs during
meetings, both the full online IETF 109 meeting, virtuals, adhocs, and
hallway conversations.

The chat services are intended to be explorational and informal. However,
please treat them as contexts where contribution rules apply (See
https://www.ietf.org/about/note-well/).

Please send feedback on the services to [email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Sep 2020 13:21:40 -0500

One edit to correct a mangle already:

On 9/25/20 1:18 PM, Robert Sparks wrote:
> talking about the potential delay for the zulip email message. Lets 
> wait for Glen to have an opportunity to look/tweak before we talk 
> about that.
>
> -----
>
> path with the introduction of an IETF Slack space, and we want to 
> ensure that
> meetings, both the full online IETF 109 meeting, 

> virtuals,
was meant to be "interims".
> adhocs, and