Subject: [Tools-implementation] Building an understanding of the directories at ietf/YYmon

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Sep 2020 13:39:25 -0500

Does anyone already understand what all the directories at 
/a/www/ietf-ftp/ietf/YYmon (e.g 99nov) are all about?

I can make some guesses based on what I see there (I think they were an 
early effort to organize meeting materials, but it would be better if 
there were a definitive description of them already lying around.

rjsparks@ietfa:/a/www/ietf-ftp/ietf> ls -d [0-9][0-9][a-z][a-z][a-z]
00dec  01mar  03jul  04nov  90dec  92mar  94dec  95jul    97aug 99jul
00jul  02dec  03mar  05aug  91jul  92nov  94jul  96dec    97dec 99mar
00mar  02jul  03nov  05mar  91mar  93jul  94mar  96jun    98aug 99nov
01aug  02mar  04aug  05nov  91nov  93mar  95apr  96mar    98dec
01dec  02nov  04mar  06mar  92jul  93nov  95dec  97apr    98mar

The newest file there is:

-rw-rw-rw- 1 wwwrun www 279 Aug  1  2001 01aug/opsarea.txt

Looking through the http configs, they get served at 
https://www.ietf.org/ietf/YYmon, and there are a smattering of hits for 
them in the logs, all from spiders.

Some RFCs reference them:

rfc1719:

> 1. Introduction
>
>     At the Amsterdam IETF meeting, we held a BOF, entitled the "IPDecide
>     BOF", on the process and progress of the IPng activities.
>
>     ("IPng" stands for "IP, the next generation".   The IPDecide BOF was
>     chaired by Brian Carpenter.  Minutes are available in the IETF
>     directories, with the file name </ietf/93jul/ipdecide-minutes-
>     93jul.txt>.)

rfc1752:

>     [Carpen93] Carpenter, B. and T. Dixon, "Minutes of the IPng Decision
>        Process BOF (IPDECIDE)", /ietf/93jul/ipdecide-minutes-93jul.txt,
>        August 1993.

rfc3238:

>     [OPESBOF1]  OPES BOF, 49th IETF, December 12, 2000.  Agenda:
>                 "http://www.ietf.org/ietf/00dec/opes-agenda.txt".
>                 Minutes:  "http://www.ietf.cnri.reston.va.us/
>                 proceedings/00dec/toc.htm#P25_256".
>
> IAB Informational [Page 14]
> RFC 3238 IAB Considerations for OPES January 2002
>
>     [OPESBOF2]  OPES BOF, 50th IETF, March 9, 2001.  Minutes:
>                 "http://www.ietf.org/proceedings/01mar/ietf50-40.htm".
>
>     [OPESBOF3]  OPES BOF, 51st IETF, August 2001.  Agenda:
>                 "http://www.ietf.org/ietf/01aug/opes.txt".  Minutes:
>                 "http://www.ietf.org/proceedings/01aug/minutes/OPES.HTM".

I think these would go into a museum that gets served somewhere, but I 
don't know if we should force that to continue to be a slice of the 
www.ietf.org namespace.

Is it ok to break those few URLs and enter errata against the RFCs to 
point to where we move them to?

There's no real win to slice parts of https://www.ietf.org/ietf/ out 
with redirects - I'd like to return everything under that url to be 
something the website (i.e. wagtail) can use. Otherwise we decide to 
continue to live with having that chunk of the namespace dispatched to a 
separate service than wagtail.

RjS

---

From: Russ Housley <[email-masked]>
Date: Tue, 1 Sep 2020 14:59:01 -0400

If memory serves, the proceedings used to include a snapshot of the I-Ds that were active at the time of the meeting.  This is from a time when the proceedings were distributed as a CD-ROM.

Russ

> On Sep 1, 2020, at 2:39 PM, Robert Sparks <[email-masked]> wrote:
> 
> Does anyone already understand what all the directories at /a/www/ietf-ftp/ietf/YYmon (e.g 99nov) are all about?
> 
> I can make some guesses based on what I see there (I think they were an early effort to organize meeting materials, but it would be better if there were a definitive description of them already lying around.
> 
> Looking through the http configs, they get served at https://www.ietf.org/ietf/YYmon <https://www.ietf.org/ietf/YYmon>, and there are a smattering of hits for them in the logs, all from spiders.
> 
>>                "http://www.ietf.org/ietf/00dec/opes-agenda.txt" <http://www.ietf.org/ietf/00dec/opes-agenda.txt>.
>>                proceedings/00dec/toc.htm#P25_256" <http://www.ietf.cnri.reston.va.us/proceedings/00dec/toc.htm#P25_256>.
>> 
>>                "http://www.ietf.org/proceedings/01mar/ietf50-40.htm" <http://www.ietf.org/proceedings/01mar/ietf50-40.htm>.
>> 
>>                "http://www.ietf.org/ietf/01aug/opes.txt" <http://www.ietf.org/ietf/01aug/opes.txt>.  Minutes:
>>                "http://www.ietf.org/proceedings/01aug/minutes/OPES.HTM" <http://www.ietf.org/proceedings/01aug/minutes/OPES.HTM>.
> 
> 
> I think these would go into a museum that gets served somewhere, but I don't know if we should force that to continue to be a slice of the www.ietf.org <http://www.ietf.org/> namespace.
> 
> Is it ok to break those few URLs and enter errata against the RFCs to point to where we move them to?
> 
> There's no real win to slice parts of https://www.ietf.org/ietf/ <https://www.ietf.org/ietf/> out with redirects - I'd like to return everything under that url to be something the website (i.e. wagtail) can use. Otherwise we decide to continue to live with having that chunk of the namespace dispatched to a separate service than wagtail.
> 
> RjS
> 
> 
> 
> 
> 
> 
> 
> -- 
> Tools-implementation mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-implementation

---

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Sep 2020 14:12:22 -0500

On 9/1/20 1:59 PM, Russ Housley wrote:
> If memory serves, the proceedings used to include a snapshot of the 
> I-Ds that were active at the time of the meeting.  This is from a time 
> when the proceedings were distributed as a CD-ROM.
Yes, but I don't think that's what these directories contain. There are 
other directories that support the cd-rom images, and proceedings.
>
> Russ
>
>
>> On Sep 1, 2020, at 2:39 PM, Robert Sparks <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> I can make some guesses based on what I see there (I think they were 
>> an early effort to organize meeting materials, but it would be better 
>> if there were a definitive description of them already lying around.
>>
>> https://www.ietf.org/ietf/YYmon, and there are a smattering of hits 
>> for them in the logs, all from spiders.
>>
>>>                 Minutes:"http://www.ietf.cnri.reston.va.us/ proceedings/00dec/toc.htm#P25_256".
>>>
>> I think these would go into a museum that gets served somewhere, but 
>> I don't know if we should force that to continue to be a slice of the 
>> www.ietf.org namespace.
>>
>> continue to live with having that chunk of the namespace dispatched 
>> to a separate service than wagtail.
>>
>> RjS
>>
>>
>>
>>
>> -- 
>> [email-masked] <mailto:[email-masked]>