Subject: [Tools-implementation] Artifacts

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Aug 2020 09:59:11 -0500

This is my first pass at pulling out the things I think we should think 
of as artifacts.

For me, it has been helpful to consider what would work well being put 
in something like one or more s3 buckets (I'm not proposing we _do_ 
that, but thinking about it that way clarified the nature of some of the 
things for me).

Not all of these things would be published - Some are things we just 
have to keep online. Some are things that should only be seen through 
software, but much is stuff that should just be in the public record and 
when we look at improving how we put it there, we should make it as 
self-documenting as we can.

-----

- Artifact related things
     - /a/jabber    Jabber Room Logs, Shared between EJabberD and 
Apache    Glen    simple artifacts
     - /a/rsync    RSYNC operations (contains only one directory)    
Glen    The one directory is an artifact directory (bibxml). That should 
move to a place we serve artifacts from
         - /a/rsync/bibxml    RSYNC BIBXML mirror    Henrik
     - /a/www/audio    Audio file repository    Glen    last we have is 
mp3s from 106. We aren't serving this - is it entirely archival?
     - /a/www/ietf-ftp    SITE: ftp.ietf.org <http://ftp.ietf.org>
         - /a/www/ietf-ftp/charter
         - /a/www/ietf-ftp/concluded-wg-ietf-mail-archive
         - /a/www/ietf-ftp/conflict-reviews
         - /a/www/ietf-ftp/iana
         - /a/www/ietf-ftp/iana-timezone
         - /a/www/ietf-ftp/ietf    Primary FTP directory
         - /a/www/ietf-ftp/ietf-mail-archive    Contains text versions 
of mail archive    Ryan
         - /a/www/ietf-ftp/ietf-online-proceedings    Limited copy of 
proceedings from 1993-1996, 2005
         - /a/www/ietf-ftp/ietf/99nov    Many yymmm directories like this
         - /a/www/ietf-ftp/ietf/IPR
         - /a/www/ietf-ftp/ietf/aaa    Many directories named for wg 
acronyms like this
         - /a/www/ietf-ftp/internet-drafts    Active Internet Draft 
repository
         - /a/www/ietf-ftp/review
         - /a/www/ietf-ftp/rfc
         - /a/www/ietf-ftp/slides
         - /a/www/ietf-ftp/status-changes
         - /a/www/ietf-ftp/yang
     * /a/www/nomcom    Nomcom ???    Henrik
     * /a/www/public_keys    Possibly Nombom also???    Henrik
     - /a/www/www6s/archive/id    Master combined repository of all 
247923 Internet-drafts
     - /a/www/www6s/diskimages    Legacy ISO images for IETF 68 through 
IETF 80
     - /a/www/www6s/download    Four files (id-abstract.txt, id-all.txt 
id-index.txt rfc-index.txt)
     * /a/www/www6s/draft-archive    Contains 177334 Internet-drafts
     - /a/www/www6s/lou-berger-archive    Contains 260 Internet-drafts 
from 1997-2004        is ghostlinkd feeding from this? Why is it in such 
a different place?
     - /a/www/www6s/proceedings    Active Proceedings storage 
directory        we should dive into this. "mail" is just a copy of a 
draft? Some of this is old, fully built out web content. Others is just 
artifact to support datataracker. Should separate these to make 
management clearer in the future.
     - /a/www/video    Video internal archive    Glen
     - /a/www/www6s/status-report/imr    Current Status Report pages    
     Is this what's served at 
https://www.ietf.org/status-report/ietf-progress-report.html?
     * /a/www/www6s/tool-id-archive    Cotains 88844 Internet-drafts 
1992-2020        Are these used by ghostlinkd?
     - /a/www/www6s/wg-descriptions    Contains 880 text files named for 
WGS from 2008-2012
     - /a/www/wwws/enc    Public mount point for PGP public key and 
Draft signing bundle    Glen
     - /a/www/wwws/images    Contains 89 image files 2004-2018     These 
are probably artifacts, though might think about them as statics. What 
uses them? Should they be in a directory that makes that more obvious?

---

From: Russ Housley <[email-masked]>
Date: Mon, 24 Aug 2020 12:15:40 -0400

Robert:

We have never served the audio files directly, but we need to keep them for other reasons, and these are the onlu files that could be delivered in response to a subpoena for audio.  The way the audio is delivered by youtube means that we cannot vouch for their integrity.

Russ

> On Aug 24, 2020, at 10:59 AM, Robert Sparks <[email-masked]> wrote:
> 
> This is my first pass at pulling out the things I think we should think of as artifacts.
> 
> For me, it has been helpful to consider what would work well being put in something like one or more s3 buckets (I'm not proposing we _do_ that, but thinking about it that way clarified the nature of some of the things for me).
> 
> Not all of these things would be published - Some are things we just have to keep online. Some are things that should only be seen through software, but much is stuff that should just be in the public record and when we look at improving how we put it there, we should make it as self-documenting as we can.
> 
> -----
> 
>     - /a/jabber    Jabber Room Logs, Shared between EJabberD and Apache    Glen    simple artifacts
>     - /a/rsync    RSYNC operations (contains only one directory)    Glen    The one directory is an artifact directory (bibxml). That should move to a place we serve artifacts from
>     - /a/www/audio    Audio file repository    Glen    last we have is mp3s from 106. We aren't serving this - is it entirely archival?
>         - /a/www/ietf-ftp/ietf-mail-archive    Contains text versions of mail archive    Ryan
>         - /a/www/ietf-ftp/ietf-online-proceedings    Limited copy of proceedings from 1993-1996, 2005
>         - /a/www/ietf-ftp/ietf/aaa    Many directories named for wg acronyms like this
>         - /a/www/ietf-ftp/internet-drafts    Active Internet Draft repository
>         - /a/www/ietf-ftp/review
>         - /a/www/ietf-ftp/rfc
>         - /a/www/ietf-ftp/slides
>     - /a/www/www6s/archive/id    Master combined repository of all 247923 Internet-drafts
>     - /a/www/www6s/diskimages    Legacy ISO images for IETF 68 through IETF 80
>     - /a/www/www6s/download    Four files (id-abstract.txt, id-all.txt id-index.txt rfc-index.txt)
>     - /a/www/www6s/lou-berger-archive    Contains 260 Internet-drafts from 1997-2004        is ghostlinkd feeding from this? Why is it in such a different place?
>     - /a/www/www6s/proceedings    Active Proceedings storage directory        we should dive into this. "mail" is just a copy of a draft? Some of this is old, fully built out web content. Others is just artifact to support datataracker. Should separate these to make management clearer in the future.
>     - /a/www/www6s/status-report/imr    Current Status Report pages        Is this what's served at https://www.ietf.org/status-report/ietf-progress-report.html?
>     * /a/www/www6s/tool-id-archive    Cotains 88844 Internet-drafts 1992-2020        Are these used by ghostlinkd?
>     - /a/www/www6s/wg-descriptions    Contains 880 text files named for WGS from 2008-2012
>     - /a/www/wwws/enc    Public mount point for PGP public key and Draft signing bundle    Glen
>     - /a/www/wwws/images    Contains 89 image files 2004-2018     These are probably artifacts, though might think about them as statics. What uses them? Should they be in a directory that makes that more obvious?
> 
> -- 
> Tools-implementation mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-implementation