Subject: [Tools-implementation] webalizer views

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Aug 2020 09:09:29 -0500

Glen's survey of the filesystem pointed out that we stopped running 
webalizer over the web logs around the time of the server upgrade. At 
one point it looks like we had this running over the ftp logs as well. 
The earlier output for the datatracker is still available at 
https://datatracker.ietf.org/usagedata/. The runs we had over the 
website are no longer being served.

Now - nobody asked about these things, and even we didn't notice so 
there's a strong argument that they weren't being used at all so we 
could just take them completely down.

On the other hand, we do want to be more transparent and we set this up 
(and re-set this up IIRC) to support things like discussions around 
terminating the ftp service. That nobody is looking might be due more to 
the lack of making the pages discoverable than to a lack of interest or 
utility.

At some point there will need to be a concerted effort on identifying 
useful metrics for the services we're running  and making those metrics 
visible. It might make that conversation go better if these kinds of 
stats could already be seen?

Do we want to set this back up for now?

(Yes, it won't show anything about what was served from cloudflare - we 
can work on that separately).

RjS

---

From: Russ Housley <[email-masked]>
Date: Mon, 24 Aug 2020 10:16:42 -0400

I think we want this data.  Everytime that we put the Secretariat contract out for bid, we are asked for usage data.  This is a great way to avoid a special project to collect it.

Russ

> On Aug 24, 2020, at 10:09 AM, Robert Sparks <[email-masked]> wrote:
> 
> Glen's survey of the filesystem pointed out that we stopped running webalizer over the web logs around the time of the server upgrade. At one point it looks like we had this running over the ftp logs as well. The earlier output for the datatracker is still available at https://datatracker.ietf.org/usagedata/. The runs we had over the website are no longer being served.
> 
> Now - nobody asked about these things, and even we didn't notice so there's a strong argument that they weren't being used at all so we could just take them completely down.
> 
> On the other hand, we do want to be more transparent and we set this up (and re-set this up IIRC) to support things like discussions around terminating the ftp service. That nobody is looking might be due more to the lack of making the pages discoverable than to a lack of interest or utility.
> 
> At some point there will need to be a concerted effort on identifying useful metrics for the services we're running  and making those metrics visible. It might make that conversation go better if these kinds of stats could already be seen?
> 
> (Yes, it won't show anything about what was served from cloudflare - we can work on that separately).
> 
> RjS
> 
> -- 
> Tools-implementation mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-implementation