Subject: Re: [Tools-implementation] Dispatch for https://trac.tools.ietf.org/tools/ietfdb/ticket/2695

From: Robert Sparks <[email-masked]>
Date: Tue, 7 Jul 2020 15:17:01 -0500

Any opinions here? If you don't know enough to have an opinion, what 
information can I provide that would help?

RjS

On 6/30/20 5:29 PM, Robert Sparks wrote:
> Please read through https://trac.tools.ietf.org/tools/ietfdb/ticket/2695
>
> The key issue here is that, right now, we can't use markdown for 
> charters.
>
> To allow it, and keep the workflow similar to what we have now, we 
> would need to add controls to the form that lets the AD edit so the AD 
> can tell us if the charter is plain text or markdown.
>
> The alternative is to only allow uploads as Tom suggests. If I were an 
> AD that would irritate me mightily.
>
> It also might mean a model addition to keep the intended type (or some 
> surgery if we want to keep the type in a file extension).
>
> Consideration to diffs when things change from text to md need to be 
> considered. I suspect we diff text against md source (and md source 
> against md source for that kind of revision).
>
> What else am I missing?
>
> RjS
>

---

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 14 Jul 2020 12:25:11 +0100

Hi Robert,

On Tue, Jun 30, 2020, at 11:29 PM, Robert Sparks wrote:
> The key issue here is that, right now, we can't use markdown for charters.
> 
> To allow it, and keep the workflow similar to what we have now, we would 
> need to add controls to the form that lets the AD edit so the AD can 
> tell us if the charter is plain text or markdown.

Sounds reasonable.

> AD that would irritate me mightily.

If I were still an AD, that would have irritated me as well :-).

> surgery if we want to keep the type in a file extension).

Being able to flip between "this is text" and "this is markdown" would be useful.

> against md source for that kind of revision).

Yes, diffing should be straightforward. As markdown is mostly text, diffing it as such is sensible.

I hope the above was helpful!

> What else am I missing?

Best Regards,
Alexey