Subject: [Tools-implementation] next cut at automatic scheduling

From: Robert Sparks <[email-masked]>
Date: Wed, 17 Jun 2020 10:44:53 -0500

Sasha made some changes to make the constraints a bit more like what was 
really in place for 106. Attached is the result of an automated build.

Please comment on whether you think this would have been a good starting 
schedule for 106. (Russ, I'm particularly interested in your critique.)

RjS

---

From: Russ Housley <[email-masked]>
Date: Wed, 17 Jun 2020 11:47:19 -0400

> On Jun 17, 2020, at 11:44 AM, Robert Sparks <[email-masked]> wrote:
> 
> Sasha made some changes to make the constraints a bit more like what was really in place for 106. Attached is the result of an automated build.
> 
> Please comment on whether you think this would have been a good starting schedule for 106. (Russ, I'm particularly interested in your critique.)
> 

I will not be able to dig into this until Friday.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Wed, 17 Jun 2020 10:53:00 -0500

> I will not be able to dig into this until Friday.
Understood, and that's ok.

---

From: Russ Housley <[email-masked]>
Date: Fri, 19 Jun 2020 10:36:47 -0400

Robert:

Tuesday @ 17:10: cfrg, lake, and rats would be a problem.  Did lake say that cfrg was a conflict?

Wednesday @ 15:20: ace and acme would be a problem.  Did the people that need to be there reflect that?

Thursday @ 13:30: I suspect raw and roll are a problem; but one is fairly new and the other is fairly old, so I might be wrong.

Thursday @ 15:50: There is no SEC group this slot, but there are many doubled-up elsewhere.  Maybe a meta rule is needed to not double-up if possible.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Fri, 19 Jun 2020 10:17:06 -0500

> Tuesday @ 17:10: cfrg, lake, and rats would be a problem.  Did lake say that cfrg was a conflict?

Yes, as "technology overlap".

The generation you looked at didn't penalize technology overlap as much 
as it did chair and key participant conflict.

Here's another run with all three of those set to equal badness (attached)

> Wednesday @ 15:20: ace and acme would be a problem.  Did the people that need to be there reflect that?
ace did not list acme as any kind of conflict. Nor did acme list ace as 
any kind of conflict.
> Thursday @ 13:30: I suspect raw and roll are a problem; but one is fairly new and the other is fairly old, so I might be wrong.
ack
> Thursday @ 15:50: There is no SEC group this slot, but there are many doubled-up elsewhere.  Maybe a meta rule is needed to not double-up if possible.
That's an interesting idea.

---

From: Russ Housley <[email-masked]>
Date: Fri, 19 Jun 2020 14:42:41 -0400

Three IRTF sessions in the first slot would probably drive Colin bonkers.

Three SEC sessions in the second slot seems equally bad.

Three RTG sessions in the first slot on Tuesday seems equally bad.

Three SEC sessions in the first slot on Wednesday seems equally bad.

Three RTG sessions in the first slot on Thursday seems equally bad.

Three RTG sessions in the first slot on Friday seems equally bad.

So, the meta-rule seems important.  And, triple-up should be a last resort.

Russ

> On Jun 19, 2020, at 11:17 AM, Robert Sparks <[email-masked]> wrote:
> 
> 
> The generation you looked at didn't penalize technology overlap as much as it did chair and key participant conflict.
> 
> ace did not list acme as any kind of conflict. Nor did acme list ace as any kind of conflict.
>> 
> <Screenshot_2020-06-19 IETF 999 meeting agenda.png>-- 
> Tools-implementation mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-implementation

---

From: Robert Sparks <[email-masked]>
Date: Fri, 19 Jun 2020 13:57:45 -0500

> So, the meta-rule seems important.  And, triple-up should be a last resort.
So the rules engine works pair-wise right now. It would be adding a 
completely new concept to it to work with triplets (or more).

---

From: Russ Housley <[email-masked]>
Date: Fri, 19 Jun 2020 15:48:53 -0400

> On Jun 19, 2020, at 2:57 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> So the rules engine works pair-wise right now. It would be adding a completely new concept to it to work with triplets (or more).

Okay.  The avoid double-up meat rule should still be an improvement.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 22 Jun 2020 12:03:50 +0200

> completely new concept to it to work with triplets (or more).

It would, but I think it would only affect cost calculation of placing a
session in a certain slot, so the effect should be quite local inside the
placement cost calculation.  Conceptually it's quite a change, but if the
code effects are limited, that doesn't necessarily constitute a blocker,
I think?

	Henrik